aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:07:22 +0000
committerNiclas Zeising <zeising@FreeBSD.org>2019-11-06 18:07:22 +0000
commit82f108df3064ff3c1a1e2286a12f648d68dae4cd (patch)
treeb4d5bf951a26d05982f5c0f534d2f244ff41ae41 /multimedia
parent7be404eb3fcc6b1994712ba54ceb56f81ab474e5 (diff)
downloadports-82f108df3064ff3c1a1e2286a12f648d68dae4cd.tar.gz
ports-82f108df3064ff3c1a1e2286a12f648d68dae4cd.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/QtAV/Makefile2
-rw-r--r--multimedia/aegisub/Makefile4
-rw-r--r--multimedia/audacious-gtk3/Makefile2
-rw-r--r--multimedia/audacious-plugins-gtk3/Makefile2
-rw-r--r--multimedia/audacious-plugins/Makefile2
-rw-r--r--multimedia/audacious/Makefile2
-rw-r--r--multimedia/avidemux/Makefile.common4
-rw-r--r--multimedia/butt/Makefile2
-rw-r--r--multimedia/ccextractor/Makefile2
-rw-r--r--multimedia/cheese/Makefile4
-rw-r--r--multimedia/cinelerra-gg/Makefile6
-rw-r--r--multimedia/clutter-gst/Makefile2
-rw-r--r--multimedia/dvbcut/Makefile2
-rw-r--r--multimedia/fxtv/Makefile2
-rw-r--r--multimedia/gmerlin/Makefile2
-rw-r--r--multimedia/gmtk/Makefile2
-rw-r--r--multimedia/gnome-mplayer/Makefile2
-rw-r--r--multimedia/gnome-twitch/Makefile2
-rw-r--r--multimedia/gstreamer-plugins-good/Makefile1
-rw-r--r--multimedia/gstreamer-plugins/Makefile1
-rw-r--r--multimedia/gstreamer1-plugins/Makefile.common3
-rw-r--r--multimedia/gstreamer1-vaapi/Makefile2
-rw-r--r--multimedia/kaffeine/Makefile2
-rw-r--r--multimedia/kmplayer/Makefile2
-rw-r--r--multimedia/kodi/Makefile5
-rw-r--r--multimedia/libav/Makefile4
-rw-r--r--multimedia/libcec/Makefile1
-rw-r--r--multimedia/libquicktime/Makefile3
-rw-r--r--multimedia/libva-vdpau-driver/Makefile2
-rw-r--r--multimedia/libvdpau-va-gl/Makefile2
-rw-r--r--multimedia/libvdpau/Makefile2
-rw-r--r--multimedia/libxine/Makefile4
-rw-r--r--multimedia/minitube/Makefile2
-rw-r--r--multimedia/mlt-qt5/Makefile2
-rw-r--r--multimedia/mlt/Makefile2
-rw-r--r--multimedia/mpc-qt/Makefile2
-rw-r--r--multimedia/mpeg_play/Makefile2
-rw-r--r--multimedia/mythtv/Makefile3
-rw-r--r--multimedia/phonon-gstreamer/Makefile2
-rw-r--r--multimedia/py-qt5-multimedia/Makefile2
-rw-r--r--multimedia/py-qt5-multimediawidgets/Makefile2
-rw-r--r--multimedia/qt5-multimedia/Makefile2
-rw-r--r--multimedia/recordmydesktop/Makefile1
-rw-r--r--multimedia/simplescreenrecorder/Makefile2
-rw-r--r--multimedia/smplayer/Makefile2
-rw-r--r--multimedia/totem/Makefile2
-rw-r--r--multimedia/vdr-plugin-xineliboutput/Makefile2
-rw-r--r--multimedia/winff/Makefile2
-rw-r--r--multimedia/xanim/Makefile2
-rw-r--r--multimedia/xawtv/Makefile2
-rw-r--r--multimedia/xine/Makefile2
51 files changed, 68 insertions, 50 deletions
diff --git a/multimedia/QtAV/Makefile b/multimedia/QtAV/Makefile
index ee1e5ff3045c..ba79bf5da86e 100644
--- a/multimedia/QtAV/Makefile
+++ b/multimedia/QtAV/Makefile
@@ -16,7 +16,7 @@ LICENSE_FILE= ${WRKSRC}/lgpl-2.1.txt
LIB_DEPENDS= libass.so:multimedia/libass \
libavcodec.so:multimedia/ffmpeg
-USES= compiler:c++11-lang qmake:outsource qt:5
+USES= compiler:c++11-lang gl qmake:outsource qt:5 xorg
USE_GL= gl
USE_QT= core declarative gui network opengl sql widgets \
buildtools_build qmake_build
diff --git a/multimedia/aegisub/Makefile b/multimedia/aegisub/Makefile
index 0aabda068438..5d01d41ed999 100644
--- a/multimedia/aegisub/Makefile
+++ b/multimedia/aegisub/Makefile
@@ -23,8 +23,8 @@ LIB_DEPENDS= libboost_thread.so:devel/boost-libs \
libass.so:multimedia/libass \
libfontconfig.so:x11-fonts/fontconfig
-USES= compiler:c++11-lib desktop-file-utils gettext gmake iconv \
- localbase pkgconfig tar:xz
+USES= compiler:c++11-lib desktop-file-utils gettext gl gmake gnome \
+ iconv localbase pkgconfig tar:xz
USE_GNOME= intltool
USE_WX= 3.0
WX_CONF_ARGS= absolute
diff --git a/multimedia/audacious-gtk3/Makefile b/multimedia/audacious-gtk3/Makefile
index 0b3d581a033c..dfeb2d74ff9e 100644
--- a/multimedia/audacious-gtk3/Makefile
+++ b/multimedia/audacious-gtk3/Makefile
@@ -26,7 +26,7 @@ FILESDIR= ${MASTERDIR}/files
SUB_FILES= pkg-message
USES= autoreconf compiler:c++11-lib desktop-file-utils \
- gettext-tools gmake localbase pkgconfig
+ gettext-tools gmake gnome localbase pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= audacious-media-player
diff --git a/multimedia/audacious-plugins-gtk3/Makefile b/multimedia/audacious-plugins-gtk3/Makefile
index ced31d744389..6bbcafdd65ec 100644
--- a/multimedia/audacious-plugins-gtk3/Makefile
+++ b/multimedia/audacious-plugins-gtk3/Makefile
@@ -30,7 +30,7 @@ DISTINFO_FILE= ${.CURDIR}/distinfo
FILESDIR= ${MASTERDIR}/files
USES= autoreconf compiler:c++11-lib gettext-tools gmake gnome \
- iconv localbase pkgconfig
+ iconv localbase pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= audacious-media-player
diff --git a/multimedia/audacious-plugins/Makefile b/multimedia/audacious-plugins/Makefile
index 52d2dec6326d..b19be814877b 100644
--- a/multimedia/audacious-plugins/Makefile
+++ b/multimedia/audacious-plugins/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
RUN_DEPENDS= audacious:multimedia/audacious
USES= compiler:c++11-lib gettext-tools gmake gnome iconv \
- localbase pkgconfig tar:bzip2
+ localbase pkgconfig tar:bzip2 xorg
USE_GNOME= gtk20 glib20 libxml2 cairo gdkpixbuf2
USE_XORG= x11
diff --git a/multimedia/audacious/Makefile b/multimedia/audacious/Makefile
index 24e0c96d355d..7a8749d340f9 100644
--- a/multimedia/audacious/Makefile
+++ b/multimedia/audacious/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libfreetype.so:print/freetype2 \
libfontconfig.so:x11-fonts/fontconfig
USES= compiler:c++11-lib desktop-file-utils gettext-tools gmake \
- gnome localbase pkgconfig tar:bzip2
+ gnome localbase pkgconfig tar:bzip2 xorg
USE_XORG= x11 sm
USE_GNOME= gtk20 glib20 cairo
USE_LDCONFIG= yes
diff --git a/multimedia/avidemux/Makefile.common b/multimedia/avidemux/Makefile.common
index 0d62ef905b69..7c3eda6992f8 100644
--- a/multimedia/avidemux/Makefile.common
+++ b/multimedia/avidemux/Makefile.common
@@ -17,7 +17,7 @@ USE_GNOME= libxml2
OPTIONS_FILE= ${PORT_DBDIR}/${OPTIONS_NAME:C/-.*//}/options
-USES= cmake:noninja pkgconfig iconv gmake compiler:features sqlite
+USES= cmake:noninja pkgconfig iconv gmake gnome compiler:features sqlite
USES+= dos2unix
DOS2UNIX_FILES= cmake/admCheckMiscLibs.cmake \
avidemux_core/ADM_coreVideoCodec/include/ADM_coreVideoCodec6_export.h \
@@ -137,6 +137,7 @@ CMAKE_ARGS+= -DFONTCONFIG:BOOL=OFF
.if ${PORT_OPTIONS:MXVIDEO}
#LIB_DEPENDS+= Xv:x11/libXv
+USES+= xorg
USE_XORG+= xv
.else
CMAKE_ARGS+= -DXVIDEO:BOOL=OFF
@@ -199,6 +200,7 @@ PLIST_SUB+= XVID="@comment "
.endif
.if ${PORT_OPTIONS:MSDL}
+USES+= sdl
USE_SDL= sdl
PLIST_SUB+= SDL=""
.else
diff --git a/multimedia/butt/Makefile b/multimedia/butt/Makefile
index d46f9bd894ad..e2deea101c7a 100644
--- a/multimedia/butt/Makefile
+++ b/multimedia/butt/Makefile
@@ -24,7 +24,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
libsamplerate.so:audio/libsamplerate \
libvorbis.so:audio/libvorbis
-USES= autoreconf compiler:c++11-lang gmake jpeg pkgconfig
+USES= autoreconf compiler:c++11-lang gmake jpeg pkgconfig xorg
USE_XORG= x11 xrender xcursor xfixes xext xft xinerama
GNU_CONFIGURE= yes
diff --git a/multimedia/ccextractor/Makefile b/multimedia/ccextractor/Makefile
index 0018afc723a7..39c8bb9fb796 100644
--- a/multimedia/ccextractor/Makefile
+++ b/multimedia/ccextractor/Makefile
@@ -29,7 +29,7 @@ LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig \
libx265.so:multimedia/x265 \
libxvidcore.so:multimedia/xvid
-USES= cmake iconv localbase:ldflags pkgconfig
+USES= cmake iconv localbase:ldflags pkgconfig xorg
USE_GITHUB= yes
GH_ACCOUNT= CCExtractor
USE_XORG= x11
diff --git a/multimedia/cheese/Makefile b/multimedia/cheese/Makefile
index bfce36baa902..306137a2c15d 100644
--- a/multimedia/cheese/Makefile
+++ b/multimedia/cheese/Makefile
@@ -29,8 +29,8 @@ RUN_DEPENDS= gnome-video-effects>=0:graphics/gnome-video-effects
PORTSCOUT= limitw:1,even
-USES= gettext gmake gnome libtool localbase pathfix \
- pkgconfig tar:xz
+USES= gettext gl gmake gnome libtool localbase pathfix \
+ pkgconfig tar:xz xorg
USE_GNOME= cairo intlhack evolutiondataserver3 librsvg2 \
gnomedesktop3 libxml2:build introspection:build
USE_GL= egl
diff --git a/multimedia/cinelerra-gg/Makefile b/multimedia/cinelerra-gg/Makefile
index 131797a6e736..9619204f8f39 100644
--- a/multimedia/cinelerra-gg/Makefile
+++ b/multimedia/cinelerra-gg/Makefile
@@ -51,7 +51,8 @@ EXTRA_PATCHES= ${BUILD_WRKSRC}/blds/bsd.patch:-p1
REV= 502b6f3b6fd04f6b01c6d70dcb81aa304dd0db1c # git revision
-USES= autoreconf gettext-runtime gettext-tools gmake iconv:wchar_t jpeg localbase makeinfo python:2.7,build shebangfix
+USES= autoreconf gettext-runtime gettext-tools gmake iconv:wchar_t \
+ jpeg localbase makeinfo python:2.7,build shebangfix xorg
SHEBANG_GLOB= *.sh *.bld
GNU_CONFIGURE= yes
USE_XORG= x11 xau xdmcp xext xfixes xft xinerama xv
@@ -79,7 +80,7 @@ OPTIONS_SUB= yes
LV2_DESC= Use LV2 plugins
LV2_CONFIGURE_WITH= lv2
-LV2_USES= pkgconfig
+LV2_USES= gnome pkgconfig
LV2_USE= GNOME=atk,cairo,gdkpixbuf2,glib20,gtk20,pango
LV2_CFLAGS= -I${LOCALBASE}/include/lilv-0 -I${LOCALBASE}/include/suil-0
LV2_BUILD_DEPENDS= lv2>0:audio/lv2
@@ -90,6 +91,7 @@ LV2_LIB_DEPENDS= liblilv-0.so:audio/lilv \
libsuil-0.so:audio/suil
OPENGL_CONFIGURE_WITH= gl
+OPENGL_USES= gl
OPENGL_USE= GL=gl,glu
post-patch:
diff --git a/multimedia/clutter-gst/Makefile b/multimedia/clutter-gst/Makefile
index 149ca61b9e44..a54bcb01c04d 100644
--- a/multimedia/clutter-gst/Makefile
+++ b/multimedia/clutter-gst/Makefile
@@ -14,7 +14,7 @@ LIB_DEPENDS= libclutter-1.0.so:graphics/clutter
PORTSCOUT= ignore:1
-USES= gmake libtool localbase pathfix \
+USES= gl gmake gnome libtool localbase pathfix \
pkgconfig tar:xz xorg
USE_GNOME= introspection gnomeprefix
GNU_CONFIGURE= yes
diff --git a/multimedia/dvbcut/Makefile b/multimedia/dvbcut/Makefile
index 873c0320dc97..08da8793af5b 100644
--- a/multimedia/dvbcut/Makefile
+++ b/multimedia/dvbcut/Makefile
@@ -20,7 +20,7 @@ LIB_DEPENDS= liba52.so:audio/liba52 \
libavutil.so:multimedia/ffmpeg
RUN_DEPENDS:= ${BUILD_DEPENDS}
-USES= compiler:c++11-lang desktop-file-utils pkgconfig \
+USES= compiler:c++11-lang desktop-file-utils gl pkgconfig \
qmake:outsource qt:5 shared-mime-info
USE_QT= core gui widgets xml buildtools_build linguisttools_build
diff --git a/multimedia/fxtv/Makefile b/multimedia/fxtv/Makefile
index 4fd9121b587b..b4d9c68f149e 100644
--- a/multimedia/fxtv/Makefile
+++ b/multimedia/fxtv/Makefile
@@ -17,7 +17,7 @@ ONLY_FOR_ARCHS= amd64 i386
LIB_DEPENDS= libtiff.so:graphics/tiff \
libXaw3d.so:x11-toolkits/Xaw3d
-USES= gmake jpeg tar:tgz
+USES= gmake jpeg tar:tgz xorg
MAKE_ENV= X11BASE=${LOCALBASE}
USE_XORG= ice sm x11 xaw xext xmu xt xpm xxf86vm xxf86dga
MAKE_FLAGS= -e
diff --git a/multimedia/gmerlin/Makefile b/multimedia/gmerlin/Makefile
index fd3780da4397..534c8f332545 100644
--- a/multimedia/gmerlin/Makefile
+++ b/multimedia/gmerlin/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libexif.so:graphics/libexif \
libgavl.so:multimedia/gavl \
libfontconfig.so:x11-fonts/fontconfig
-USES= gettext libtool makeinfo pathfix pkgconfig sqlite
+USES= gettext gl gnome libtool makeinfo pathfix pkgconfig sqlite xorg
USE_GNOME= gtk20 libxml2
USE_XORG= x11 xext xfixes xinerama xv
USE_GL= gl
diff --git a/multimedia/gmtk/Makefile b/multimedia/gmtk/Makefile
index d4c79f377767..111d78255f3a 100644
--- a/multimedia/gmtk/Makefile
+++ b/multimedia/gmtk/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2
BUILD_DEPENDS= p5-XML-Parser>0:textproc/p5-XML-Parser
-USES= gettext gmake libtool pathfix perl5 pkgconfig
+USES= gettext gmake gnome libtool pathfix perl5 pkgconfig xorg
USE_XORG= x11
USE_GNOME= glib20 intltool
USE_PERL5= build
diff --git a/multimedia/gnome-mplayer/Makefile b/multimedia/gnome-mplayer/Makefile
index 528da1fadcc7..a15b34700dbe 100644
--- a/multimedia/gnome-mplayer/Makefile
+++ b/multimedia/gnome-mplayer/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libdbus-glib-1.so:devel/dbus-glib \
libgmtk.so:multimedia/gmtk
RUN_DEPENDS= mplayer:multimedia/mplayer
-USES= desktop-file-utils gettext gmake pkgconfig
+USES= desktop-file-utils gettext gmake gnome pkgconfig xorg
USE_XORG= x11 xscrnsaver
USE_GNOME= glib20
GNU_CONFIGURE= yes
diff --git a/multimedia/gnome-twitch/Makefile b/multimedia/gnome-twitch/Makefile
index c0c7d5a6e76e..95ab62264df6 100644
--- a/multimedia/gnome-twitch/Makefile
+++ b/multimedia/gnome-twitch/Makefile
@@ -19,7 +19,7 @@ LIB_DEPENDS= libjson-glib-1.0.so:devel/json-glib \
libwebkit2gtk-4.0.so:www/webkit2-gtk3
USES= compiler:c11 gettext gnome meson pkgconfig python:3.5+,build \
- tar:xz
+ tar:xz xorg
USE_GITHUB= yes
USE_LDCONFIG= yes
USE_GNOME= gtk30
diff --git a/multimedia/gstreamer-plugins-good/Makefile b/multimedia/gstreamer-plugins-good/Makefile
index 14b86d571732..f0133bfe856d 100644
--- a/multimedia/gstreamer-plugins-good/Makefile
+++ b/multimedia/gstreamer-plugins-good/Makefile
@@ -15,6 +15,7 @@ MASTERDIR= ${.CURDIR}/../../multimedia/gstreamer-plugins
BUILD_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:multimedia/gstreamer-plugins
RUN_DEPENDS+= gstreamer-plugins>=${GST_VERSION}${GST_MINOR_VERSION}:multimedia/gstreamer-plugins
+USES+= xorg
USE_XORG+= xdamage
gst_good_DIST= good
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 1b7e30312f81..5f0ac196fa3f 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -72,6 +72,7 @@ PLIST_SUB+= I386="@comment "
gst_base_DIST= base
NO_GSTREAMER_COMMON= yes
USE_LDCONFIG= yes
+USES+= xorg
USE_XORG= x11 xv xext xorgproto
PLIST_SUB+= VERSION="${VERSION}" \
SHLIB_VERSION="${SHLIB_VERSION}"
diff --git a/multimedia/gstreamer1-plugins/Makefile.common b/multimedia/gstreamer1-plugins/Makefile.common
index acd68e209e42..ecc27d8761f0 100644
--- a/multimedia/gstreamer1-plugins/Makefile.common
+++ b/multimedia/gstreamer1-plugins/Makefile.common
@@ -328,6 +328,7 @@ gst_libmms_LIB_DEPENDS= libmms.so:net/libmms
gst_libmms_PLIST_FILES= ${GST_LIB_DIR}/libgstmms.so
# librfb
+gst_librfb_USES= xorg
gst_librfb_USE_XORG= x11
# liblv2
@@ -490,6 +491,7 @@ gst_webrtcdsp_LIB_DEPENDS= libwebrtc_audio_processing.so:audio/webrtc-audio-proc
# X ximage and xvimage sinks aka output
.if ${DIST} == base
+gst_x_USES= xorg
gst_x_USE_XORG= x11 xv xext
gst_x_CONFIGURE_ARGS= --enable-xvideo --enable-xshm
gst_x_GST_PLUGIN_DIR= sys/ximage sys/xvimage
@@ -499,6 +501,7 @@ gst_x_PLIST_FILES= ${GST_LIB_DIR}/libgstximagesink.so \
.if ${DIST} == good
# Ximagesrc
+gst_x_USES= xorg
gst_x_USE_XORG= x11 xfixes xdamage xext
gst_x_CONFIGURE_ARGS= --enable-x
gst_x_GST_PLUGIN_DIR= sys/ximage
diff --git a/multimedia/gstreamer1-vaapi/Makefile b/multimedia/gstreamer1-vaapi/Makefile
index 6453d6ddb248..da4de2952f29 100644
--- a/multimedia/gstreamer1-vaapi/Makefile
+++ b/multimedia/gstreamer1-vaapi/Makefile
@@ -17,7 +17,7 @@ LIB_DEPENDS= libva.so:multimedia/libva
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
-USES= compiler:c11 gettext-runtime gmake gnome libtool \
+USES= compiler:c11 gettext-runtime gl gmake gnome libtool \
pkgconfig tar:xz xorg
USE_LDCONFIG= yes
USE_GNOME= glib20
diff --git a/multimedia/kaffeine/Makefile b/multimedia/kaffeine/Makefile
index a66545cc421d..f666a797d222 100644
--- a/multimedia/kaffeine/Makefile
+++ b/multimedia/kaffeine/Makefile
@@ -18,7 +18,7 @@ LIB_DEPENDS= libvlc.so:multimedia/vlc \
libdvbv5.so:multimedia/libv4l
USES= cmake compiler:c++11-lang cpe desktop-file-utils gettext \
- pkgconfig kde:5 qt:5 tar:xz
+ pkgconfig kde:5 qt:5 tar:xz xorg
USE_KDE= auth bookmarks codecs completion config configwidgets \
coreaddons i18n itemviews kio solid dbusaddons jobwidgets \
service widgetsaddons windowsystem xmlgui
diff --git a/multimedia/kmplayer/Makefile b/multimedia/kmplayer/Makefile
index b257a3faf8db..8c595d3f643f 100644
--- a/multimedia/kmplayer/Makefile
+++ b/multimedia/kmplayer/Makefile
@@ -30,7 +30,7 @@ LIB_DEPENDS= libdbus-1.so:devel/dbus \
RUN_DEPENDS= mplayer:multimedia/mplayer
USES= cmake compiler:c++11-lang desktop-file-utils gettext-runtime \
- kde:5 pkgconfig qt:5
+ gnome kde:5 pkgconfig qt:5 xorg
USE_GNOME= cairo gdkpixbuf2 gtk20
USE_QT= concurrent core dbus gui network phonon4 printsupport \
svg widgets x11extras xml \
diff --git a/multimedia/kodi/Makefile b/multimedia/kodi/Makefile
index 563171155af4..ae9bae7add25 100644
--- a/multimedia/kodi/Makefile
+++ b/multimedia/kodi/Makefile
@@ -61,8 +61,8 @@ LIB_DEPENDS= libass.so:multimedia/libass \
libyajl.so:devel/yajl
RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR}
-USES= autoreconf:build compiler:c++11-lib gettext gmake iconv jpeg \
- libtool pkgconfig python:-2.7 ssl
+USES= autoreconf:build compiler:c++11-lib gettext gmake gnome iconv \
+ jpeg libtool pkgconfig python:-2.7 ssl
KODI_ARCH_i386= x86
KODI_ARCH_amd64=x86_64
@@ -194,6 +194,7 @@ BUILD_DEPENDS+= gtk-update-icon-cache:x11-toolkits/gtk20
LIB_DEPENDS+= libdrm.so:graphics/libdrm
RUN_DEPENDS+= glxinfo:graphics/mesa-demos \
xdpyinfo:x11/xdpyinfo
+USES+= gl sdl xorg
USE_XORG= x11 xcb xext xmu xrandr xt xtst
USE_GL= egl gl glu glew
USE_SDL= image sdl2
diff --git a/multimedia/libav/Makefile b/multimedia/libav/Makefile
index 9897ada9edae..509e59fb94bf 100644
--- a/multimedia/libav/Makefile
+++ b/multimedia/libav/Makefile
@@ -20,7 +20,8 @@ LIB_DEPENDS= libopencv_core.so:graphics/opencv-core \
libvdpau.so:multimedia/libvdpau \
libhogweed.so:security/nettle
-USES= cpe compiler:c++11-lang gmake localbase perl5 pkgconfig tar:xz
+USES= cpe compiler:c++11-lang gmake localbase perl5 pkgconfig tar:xz \
+ xorg
USE_XORG= x11
USE_PERL5= build
@@ -127,6 +128,7 @@ RTMP_CONFIGURE_ENABLE= librtmp
SCHROEDINGER_LIB_DEPENDS= libschroedinger-1.0.so:multimedia/schroedinger
SCHROEDINGER_CONFIGURE_ENABLE= libschroedinger
+SDL_USES= sdl
SDL_USE= SDL=sdl
SDL_CONFIGURE_ENABLE= avplay
diff --git a/multimedia/libcec/Makefile b/multimedia/libcec/Makefile
index 0b222554962f..5ad7a3de1b56 100644
--- a/multimedia/libcec/Makefile
+++ b/multimedia/libcec/Makefile
@@ -52,6 +52,7 @@ CMAKE_ARGS+= -DSKIP_PYTHON_WRAPPER:BOOL=true
.endif
.if ${PORT_OPTIONS:MX11}
+USES+= xorg
USE_XORG= x11 xorgproto xrandr
.endif
diff --git a/multimedia/libquicktime/Makefile b/multimedia/libquicktime/Makefile
index bea8e2f06b33..8c500624364b 100644
--- a/multimedia/libquicktime/Makefile
+++ b/multimedia/libquicktime/Makefile
@@ -25,6 +25,7 @@ LIBS+= -L${LOCALBASE}/lib -lintl
INSTALL_TARGET= install-strip
.if !defined(_BUILDING_LIBQUICKTIME_PLUGINS)
+USES+= xorg
USE_XORG= xaw xv
CONFIGURE_ARGS= --with-x --enable-gpl --without-doxygen --without-lame
@@ -48,6 +49,7 @@ CONFIGURE_ARGS+= --without-cpuflags
.if !defined(_BUILDING_LIBQUICKTIME_PLUGINS)
.if ${PORT_OPTIONS:MGTK2}
+USES+= gnome
USE_GNOME+= gtk20
CONFIGURE_ARGS+= --with-gtk
.else
@@ -61,6 +63,7 @@ CONFIGURE_ARGS+= --without-alsa
.endif
.if ${PORT_OPTIONS:MOPENGL}
+USES+= gl
USE_GL= yes
CONFIGURE_ARGS+= --with-opengl
.else
diff --git a/multimedia/libva-vdpau-driver/Makefile b/multimedia/libva-vdpau-driver/Makefile
index b9ca35e0baa7..3d6667577963 100644
--- a/multimedia/libva-vdpau-driver/Makefile
+++ b/multimedia/libva-vdpau-driver/Makefile
@@ -17,7 +17,7 @@ BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/libva.pc:multimedia/libva \
${LOCALBASE}/include/linux/videodev2.h:multimedia/v4l_compat
LICENSE_FILE_GPLv2= ${WRKSRC}/COPYING
-USES= libtool gmake localbase pkgconfig tar:bzip2
+USES= libtool gl gmake localbase pkgconfig tar:bzip2
USE_GL= gl
GNU_CONFIGURE= yes
diff --git a/multimedia/libvdpau-va-gl/Makefile b/multimedia/libvdpau-va-gl/Makefile
index 758f9377b067..84a0c976b878 100644
--- a/multimedia/libvdpau-va-gl/Makefile
+++ b/multimedia/libvdpau-va-gl/Makefile
@@ -22,7 +22,7 @@ LIB_DEPENDS= libva-x11.so:multimedia/libva
USE_GITHUB= yes
GH_ACCOUNT= i-rinat
-USES= cmake compiler:c++11-lang pkgconfig
+USES= cmake compiler:c++11-lang gl pkgconfig xorg
USE_XORG= x11
USE_GL= gl
LDFLAGS+= -Wl,--as-needed # Xext, ICE, SM
diff --git a/multimedia/libvdpau/Makefile b/multimedia/libvdpau/Makefile
index 032deaa9300f..cc5f12489eeb 100644
--- a/multimedia/libvdpau/Makefile
+++ b/multimedia/libvdpau/Makefile
@@ -12,7 +12,7 @@ COMMENT= VDPAU wrapper and tracing library
LICENSE= MIT
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= autoreconf libtool pkgconfig tar:xz
+USES= autoreconf libtool pkgconfig tar:xz xorg
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-documentation
USE_XORG= xorgproto xext
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 26ac95111747..406ef5497102 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -39,8 +39,8 @@ LIB_DEPENDS= libFLAC.so:audio/flac \
libogg.so:audio/libogg \
libdvdnav.so:multimedia/libdvdnav
-USES= compiler cpe gmake gnome iconv libtool:keepla jpeg \
- localbase pathfix perl5 pkgconfig tar:xz
+USES= compiler cpe gl gmake gnome iconv libtool:keepla jpeg \
+ localbase pathfix perl5 pkgconfig sdl tar:xz xorg
LLD_UNSAFE= yes
CPE_PRODUCT= xine-lib
CPE_VENDOR= xine
diff --git a/multimedia/minitube/Makefile b/multimedia/minitube/Makefile
index 8f2145637a0e..d3c1745fff49 100644
--- a/multimedia/minitube/Makefile
+++ b/multimedia/minitube/Makefile
@@ -11,7 +11,7 @@ COMMENT= TV-like client for YouTube
LICENSE= GPLv3+
LICENSE_FILE= ${WRKSRC}/COPYING
-USES= compiler:c++11-lang qmake qt:5
+USES= compiler:c++11-lang gl qmake qt:5
USE_GITHUB= yes
GH_ACCOUNT= flaviotordini
USE_GL= gl
diff --git a/multimedia/mlt-qt5/Makefile b/multimedia/mlt-qt5/Makefile
index f1be17e4092f..6f66a7014fe0 100644
--- a/multimedia/mlt-qt5/Makefile
+++ b/multimedia/mlt-qt5/Makefile
@@ -2,7 +2,7 @@
PORTREVISION= 0
-USES= qt:5
+USES= qt:5 xorg
USE_CXXSTD= c++11
USE_QT= core gui svg widgets xml
USE_XORG= x11
diff --git a/multimedia/mlt/Makefile b/multimedia/mlt/Makefile
index b233a13763a1..c7e985312ea3 100644
--- a/multimedia/mlt/Makefile
+++ b/multimedia/mlt/Makefile
@@ -38,7 +38,7 @@ USE_GL= gl
USE_GNOME= libxml2
USE_SDL= image2
USE_XORG= x11
-USES+= gl iconv pathfix
+USES+= gl iconv pathfix xorg
PATHFIX_MAKEFILEIN= Makefile
CONFIGURE_ARGS+=--disable-qt --swig-languages=none
USE_LDCONFIG= yes
diff --git a/multimedia/mpc-qt/Makefile b/multimedia/mpc-qt/Makefile
index 5b47d616a58b..a8bdd4c0b6e3 100644
--- a/multimedia/mpc-qt/Makefile
+++ b/multimedia/mpc-qt/Makefile
@@ -19,7 +19,7 @@ GH_ACCOUNT= wm4 # mirror
GH_TAGNAME= 4bf2ca5
GH_TUPLE= Argon-:mpv-stats:1.1-28-gf42aa68:mpv_stats/external/mpv-stats
-USES= compiler:c++14-lang desktop-file-utils pkgconfig qmake qt:5
+USES= compiler:c++14-lang desktop-file-utils gl pkgconfig qmake qt:5
USE_QT= qmake_build buildtools_build linguisttools_build \
core dbus gui network svg_run widgets x11extras
USE_GL= gl
diff --git a/multimedia/mpeg_play/Makefile b/multimedia/mpeg_play/Makefile
index 1bc06ec4e2e9..9f2f19c9344b 100644
--- a/multimedia/mpeg_play/Makefile
+++ b/multimedia/mpeg_play/Makefile
@@ -16,7 +16,7 @@ NOT_FOR_ARCHS= aarch64 armv6 armv7 mips mips64
NOT_FOR_ARCHS_REASON= fails to build: Unknown endianness of architecture
WRKSRC= ${WRKDIR}/mpeg_play
-USES= imake
+USES= imake xorg
USE_XORG= x11 xext
PLIST_FILES= bin/mpeg_play \
diff --git a/multimedia/mythtv/Makefile b/multimedia/mythtv/Makefile
index 85cfa28adaf8..477e0cb29b55 100644
--- a/multimedia/mythtv/Makefile
+++ b/multimedia/mythtv/Makefile
@@ -38,7 +38,8 @@ LIB_DEPENDS= liblzo2.so:archivers/lzo2 \
BUILD_DEPENDS= yasm:devel/yasm \
${LOCALBASE}/include/linux/input.h:devel/evdev-proto
-USES= gmake gl iconv libtool pkgconfig pathfix qmake:no_env qt:5 ssl
+USES= gmake gl iconv libtool pkgconfig pathfix qmake:no_env qt:5 ssl \
+ xorg
USE_GITHUB= yes
GH_ACCOUNT= MythTV
USE_GL= gl
diff --git a/multimedia/phonon-gstreamer/Makefile b/multimedia/phonon-gstreamer/Makefile
index 386807d30689..ec98ff71bc5e 100644
--- a/multimedia/phonon-gstreamer/Makefile
+++ b/multimedia/phonon-gstreamer/Makefile
@@ -14,7 +14,7 @@ COMMENT= GStreamer backend for Phonon
LICENSE= LGPL21
-USES= cmake compiler:c++11-lang gl gnome kde:5 pkgconfig qt:5 tar:xz
+USES= cmake compiler:c++11-lang gl gnome kde:5 pkgconfig qt:5 tar:xz xorg
USE_GL= gl
USE_GNOME= glib20 libxml2
USE_GSTREAMER1= yes
diff --git a/multimedia/py-qt5-multimedia/Makefile b/multimedia/py-qt5-multimedia/Makefile
index 19b9b986ca80..b1c69ea8a150 100644
--- a/multimedia/py-qt5-multimedia/Makefile
+++ b/multimedia/py-qt5-multimedia/Makefile
@@ -12,7 +12,7 @@ RUN_DEPENDS= ${PY_ENUM34}
CONFIGURE_ARGS= --enable QtMultimedia
PYQT_DIST= yes
-USES= python pyqt:5 qt:5
+USES= gl python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run gui_run network_run
USE_PYTHON= concurrent flavors py3kplist
diff --git a/multimedia/py-qt5-multimediawidgets/Makefile b/multimedia/py-qt5-multimediawidgets/Makefile
index c838458e3868..5dc74784001c 100644
--- a/multimedia/py-qt5-multimediawidgets/Makefile
+++ b/multimedia/py-qt5-multimediawidgets/Makefile
@@ -12,7 +12,7 @@ RUN_DEPENDS= ${PY_ENUM34}
CONFIGURE_ARGS= --enable QtMultimediaWidgets
PYQT_DIST= yes
-USES= python pyqt:5 qt:5
+USES= gl python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run multimedia_run widgets_run
USE_PYTHON= concurrent flavors py3kplist
diff --git a/multimedia/qt5-multimedia/Makefile b/multimedia/qt5-multimedia/Makefile
index 5e28ad19c084..9cc7c10c6a39 100644
--- a/multimedia/qt5-multimedia/Makefile
+++ b/multimedia/qt5-multimedia/Makefile
@@ -12,7 +12,7 @@ COMMENT= Qt audio, video, radio and camera support module
# LICENSE set via USES_QT5 (bsd.qt.mk)
USES= compiler:c++11-lang gl gnome pkgconfig openal qmake:norecursive \
- qt-dist:5,multimedia
+ qt-dist:5,multimedia xorg
USE_GL= gl
USE_GNOME= glib20
USE_QT= core declarative gui network opengl widgets \
diff --git a/multimedia/recordmydesktop/Makefile b/multimedia/recordmydesktop/Makefile
index e392a9a9240e..e805a5001904 100644
--- a/multimedia/recordmydesktop/Makefile
+++ b/multimedia/recordmydesktop/Makefile
@@ -16,6 +16,7 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS+= --enable-oss=yes \
--enable-jack=yes
+USES= xorg
USE_XORG= ice sm x11 xext xorgproto xfixes xdamage
PLIST_FILES= bin/recordmydesktop man/man1/recordmydesktop.1.gz
diff --git a/multimedia/simplescreenrecorder/Makefile b/multimedia/simplescreenrecorder/Makefile
index d1d964a32d39..bc3a00f9b1f1 100644
--- a/multimedia/simplescreenrecorder/Makefile
+++ b/multimedia/simplescreenrecorder/Makefile
@@ -15,7 +15,7 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libasound.so:audio/alsa-lib \
libavformat.so:multimedia/ffmpeg
-USES= cmake compiler:c++11-lang pkgconfig qt:5
+USES= cmake compiler:c++11-lang pkgconfig qt:5 xorg
USE_GITHUB= yes
GH_ACCOUNT= MaartenBaert
GH_PROJECT= ssr
diff --git a/multimedia/smplayer/Makefile b/multimedia/smplayer/Makefile
index 964b515c2520..c0922043dbe0 100644
--- a/multimedia/smplayer/Makefile
+++ b/multimedia/smplayer/Makefile
@@ -13,7 +13,7 @@ LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/Copying.txt
USES= cpe compiler:c++11-lang desktop-file-utils dos2unix gmake \
- qmake qt:5 tar:bzip2
+ qmake qt:5 tar:bzip2 xorg
USE_QT= buildtools_build linguisttools_build \
core dbus gui network script widgets xml
USE_XORG= x11
diff --git a/multimedia/totem/Makefile b/multimedia/totem/Makefile
index 449b13ec928e..28f65b6fc630 100644
--- a/multimedia/totem/Makefile
+++ b/multimedia/totem/Makefile
@@ -38,7 +38,7 @@ RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:misc/iso-codes \
PORTSCOUT= limitw:1,even
USES= compiler desktop-file-utils gettext gl gnome localbase meson \
- pkgconfig python:3.4+ tar:xz
+ pkgconfig python:3.4+ tar:xz xorg
USE_GNOME= cairo gtk30 intlhack introspection libxml2 nautilus3 \
pygobject3
USE_XORG= x11 xorgproto xtst ice sm
diff --git a/multimedia/vdr-plugin-xineliboutput/Makefile b/multimedia/vdr-plugin-xineliboutput/Makefile
index 6c4072d2c347..4c6ad6351e28 100644
--- a/multimedia/vdr-plugin-xineliboutput/Makefile
+++ b/multimedia/vdr-plugin-xineliboutput/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libxine.so:multimedia/libxine \
libvdpau.so:multimedia/libvdpau
PATCH_STRIP= -p1
-USES= compiler:c++11-lang pkgconfig tar:bzip2
+USES= compiler:c++11-lang gl pkgconfig tar:bzip2 xorg
USE_XORG= xrandr xrender
HAS_CONFIGURE= yes
CONFIGURE_ARGS= --cc="${CC}" --cxx="${CXX}" --add-cflags=-I${VDRDIR}
diff --git a/multimedia/winff/Makefile b/multimedia/winff/Makefile
index 3eca8e9d0af5..55271750e639 100644
--- a/multimedia/winff/Makefile
+++ b/multimedia/winff/Makefile
@@ -18,8 +18,8 @@ LICENSE= GPLv3
LIB_DEPENDS= libavutil.so:multimedia/ffmpeg
+USES= fpc lazarus:flavors xorg
USE_XORG= x11
-USES= fpc lazarus:flavors
USE_FPC= chm fcl-base fcl-image fcl-json fcl-xml pasjpeg regexpr x11
NO_WRKSUBDIR= yes
diff --git a/multimedia/xanim/Makefile b/multimedia/xanim/Makefile
index 4b4faa04bc86..499cd1595865 100644
--- a/multimedia/xanim/Makefile
+++ b/multimedia/xanim/Makefile
@@ -18,7 +18,7 @@ NO_CDROM= Must be redistributed without fee
# clang's cpp destroys whitespace, particularly hard tabs in makefiles,
# which is fatal for imake.
-USES= alias imake
+USES= alias imake xorg
USE_GCC= any
USE_XORG= xext xt sm ice xext x11
MAKE_ARGS+= -j 2 # safe and helps even the single-CPU machines
diff --git a/multimedia/xawtv/Makefile b/multimedia/xawtv/Makefile
index 285fc78509a5..0364390810be 100644
--- a/multimedia/xawtv/Makefile
+++ b/multimedia/xawtv/Makefile
@@ -18,7 +18,7 @@ OPTIONS_DEFINE_i386= MMX
OPTIONS_DEFAULT= AALIB
ZVBI_DESC= Enable libzvbi support
-USES= gmake iconv jpeg motif ncurses perl5 tar:bzip2 pkgconfig
+USES= gmake iconv jpeg motif ncurses perl5 tar:bzip2 pkgconfig xorg
GNU_CONFIGURE= yes
USE_XORG= x11 xaw
CPPFLAGS+= -I${WRKSRC}/common
diff --git a/multimedia/xine/Makefile b/multimedia/xine/Makefile
index 71f46a6b328a..11d3f37b668e 100644
--- a/multimedia/xine/Makefile
+++ b/multimedia/xine/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libpng.so:graphics/png \
libxine.so:multimedia/libxine
USES= desktop-file-utils gmake iconv jpeg pkgconfig readline \
- shared-mime-info tar:xz
+ shared-mime-info tar:xz xorg
USE_XORG= x11 xext xinerama xscrnsaver xt xtst xv xxf86vm
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --enable-vdr-keys \