aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2000-10-28 13:05:25 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2000-10-28 13:05:25 +0000
commita82e50a994f167dc21ab5d3949e6fff858d51939 (patch)
treea1776fae313ebb7a44d73896d3dceda959243a6a /multimedia
parentb121518905294737790136be3413b6e3aa2e69e0 (diff)
downloadports-a82e50a994f167dc21ab5d3949e6fff858d51939.tar.gz
ports-a82e50a994f167dc21ab5d3949e6fff858d51939.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpeg_encode/Makefile14
-rw-r--r--multimedia/mpeg_encode/files/patch-aa28
-rw-r--r--multimedia/mpeg_encode/files/patch-ab11
-rw-r--r--multimedia/mpeg_encode/files/patch-ac20
-rw-r--r--multimedia/mpeg_encode/files/patch-ad15
5 files changed, 57 insertions, 31 deletions
diff --git a/multimedia/mpeg_encode/Makefile b/multimedia/mpeg_encode/Makefile
index 3c879d391e41..2a3ca429062c 100644
--- a/multimedia/mpeg_encode/Makefile
+++ b/multimedia/mpeg_encode/Makefile
@@ -13,11 +13,19 @@ DISTNAME= ${PKGNAME}-src
MAINTAINER= ports@FreeBSD.org
-USE_GMAKE= yes
MAN1= mpeg_encode.1
-MANCOMPRESSED= yes
-WRKSRC= ${WRKDIR}/mpeg_encode
+WRKSRC= ${WRKDIR}/${PORTNAME}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/mpeg_encode ${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/docs/mpeg_encode.1 ${PREFIX}/man/man1
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${PREFIX}/share/doc/${PORTNAME}
+.for i in users-guide.ps template.param
+ ${INSTALL_DATA} ${WRKSRC}/docs/${i} ${PREFIX}/share/doc/${PORTNAME}
+.endfor
+.endif
.include <bsd.port.mk>
diff --git a/multimedia/mpeg_encode/files/patch-aa b/multimedia/mpeg_encode/files/patch-aa
index b626b85d037c..c4d2f537b154 100644
--- a/multimedia/mpeg_encode/files/patch-aa
+++ b/multimedia/mpeg_encode/files/patch-aa
@@ -13,31 +13,3 @@
#if !defined(sco) && !defined(sgi) && !defined(IRIX)
extern char* malloc();
#endif
---- ./libpnmrw.c~ Thu Aug 1 08:52:14 1996
-+++ ./libpnmrw.c Thu Aug 1 08:51:26 1996
-@@ -126,7 +126,9 @@
- pm_perror( reason )
- char* reason;
- {
-+#ifndef __FreeBSD__
- extern char* sys_errlist[];
-+#endif
- extern int errno;
- char* e;
-
---- Makefile~ Wed Aug 16 17:16:56 1995
-+++ Makefile Thu Aug 1 09:00:04 1996
-@@ -182,6 +182,13 @@
-
- all: mpeg_encode
-
-+install:
-+ install -c mpeg_encode ${PREFIX}/bin
-+ install -c -m 644 mpeg_encode.1 ${PREFIX}/man/man1
-+ gzip -9nf ${PREFIX}/man/man1/mpeg_encode.1
-+ mkdir -p ${PREFIX}/share/doc/mpeg_encode
-+ install -c docs/users-guide.ps docs/template.param ${PREFIX}/share/doc/mpeg_encode
-+
- #########
- # TESTS #
- #########
diff --git a/multimedia/mpeg_encode/files/patch-ab b/multimedia/mpeg_encode/files/patch-ab
new file mode 100644
index 000000000000..5af9c672ec4a
--- /dev/null
+++ b/multimedia/mpeg_encode/files/patch-ab
@@ -0,0 +1,11 @@
+--- ./libpnmrw.c~ Thu Aug 1 08:52:14 1996
++++ ./libpnmrw.c Thu Aug 1 08:51:26 1996
+@@ -126,7 +126,9 @@
+ pm_perror( reason )
+ char* reason;
+ {
++#ifndef __FreeBSD__
+ extern char* sys_errlist[];
++#endif
+ extern int errno;
+ char* e;
diff --git a/multimedia/mpeg_encode/files/patch-ac b/multimedia/mpeg_encode/files/patch-ac
new file mode 100644
index 000000000000..4760ecb9ecfc
--- /dev/null
+++ b/multimedia/mpeg_encode/files/patch-ac
@@ -0,0 +1,20 @@
+--- Makefile~ Wed Aug 16 17:16:56 1995
++++ Makefile Fri Oct 20 19:20:05 2000
+@@ -68,7 +68,7 @@
+ #####################################################################
+ # COMPILER # specify compiler; should be ANSI-compliant if possible #
+ #####################################################################
+-CC = gcc
++CC ?= gcc
+
+ ################################################
+ # MAKE # command to use for the "make" command #
+@@ -96,7 +96,7 @@
+ #
+
+ # gcc
+-CFLAGS = $(INCLUDEDIR) $(DEBUGFLAG) -Wall -Wmissing-prototypes $(PROFLAG) $(PROTOFLAG)
++CFLAGS += $(INCLUDEDIR) -Wall -Wmissing-prototypes $(PROFLAG) $(PROTOFLAG)
+
+ # gcc-strict
+ #CFLAGS = $(INCLUDEDIR) $(DEBUGFLAG) -pedantic -Wall -Waggregate-return -Wtraditional -Wshadow -Wpointer-arith -Wno-parentheses -Wwrite-strings -Wconversion -Wcast-qual -Wcast-align -Wnested-externs -Wuninitialized -Wmissing-prototypes $(PROFLAG) $(PROTOFLAG)
diff --git a/multimedia/mpeg_encode/files/patch-ad b/multimedia/mpeg_encode/files/patch-ad
new file mode 100644
index 000000000000..22085cdd4bec
--- /dev/null
+++ b/multimedia/mpeg_encode/files/patch-ad
@@ -0,0 +1,15 @@
+--- jpeg/Makefile.orig Fri Aug 4 18:27:00 1995
++++ jpeg/Makefile Fri Oct 20 19:05:22 2000
+@@ -21,10 +21,10 @@
+ manext = 1
+
+ # The name of your C compiler:
+-CC= gcc
++CC?= gcc
+
+ # You may need to adjust these cc options:
+-CFLAGS= -O -I$(srcdir)
++CFLAGS+= -I$(srcdir)
+ # Generally, we recommend defining any configuration symbols in jconfig.h,
+ # NOT via -D switches here.
+ # However, any special defines for ansi2knr.c may be included here: