aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-14 02:08:17 +0000
committerMario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>2005-12-14 02:08:17 +0000
commitdae3e0ec5ff8c6a7637d6b538f1d7a9993dce713 (patch)
treef24deeb35373cb0be95f507b102fcd93cfb88c7b /multimedia
parentab0202def34ab31224fc3b332329308145af647f (diff)
downloadports-dae3e0ec5ff8c6a7637d6b538f1d7a9993dce713.tar.gz
ports-dae3e0ec5ff8c6a7637d6b538f1d7a9993dce713.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/dvdwizard/Makefile73
-rw-r--r--multimedia/dvdwizard/distinfo3
-rw-r--r--multimedia/dvdwizard/pkg-descr16
4 files changed, 93 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 67bd12f3f748..3c728adb3a3e 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -21,6 +21,7 @@
SUBDIR += dvdauthor
SUBDIR += dvdrip
SUBDIR += dvdstyler
+ SUBDIR += dvdwizard
SUBDIR += dvts
SUBDIR += emovix
SUBDIR += enjoympeg
diff --git a/multimedia/dvdwizard/Makefile b/multimedia/dvdwizard/Makefile
new file mode 100644
index 000000000000..2cdcda5c09d1
--- /dev/null
+++ b/multimedia/dvdwizard/Makefile
@@ -0,0 +1,73 @@
+# New ports collection makefile for: dvdwizard
+# Date created: Fri Dec 9 03:01:18 UTC 2005
+# Whom: Mario Sergio Fujikawa Ferreira <lioux@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= dvdwizard
+PORTVERSION= 0.4.1
+CATEGORIES= multimedia
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
+MASTER_SITE_SUBDIR= udrecsuite
+DISTNAME= udrec_suite-${PORTVERSION}
+
+MAINTAINER= lioux@FreeBSD.org
+COMMENT= Automated creation of DVDs with chapters and menus
+
+RUN_DEPENDS= \
+ toolame:${PORTSDIR}/audio/toolame \
+ convert:${PORTSDIR}/graphics/ImageMagick \
+ seq2:${PORTSDIR}/misc/seq2 \
+ dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
+ spumux:${PORTSDIR}/multimedia/dvdauthor \
+ mpeg2enc:${PORTSDIR}/multimedia/mjpegtools \
+ ppmtoy4m:${PORTSDIR}/multimedia/mjpegtools \
+ transcode:${PORTSDIR}/multimedia/transcode \
+ bash:${PORTSDIR}/shells/bash
+
+USE_REINPLACE= yes
+NO_BUILD= yes
+WRKSRC= ${WRKDIR}/${DISTNAME}/${PORTNAME}
+
+SCRIPT_FILES= \
+ chaptercheck \
+ dvdcpics \
+ dvdtguess \
+ dvdwizard \
+ mk_vmgm \
+ mk_vtsm \
+ mk_vtsm_audio \
+ mpgprobe
+
+PLIST_DIR= \
+ %%DATADIR%% \
+ %%EXAMPLESDIR%%
+PLIST_FILES= \
+ ${SCRIPT_FILES:S,^,bin/,} \
+ %%DATADIR%%/dvdwizardrc \
+ %%EXAMPLESDIR%%/dvdwizard.conf.sample
+
+post-patch:
+ @${REINPLACE_CMD} -E \
+ -e 's|/bin/bash|${LOCALBASE}/bin/bash|' \
+ -e 's|^(rcfile[[:space:]]*=).*$$|\1"${DATADIR}/dvdwizardrc"|' \
+ -e 's|\(seq |(${LOCALBASE}/bin/seq2 |' \
+ -e 's|`seq |`${LOCALBASE}/bin/seq2 |' \
+ ${WRKSRC}/*
+
+do-install:
+# script
+.for script in ${SCRIPT_FILES}
+ @${INSTALL_SCRIPT} ${WRKSRC}/${script} ${PREFIX}/bin
+.endfor
+# examples
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/dvdwizard.conf.sample \
+ ${EXAMPLESDIR}
+# shared data
+ @${MKDIR} ${DATADIR}
+ @${INSTALL_DATA} ${WRKSRC}/dvdwizardrc \
+ ${DATADIR}
+
+.include <bsd.port.mk>
diff --git a/multimedia/dvdwizard/distinfo b/multimedia/dvdwizard/distinfo
new file mode 100644
index 000000000000..8a64485978d8
--- /dev/null
+++ b/multimedia/dvdwizard/distinfo
@@ -0,0 +1,3 @@
+MD5 (udrec_suite-0.4.1.tar.gz) = 375fab1573379da4bb1e6c748732e5e3
+SHA256 (udrec_suite-0.4.1.tar.gz) = d20e85c792d2fee3942c09d8ce6fdd3df31ca22ef96e403f695ca2544e72fe51
+SIZE (udrec_suite-0.4.1.tar.gz) = 1725883
diff --git a/multimedia/dvdwizard/pkg-descr b/multimedia/dvdwizard/pkg-descr
new file mode 100644
index 000000000000..64a236706fb7
--- /dev/null
+++ b/multimedia/dvdwizard/pkg-descr
@@ -0,0 +1,16 @@
+[ excerpt from distfile's README with modifications ]
+
+dvdwizard is a wrapper-script which incorporates a fully automated
+creation of a DVD-structure with Chapters and menus from one or
+more mpeg-streams. This is done by several "sub-scripts" and various
+freely available tools.
+
+A lot of things have changed since the initial version. It is now
+possible to author multiple titlesets at once, PAL or NTSC is
+supported. If the movie has more than one audio stream, an audio
+selection menu will be shown, languages of audio tracks are now
+freely customizable. Also, a configuration file has been introduced.
+
+WWW: http://udrecsuite.sourceforge.net/
+
+-- lioux@FreeBSD.org