aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorWilliam Grzybowski <wg@FreeBSD.org>2013-10-09 01:54:21 +0000
committerWilliam Grzybowski <wg@FreeBSD.org>2013-10-09 01:54:21 +0000
commitddef80a87d6385132e8527ac82a6e985074d6645 (patch)
treee8d6e1537a8e980bf8502bf12b4773f500d61ecb /multimedia
parent53718280e85e136a2684359a6cc2a47641ee5d2f (diff)
downloadports-ddef80a87d6385132e8527ac82a6e985074d6645.tar.gz
ports-ddef80a87d6385132e8527ac82a6e985074d6645.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mpeg4ip/Makefile8
-rw-r--r--multimedia/mpeg4ip/files/patch-configure24
-rw-r--r--multimedia/mpeg4ip/files/patch-server-mp4live-Makefile.in27
3 files changed, 52 insertions, 7 deletions
diff --git a/multimedia/mpeg4ip/Makefile b/multimedia/mpeg4ip/Makefile
index e95107649c8f..d0bb74c86957 100644
--- a/multimedia/mpeg4ip/Makefile
+++ b/multimedia/mpeg4ip/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= faac:${PORTSDIR}/audio/faac \
id3tag:${PORTSDIR}/audio/libid3tag \
a52:${PORTSDIR}/audio/liba52 \
mpeg2:${PORTSDIR}/multimedia/libmpeg2 \
- avcodec:${PORTSDIR}/multimedia/ffmpeg \
+ libavcodec0.so:${PORTSDIR}/multimedia/ffmpeg0 \
x264:${PORTSDIR}/multimedia/x264
RUN_DEPENDS= mp4v2>=1.9.1:${PORTSDIR}/multimedia/mp4v2
@@ -30,8 +30,8 @@ USE_SDL= sdl
USE_GMAKE= yes
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-CPPFLAGS+= -I${LOCALBASE}/include/SDL -I${LOCALBASE}/include/ffmpeg -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
-LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
+CPPFLAGS+= -I${LOCALBASE}/include/SDL -I${LOCALBASE}/include/ffmpeg0 -I${LOCALBASE}/include ${PTHREAD_CFLAGS}
+LDFLAGS+= -L${LOCALBASE}/lib/ffmpeg0 -L${LOCALBASE}/lib ${PTHREAD_LIBS}
CONFIGURE_ARGS= --enable-ffmpeg=${LOCALBASE} \
--enable-mp4live \
--disable-static
@@ -165,7 +165,7 @@ pre-configure:
${WRKSRC}/doc/mp4v2/Makefile.in
# objformat
@${FIND} ${WRKSRC} -name configure | ${XARGS} ${REINPLACE_CMD} -e 's|echo aout|echo elf|'
- @${REINPLACE_CMD} -e 's|$${enable_ffmpeg}/lib/libavcodec.a|-lavcodec -lswscale|g' \
+ @${REINPLACE_CMD} -e 's|$${enable_ffmpeg}/lib/libavcodec.a|-lavcodec0 -lswscale0|g' \
${WRKSRC}/configure
# replace bundled mp4v2 with placeholder
diff --git a/multimedia/mpeg4ip/files/patch-configure b/multimedia/mpeg4ip/files/patch-configure
index bf06ac088aa1..ae82fc99c1e7 100644
--- a/multimedia/mpeg4ip/files/patch-configure
+++ b/multimedia/mpeg4ip/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2010-12-09 12:24:43.000000000 -0800
-+++ configure 2010-12-09 12:25:28.000000000 -0800
+--- configure.orig 2007-10-08 12:11:23.000000000 -0300
++++ configure 2013-10-08 22:35:24.628157749 -0300
@@ -24544,13 +24544,12 @@
fi
@@ -31,8 +31,26 @@
echo "$as_me: have enable ffmpeg $enable_ffmpeg" >&6;}
- FFMPEG_INC=-I${enable_ffmpeg}/libavcodec
- FFMPEG_LIB="${enable_ffmpeg}/libavcodec/libavcodec.a -lz"
-+ FFMPEG_INC=-I${enable_ffmpeg}/include/ffmpeg
++ FFMPEG_INC=-I${enable_ffmpeg}/include/ffmpeg0
+ FFMPEG_LIB="${enable_ffmpeg}/lib/libavcodec.a -lz"
saveCFLAGS="$CFLAGS"
CFLAGS="$CFLAGS $FFMPEG_INC"
{ echo "$as_me:$LINENO: checking for AVRational" >&5
+@@ -26613,7 +26610,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <avcodec.h>
++#include <libavcodec/avcodec.h>
+
+ int
+ main ()
+@@ -27008,7 +27005,7 @@
+ cat confdefs.h >>conftest.$ac_ext
+ cat >>conftest.$ac_ext <<_ACEOF
+ /* end confdefs.h. */
+-#include <ffmpeg/avcodec.h>
++#include <libavcodec/avcodec.h>
+
+ int
+ main ()
diff --git a/multimedia/mpeg4ip/files/patch-server-mp4live-Makefile.in b/multimedia/mpeg4ip/files/patch-server-mp4live-Makefile.in
new file mode 100644
index 000000000000..34d3f938fde6
--- /dev/null
+++ b/multimedia/mpeg4ip/files/patch-server-mp4live-Makefile.in
@@ -0,0 +1,27 @@
+--- server/mp4live/Makefile.in.orig 2007-10-08 12:11:18.000000000 -0300
++++ server/mp4live/Makefile.in 2013-10-08 22:45:00.417159508 -0300
+@@ -122,18 +122,18 @@
+ DEFAULT_INCLUDES = -I. -I$(srcdir) -I$(top_builddir)
+ depcomp = $(SHELL) $(top_srcdir)/depcomp
+ am__depfiles_maybe = depfiles
+-COMPILE = $(CC) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+- $(CPPFLAGS) $(AM_CFLAGS) $(CFLAGS)
++COMPILE = $(CC) $(DEFS) $(CPPFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
++ $(AM_CFLAGS) $(CFLAGS)
+ LTCOMPILE = $(LIBTOOL) --tag=CC --mode=compile $(CC) $(DEFS) \
+- $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
++ $(CPPFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(AM_CFLAGS) $(CFLAGS)
+ CCLD = $(CC)
+ LINK = $(LIBTOOL) --tag=CC --mode=link $(CCLD) $(AM_CFLAGS) $(CFLAGS) \
+ $(AM_LDFLAGS) $(LDFLAGS) -o $@
+-CXXCOMPILE = $(CXX) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
+- $(AM_CPPFLAGS) $(CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
++CXXCOMPILE = $(CXX) $(DEFS) $(CPPFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) \
++ $(AM_CPPFLAGS) $(AM_CXXFLAGS) $(CXXFLAGS)
+ LTCXXCOMPILE = $(LIBTOOL) --tag=CXX --mode=compile $(CXX) $(DEFS) \
+- $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) $(CPPFLAGS) \
++ $(CPPFLAGS) $(DEFAULT_INCLUDES) $(INCLUDES) $(AM_CPPFLAGS) \
+ $(AM_CXXFLAGS) $(CXXFLAGS)
+ CXXLD = $(CXX)
+ CXXLINK = $(LIBTOOL) --tag=CXX --mode=link $(CXXLD) $(AM_CXXFLAGS) \