aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2006-03-18 15:37:46 +0000
committerPav Lucistnik <pav@FreeBSD.org>2006-03-18 15:37:46 +0000
commit057187dfc8d6084d42e82a4328d6aafd478c0300 (patch)
tree6d2423d1bc84d29f493f79ae0a2538d2cc288717 /multimedia
parentbf347166b68416bdf218658b64e2a4f03d4685ee (diff)
downloadports-057187dfc8d6084d42e82a4328d6aafd478c0300.tar.gz
ports-057187dfc8d6084d42e82a4328d6aafd478c0300.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/dvd-slideshow/Makefile9
-rw-r--r--multimedia/dvd-slideshow/files/patch-dvd-slideshow27
2 files changed, 33 insertions, 3 deletions
diff --git a/multimedia/dvd-slideshow/Makefile b/multimedia/dvd-slideshow/Makefile
index a34d60aaed0e..5ee259d2c8e8 100644
--- a/multimedia/dvd-slideshow/Makefile
+++ b/multimedia/dvd-slideshow/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dvd-slideshow
PORTVERSION= 0.7.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE_EXTENDED}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -21,10 +21,10 @@ RUN_DEPENDS= bash:${PORTSDIR}/shells/bash \
ffmpeg:${PORTSDIR}/multimedia/ffmpeg \
sox:${PORTSDIR}/audio/sox \
dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
- mkisofs:${PORTSDIR}/sysutils/cdrtools
+ mkisofs:${PORTSDIR}/sysutils/cdrtools \
+ ${X11BASE}/lib/X11/fonts/urwfonts-ttf/README:${PORTSDIR}/x11-fonts/urwfonts-ttf
NO_BUILD= yes
-USE_REINPLACE= yes
OPTIONS= DVDRWTOOLS "Needed to record/burn DVD" off \
LAME "Optional support for audio" off \
@@ -77,6 +77,9 @@ post-patch:
.for FILE in dvd-slideshow dvd-menu dir2slideshow gallery2slideshow jigl2slideshow
@${REINPLACE_CMD} -e 's|!/bin/bash|!${PREFIX}/bin/bash|g' ${WRKSRC}/${FILE}
.endfor
+.for FILE in dvd-menu dvd-slideshow
+ @${REINPLACE_CMD} -e 's|/usr/share/fonts/|${X11BASE}/lib/X11/fonts/|' ${WRKSRC}/${FILE}
+.endfor
do-build:
# nada. NO_BUILD does not work if no OPTION is selected. see PR 78436
diff --git a/multimedia/dvd-slideshow/files/patch-dvd-slideshow b/multimedia/dvd-slideshow/files/patch-dvd-slideshow
index de110c2cbaed..bd1729e204ad 100644
--- a/multimedia/dvd-slideshow/files/patch-dvd-slideshow
+++ b/multimedia/dvd-slideshow/files/patch-dvd-slideshow
@@ -1,5 +1,32 @@
--- dvd-slideshow.orig Fri Dec 30 04:21:02 2005
+++ dvd-slideshow Fri Dec 30 04:25:22 2005
+@@ -738,7 +738,7 @@
+ minutes=`echo $1 | cut -d: -f2`
+ seconds=`echo $1 | cut -d: -f3 | cut -d. -f1`
+ fraction=`echo $1 | cut -d: -f3 | cut -d. -f2`
+- characters=`echo "$fraction" | wc --chars`
++ characters=`echo "$fraction" | wc -m`
+ if [ "$characters" -eq 1 ] ; then ## no decimal was specified
+ duration_ms="0"
+ elif [ "$characters" -eq 2 ] ; then ## 1 decimal was specified
+@@ -982,7 +982,7 @@
+ duration_sec=`echo $1 | awk -F. '{ print $1 }'`
+ if [ -z "$duration_sec" ] ; then duration_sec=0 ; fi
+ duration_hu=`echo $1 | awk -F. '{ print $2 }'`
+- characters=`echo "$duration_hu" | wc --chars`
++ characters=`echo "$duration_hu" | wc -m`
+ if [ "$characters" -eq 1 ] ; then
+ ## no decimal was specified
+ duration_hu=0
+@@ -1010,7 +1010,7 @@
+ duration_sec=`echo $1 | awk -F. '{ print $1 }'`
+ if [ -z "$duration_sec" ] ; then duration_sec=0 ; fi
+ duration_ms=`echo $1 | awk -F. '{ print $2 }'`
+- characters=`echo "$duration_ms" | wc --chars`
++ characters=`echo "$duration_ms" | wc -m`
+ if [ "$characters" -eq 1 ] ; then
+ ## no decimal was specified
+ duration_ms=0
@@ -2051,7 +2051,7 @@
audio_inside_txtfile=0
imagefiles=0 ; moviefiles=0 ; audiofiles=0