aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorBruce M Simpson <bms@FreeBSD.org>2008-09-02 14:08:07 +0000
committerBruce M Simpson <bms@FreeBSD.org>2008-09-02 14:08:07 +0000
commitdb0301d2abbf4032a04046a84320b739adc496b3 (patch)
tree7d140e79d67414f4354a66b8de2161143e44096c /multimedia
parent051c15341e1b707df93d91dcc682582dbca6a0c6 (diff)
downloadports-db0301d2abbf4032a04046a84320b739adc496b3.tar.gz
ports-db0301d2abbf4032a04046a84320b739adc496b3.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/spook/Makefile69
-rw-r--r--multimedia/spook/distinfo3
-rw-r--r--multimedia/spook/files/patch-bswap.h14
-rw-r--r--multimedia/spook/files/patch-configure.ac11
-rw-r--r--multimedia/spook/files/patch-input-oss.c14
-rw-r--r--multimedia/spook/files/patch-md5.c14
-rw-r--r--multimedia/spook/files/patch-tcp.c11
-rw-r--r--multimedia/spook/files/pkg-message.in5
-rw-r--r--multimedia/spook/pkg-descr9
10 files changed, 151 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 5686146714c8..e908a5934243 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -218,6 +218,7 @@
SUBDIR += smplayer
SUBDIR += smplayer-themes
SUBDIR += spigot
+ SUBDIR += spook
SUBDIR += streamanalyze
SUBDIR += streamdvd
SUBDIR += subconv
diff --git a/multimedia/spook/Makefile b/multimedia/spook/Makefile
new file mode 100644
index 000000000000..a1c8dcd82b76
--- /dev/null
+++ b/multimedia/spook/Makefile
@@ -0,0 +1,69 @@
+# New ports collection makefile for: spook
+# Date created: 1 Sep 2008
+# Whom: Bruce M Simpson <bms@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= spook
+PORTVERSION= 20050207
+CATEGORIES= multimedia
+MASTER_SITES= http://www.litech.org/spook/dist/
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= bms@FreeBSD.org
+COMMENT= Embedded RTP/RTSP/HTTP video streamer
+
+# TODO: FireWire IIDC support (needs libraw1394, libdc1394).
+# TODO: Test with Luigi-ified V4L input drivers e.g. pwc, etc.
+
+OPTIONS= \
+ JPEG "With JPEG encoding support" on \
+ MPEG4 "With MPEG4 encoding support" off \
+ V4L "With V4L input support" on
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+
+GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf:262 aclocal:18 automake:18
+
+NOMAN= defined
+
+SUB_FILES= pkg-message
+
+CONFIGURE_ENV+= CFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+
+.include <bsd.port.pre.mk>
+
+.if !defined(WITHOUT_JPEG)
+LIB_DEPENDS+= jpeg.9:${PORTSDIR}/graphics/jpeg
+CONFIGURE_ARGS+= --enable-encoder-jpeg
+.endif
+
+.if defined(WITH_MPEG4)
+LIB_DEPENDS+= xvidcore.4:${PORTSDIR}/multimedia/xvid
+CONFIGURE_ARGS+= --enable-encoder-mpeg4
+.endif
+
+.if !defined(WITHOUT_V4L)
+BUILD_DEPENDS+= ${LOCALBASE}/include/linux/videodev.h:${PORTSDIR}/multimedia/v4l_compat
+CONFIGURE_ARGS+= --enable-input-v4l
+.endif
+
+PLIST_FILES= bin/spook bin/spookctl etc/spook.conf.dist
+
+.if !defined(NOPORTDOCS)
+PORTDOCS= README
+.endif
+
+do-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
+.endif
+ ${INSTALL_PROGRAM} ${WRKSRC}/spook ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/spookctl ${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/spook.conf.dist ${PREFIX}/etc
+
+.include <bsd.port.post.mk>
diff --git a/multimedia/spook/distinfo b/multimedia/spook/distinfo
new file mode 100644
index 000000000000..fe48ae7cc3fc
--- /dev/null
+++ b/multimedia/spook/distinfo
@@ -0,0 +1,3 @@
+MD5 (spook-20050207.tar.bz2) = b99d55cb9b2170e4a8d592021205e1a0
+SHA256 (spook-20050207.tar.bz2) = ddc91a8034f05cfd5637026a4d0a1a0e8b039df7cdf34d54b98d5bf6615ebc1f
+SIZE (spook-20050207.tar.bz2) = 160378
diff --git a/multimedia/spook/files/patch-bswap.h b/multimedia/spook/files/patch-bswap.h
new file mode 100644
index 000000000000..c1f566fe1e51
--- /dev/null
+++ b/multimedia/spook/files/patch-bswap.h
@@ -0,0 +1,14 @@
+--- bswap.h.orig 2008-09-02 14:40:15.000000000 +0100
++++ bswap.h 2008-09-02 14:41:51.000000000 +0100
+@@ -6,7 +6,11 @@
+ #ifndef __BSWAP_H__
+ #define __BSWAP_H__
+
++#ifdef __FreeBSD__
++#include <sys/endian.h>
++#else
+ #include <endian.h>
++#endif
+ #if __BYTE_ORDER == __BIG_ENDIAN
+ #define WORDS_BIGENDIAN
+ #endif
diff --git a/multimedia/spook/files/patch-configure.ac b/multimedia/spook/files/patch-configure.ac
new file mode 100644
index 000000000000..f93668ce8d08
--- /dev/null
+++ b/multimedia/spook/files/patch-configure.ac
@@ -0,0 +1,11 @@
+--- configure.ac.orig 2008-09-02 14:40:15.000000000 +0100
++++ configure.ac 2008-09-02 14:41:51.000000000 +0100
+@@ -55,7 +55,7 @@
+ [enable_encoder_jpeg=auto])
+
+ case $host in
+- *-*-linux*)
++ *-*-linux*|*freebsd*)
+ if test x$enable_input_vdig = xyes; then
+ AC_MSG_ERROR([QuickTime digitizer support is only available on Mac OS X])
+ fi
diff --git a/multimedia/spook/files/patch-input-oss.c b/multimedia/spook/files/patch-input-oss.c
new file mode 100644
index 000000000000..090bb1a6dabf
--- /dev/null
+++ b/multimedia/spook/files/patch-input-oss.c
@@ -0,0 +1,14 @@
+--- input-oss.c.orig 2008-09-02 14:40:15.000000000 +0100
++++ input-oss.c 2008-09-02 14:41:52.000000000 +0100
+@@ -28,7 +28,11 @@
+ #include <errno.h>
+ #include <pthread.h>
+
++#ifdef __FreeBSD__
++#include <sys/soundcard.h>
++#else
+ #include <linux/soundcard.h>
++#endif
+
+ #include <event.h>
+ #include <log.h>
diff --git a/multimedia/spook/files/patch-md5.c b/multimedia/spook/files/patch-md5.c
new file mode 100644
index 000000000000..508f09c0773f
--- /dev/null
+++ b/multimedia/spook/files/patch-md5.c
@@ -0,0 +1,14 @@
+--- md5.c.orig 2008-09-02 14:40:15.000000000 +0100
++++ md5.c 2008-09-02 14:41:52.000000000 +0100
+@@ -21,7 +21,11 @@
+ #include <string.h>
+ #include <sys/types.h>
+
++#ifdef __FreeBSD__
++#include <machine/endian.h>
++#else
+ #include <endian.h>
++#endif
+ #if __BYTE_ORDER == __BIG_ENDIAN
+ #define WORDS_BIGENDIAN
+ #endif
diff --git a/multimedia/spook/files/patch-tcp.c b/multimedia/spook/files/patch-tcp.c
new file mode 100644
index 000000000000..ccff178d71f9
--- /dev/null
+++ b/multimedia/spook/files/patch-tcp.c
@@ -0,0 +1,11 @@
+--- tcp.c.orig 2008-09-02 14:40:15.000000000 +0100
++++ tcp.c 2008-09-02 14:41:53.000000000 +0100
+@@ -454,7 +454,7 @@
+ strerror( errno ) );
+
+ i = 1;
+- if( setsockopt( fd, SOL_TCP, TCP_NODELAY, &i, sizeof( i ) ) < 0 )
++ if( setsockopt( fd, IPPROTO_TCP, TCP_NODELAY, &i, sizeof( i ) ) < 0 )
+ spook_log( SL_INFO, "error setting TCP_NODELAY on socket: %s",
+ strerror( errno ) );
+
diff --git a/multimedia/spook/files/pkg-message.in b/multimedia/spook/files/pkg-message.in
new file mode 100644
index 000000000000..c1782d5d7751
--- /dev/null
+++ b/multimedia/spook/files/pkg-message.in
@@ -0,0 +1,5 @@
+Please copy %%PREFIX%%/etc/spook.conf.dist to %%PREFIX%%/etc/spook.conf
+and edit before running spook.
+
+There is no daemonization support or rc script for spook yet,
+please feel free to contribute patches.
diff --git a/multimedia/spook/pkg-descr b/multimedia/spook/pkg-descr
new file mode 100644
index 000000000000..02b9905dca31
--- /dev/null
+++ b/multimedia/spook/pkg-descr
@@ -0,0 +1,9 @@
+Spook is a Linux server application to capture live video and audio
+and stream it over an IP network. Currently, Spook supports capturing
+from a Firewire IIDC camera or Video4Linux(2) source and streaming
+MPEG4 with RTSP or JPEG stills with HTTP.
+
+WWW: http://www.litech.org/spook/
+
+Bruce
+bms@FreeBSD.org