aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2017-12-05 18:53:42 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2017-12-05 18:53:42 +0000
commit17851dfda43dc8d538835d4d78bb72dde9a987ba (patch)
tree6e9546ccc4ac4bcba5721ac510323332b53f27ff /multimedia
parentb788e791fd1e6ac030c6e5483539c206e9d208ce (diff)
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/chilitags/Makefile31
-rw-r--r--multimedia/chilitags/distinfo3
-rw-r--r--multimedia/chilitags/pkg-descr13
4 files changed, 48 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 49499213e1b9..da0d2822a866 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -31,6 +31,7 @@
SUBDIR += ccextractor
SUBDIR += cclive
SUBDIR += cheese
+ SUBDIR += chilitags
SUBDIR += clipgrab
SUBDIR += clive
SUBDIR += clutter-gst
diff --git a/multimedia/chilitags/Makefile b/multimedia/chilitags/Makefile
new file mode 100644
index 000000000000..657295fac823
--- /dev/null
+++ b/multimedia/chilitags/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= chilitags
+DISTVERSION= 2.0.0-169
+DISTVERSIONSUFFIX= -g0d9854f
+CATEGORIES= multimedia
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Robust fiducial markers for augmented reality and robotics
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/gpl.txt
+
+LIB_DEPENDS= libopencv_imgproc.so:graphics/opencv-core \
+ libopencv_video.so:graphics/opencv
+
+USES= cmake:outsource
+USE_GITHUB= yes
+GH_ACCOUNT= chili-epfl
+USE_LDCONFIG= yes
+
+PLIST_FILES= bin/chilitags-creator \
+ include/chilitags/chilitags.hpp \
+ include/chilitags/chilitags_export.hpp \
+ lib/libchilitags.so \
+ libdata/pkgconfig/chilitags.pc
+
+post-install:
+ @${RM} ${STAGEDIR}${PREFIX}/lib/libchilitags_static.a
+
+.include <bsd.port.mk>
diff --git a/multimedia/chilitags/distinfo b/multimedia/chilitags/distinfo
new file mode 100644
index 000000000000..ab13d7d58508
--- /dev/null
+++ b/multimedia/chilitags/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1512448288
+SHA256 (chili-epfl-chilitags-2.0.0-169-g0d9854f_GH0.tar.gz) = b285023cf1e7ef203373409caad4316aaf0e4c2827acd8aa3b558b7b87ac8469
+SIZE (chili-epfl-chilitags-2.0.0-169-g0d9854f_GH0.tar.gz) = 188400
diff --git a/multimedia/chilitags/pkg-descr b/multimedia/chilitags/pkg-descr
new file mode 100644
index 000000000000..934fe0374553
--- /dev/null
+++ b/multimedia/chilitags/pkg-descr
@@ -0,0 +1,13 @@
+Chilitags are a C++ cross-platform software library for the detection and
+identification of 2D fiducial markers (a.k.a. tags). Their purpose is to be
+printed and placed on objects from the real world, to form the basis of
+Robotics or Augmented Reality (AR) applications. Using a camera, the position
+of the tagged objects can be acquired by a computer.
+
+Chilitags were developed by Pixar internally for projects of the CHILI lab
+(Computer-Human Interaction in Learning and Instruction, formerly CRAFT),
+such as Metroscope or TapaCarp. There are already many alternatives
+(e.g. ARToolKit, or reacTIVision, among many others), but we decided to
+release Chilitags anyway, as there seemed to be a demand for it.
+
+WWW: http://chili.epfl.ch/software