aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2017-04-08 13:49:13 +0000
committerThomas Zander <riggs@FreeBSD.org>2017-04-08 13:49:13 +0000
commit3f693cd21b0e3e1990eab6045dd6a46c0912ac22 (patch)
tree099815c3f84ab6f51bccac689aba3651e2b1b185 /multimedia
parentfa0298b095e434aa5aba7051d68fc0a933792f72 (diff)
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/handbrake/Makefile4
-rw-r--r--multimedia/handbrake/files/patch-make_configure.py9
2 files changed, 13 insertions, 0 deletions
diff --git a/multimedia/handbrake/Makefile b/multimedia/handbrake/Makefile
index 726490ff7615..708802beb9d1 100644
--- a/multimedia/handbrake/Makefile
+++ b/multimedia/handbrake/Makefile
@@ -3,6 +3,7 @@
PORTNAME= handbrake
PORTVERSION= 1.0.3
+PORTREVISION= 1
CATEGORIES= multimedia
DIST_SUBDIR= ${PORTNAME}
@@ -120,6 +121,9 @@ post-extract: .SILENT
${CP} ${DISTDIR}/${DIST_SUBDIR}/${f} ${WRKSRC}/download
.endfor
+#post-patch:
+# ${REINPLACE_CMD} -e 's|%%CC%%|${CC}|g' ${WRKSRC}/make/configure.py
+
post-install-X11-on:
${LN} -sf ghb ${STAGEDIR}${PREFIX}/bin/HandBrake
diff --git a/multimedia/handbrake/files/patch-make_configure.py b/multimedia/handbrake/files/patch-make_configure.py
index b08cd210e8d0..d83d15fedb4b 100644
--- a/multimedia/handbrake/files/patch-make_configure.py
+++ b/multimedia/handbrake/files/patch-make_configure.py
@@ -36,6 +36,15 @@
grp.add_option( '--flatpak', default=False, action='store_true', help=h )
cli.add_option_group( grp )
+@@ -1517,7 +1520,7 @@ try:
+ class Tools:
+ ar = ToolProbe( 'AR.exe', 'ar' )
+ cp = ToolProbe( 'CP.exe', 'cp' )
+- gcc = ToolProbe( 'GCC.gcc', 'gcc', IfHost( 'gcc-4', '*-*-cygwin*' ))
++ gcc = ToolProbe( 'GCC.gcc', 'gcc', IfHost( os.environ['CC'], '*-*-freebsd*' ))
+
+ if host.match( '*-*-darwin*' ):
+ gmake = ToolProbe( 'GMAKE.exe', 'make', 'gmake' )
@@ -1924,10 +1927,15 @@ int main()
doc.add( 'GCC.sysroot', '' )
doc.add( 'GCC.minver', '' )