aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2012-08-06 11:02:38 +0000
committerMartin Matuska <mm@FreeBSD.org>2012-08-06 11:02:38 +0000
commit474a3017073543a80ad99d9ff9b319ba4236e36e (patch)
tree5c978eb14c7c4849a9d7dfe854d65131d11dbb2e /multimedia
parent7ed27dcf6734cfff73bc694d566ce7aab1b7f505 (diff)
downloadports-474a3017073543a80ad99d9ff9b319ba4236e36e.tar.gz
ports-474a3017073543a80ad99d9ff9b319ba4236e36e.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpeg/Makefile21
1 files changed, 7 insertions, 14 deletions
diff --git a/multimedia/ffmpeg/Makefile b/multimedia/ffmpeg/Makefile
index 67145cc31fd8..ab6addaf7203 100644
--- a/multimedia/ffmpeg/Makefile
+++ b/multimedia/ffmpeg/Makefile
@@ -6,7 +6,7 @@
PORTNAME= ffmpeg
PORTVERSION= 0.7.13
-PORTREVISION= 4
+PORTREVISION= 5
PORTEPOCH= 1
CATEGORIES= multimedia audio ipv6 net
MASTER_SITES= http://ffmpeg.org/releases/
@@ -15,9 +15,8 @@ MAINTAINER= mm@FreeBSD.org
COMMENT= Realtime audio/video encoder/converter and streaming server
BUILD_DEPENDS= yasm:${PORTSDIR}/devel/yasm \
- ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils
-
-CONFLICTS= ffmpeg-20*
+ ${LOCALBASE}/bin/as:${PORTSDIR}/devel/binutils \
+ ${LOCALBASE}/bin/texi2html:${PORTSDIR}/textproc/texi2html
HAS_CONFIGURE= yes
CONFIGURE_LOG= config.err
@@ -25,6 +24,7 @@ USE_BZIP2= yes
USE_GMAKE= yes
MAKE_JOBS_SAFE= yes
WANT_SDL= yes
+USE_PERL5_BUILD= yes
OPTIONS_DEFINE= AACPLUS ALSA AMR_NB AMR_WB CELT DEBUG DIRAC FAAC \
FFSERVER FREETYPE FREI0R GSM LAME OPENCV OPENJPEG \
@@ -32,7 +32,7 @@ OPTIONS_DEFINE= AACPLUS ALSA AMR_NB AMR_WB CELT DEBUG DIRAC FAAC \
VDPAU VO_AACENC VO_AMRWBENC VORBIS VPX X11GRAB X264 XVID
OPTIONS_DEFAULT= FFSERVER FREETYPE FREI0R OPENCV SCHROEDINGER THEORA \
- VORBIS VPX X264 XVID
+ VORBIS VPX X264 XVID
FFSERVER_DESC= Build and install ffserver
X11GRAB_DESC= Enable x11 grabbing
@@ -64,18 +64,13 @@ COMPAT_HEADERS=libavcodec/avcodec.h \
libpostproc/postprocess.h \
libswscale/swscale.h
+MAN1+= ffmpeg.1 ffprobe.1
+
.include <bsd.port.options.mk>
# PORTDOCS
-.if ${PORT_OPTIONS:MDOCS}
-USE_PERL5_BUILD= yes
-BUILD_DEPENDS+= ${LOCALBASE}/bin/texi2html:${PORTSDIR}/textproc/texi2html
-MAN1+= ffmpeg.1 ffprobe.1
.if ${PORT_OPTIONS:MFFSERVER}
MAN1+= ffserver.1
-. endif
-.else
-CONFIGURE_ARGS+= --disable-doc
.endif
# rtmp
@@ -289,9 +284,7 @@ CONFIGURE_ARGS+= --disable-libschroedinger
.if ${PORT_OPTIONS:MSDL}
USE_SDL+= sdl
PLIST_FILES+= bin/ffplay
-.if ${PORT_OPTIONS:MDOCS}
MAN1+= ffplay.1
-.endif
.else
CONFIGURE_ARGS+= --disable-ffplay
.endif