aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-06-06 12:18:10 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-06-06 12:18:10 +0000
commitbe0a85132202af5035c7e51623348aa22ffa9aa3 (patch)
tree8f7e3c3c76490cf174b3b3bac48afddcd3f15dfa /multimedia
parent1a7ae785a97cae8fd14f7a08c80b98598b17f8a3 (diff)
downloadports-be0a85132202af5035c7e51623348aa22ffa9aa3.tar.gz
ports-be0a85132202af5035c7e51623348aa22ffa9aa3.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/Makefile1
-rw-r--r--multimedia/dvdauthorwizard/Makefile38
-rw-r--r--multimedia/dvdauthorwizard/distinfo3
-rw-r--r--multimedia/dvdauthorwizard/pkg-descr6
-rw-r--r--multimedia/dvdauthorwizard/pkg-plist49
5 files changed, 97 insertions, 0 deletions
diff --git a/multimedia/Makefile b/multimedia/Makefile
index 8b7459c6f029..41d773f16682 100644
--- a/multimedia/Makefile
+++ b/multimedia/Makefile
@@ -25,6 +25,7 @@
SUBDIR += dvbcut
SUBDIR += dvd-slideshow
SUBDIR += dvdauthor
+ SUBDIR += dvdauthorwizard
SUBDIR += dvdrip
SUBDIR += dvdstyler
SUBDIR += dvts
diff --git a/multimedia/dvdauthorwizard/Makefile b/multimedia/dvdauthorwizard/Makefile
new file mode 100644
index 000000000000..c939de389de5
--- /dev/null
+++ b/multimedia/dvdauthorwizard/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: dvdauthorwizard
+# Date created: 30 May 2007
+# Whom: liu_yinghong@yahoo.com.cn
+#
+# $FreeBSD$
+#
+
+PORTNAME= dvdauthorwizard
+PORTVERSION= 1.4.6
+CATEGORIES= multimedia kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= DVDAuthorWizard-${PORTVERSION}
+
+MAINTAINER= liu_yinghong@yahoo.com.cn
+COMMENT= The tool for creating a DVD with fully animated menu from MPEG-2 files
+
+NO_BUILD= yes
+USE_BZIP2= yes
+REINPLACE_ARGS= -i ""
+
+RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash \
+ convert:${PORTSDIR}/graphics/ImageMagick \
+ dvdauthor:${PORTSDIR}/multimedia/dvdauthor \
+ png2yuv:${PORTSDIR}/multimedia/mjpegtools \
+ sox:${PORTSDIR}/audio/sox \
+ transcode:${PORTSDIR}/multimedia/transcode \
+ kdialog:${PORTSDIR}/x11/kdebase3
+
+do-patch:
+ @${REINPLACE_CMD} 's|/bin/bash|/bin/sh|' ${WRKSRC}/inst.sh
+ @${REINPLACE_CMD} 's|/bin/bash|/usr/local/bin/bash|' \
+ ${WRKSRC}/bin/DVDAuthorWizard-Builder.sh
+
+do-install:
+ @cd ${WRKSRC} && ${SH} inst.sh ${WRKSRC} ${LOCALBASE}
+
+.include <bsd.port.mk>
diff --git a/multimedia/dvdauthorwizard/distinfo b/multimedia/dvdauthorwizard/distinfo
new file mode 100644
index 000000000000..a6466b09eea7
--- /dev/null
+++ b/multimedia/dvdauthorwizard/distinfo
@@ -0,0 +1,3 @@
+MD5 (DVDAuthorWizard-1.4.6.tar.bz2) = 2998a159c515c6dd67b4da7af2810e52
+SHA256 (DVDAuthorWizard-1.4.6.tar.bz2) = 4c899eb0738d4ca1c0465193e7a0f8bd369a9446e7568621bf391a2fd06e3df3
+SIZE (DVDAuthorWizard-1.4.6.tar.bz2) = 576022
diff --git a/multimedia/dvdauthorwizard/pkg-descr b/multimedia/dvdauthorwizard/pkg-descr
new file mode 100644
index 000000000000..cf762c61f069
--- /dev/null
+++ b/multimedia/dvdauthorwizard/pkg-descr
@@ -0,0 +1,6 @@
+This wizard will create a DVD with fully animated menu
+from MPEG-2 files. It is designed to be very easy to use.
+All you need to do is add one or more files to the playlist
+and answer the questions that follow.
+
+WWW: http://dvdauthorwizard.sourceforge.net
diff --git a/multimedia/dvdauthorwizard/pkg-plist b/multimedia/dvdauthorwizard/pkg-plist
new file mode 100644
index 000000000000..e6fd17905224
--- /dev/null
+++ b/multimedia/dvdauthorwizard/pkg-plist
@@ -0,0 +1,49 @@
+bin/DVDAuthorWizard-Builder.sh
+bin/DVDAuthorWizard.kmdr
+share/applications/kde/KDVDAuthoringWizard.desktop
+share/apps/dvdauthorwizard/Pictures/DecoFilmroll.png
+share/apps/dvdauthorwizard/Pictures/DecoNone.png
+share/apps/dvdauthorwizard/Pictures/DecoSoftEdge.png
+share/apps/dvdauthorwizard/Pictures/Shadow1-1.png
+share/apps/dvdauthorwizard/Pictures/Shadow1-1Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow2-2.png
+share/apps/dvdauthorwizard/Pictures/Shadow2-2Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow3-3.png
+share/apps/dvdauthorwizard/Pictures/Shadow3-3Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow4-4.png
+share/apps/dvdauthorwizard/Pictures/Shadow4-4Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow5-5.png
+share/apps/dvdauthorwizard/Pictures/Shadow5-5Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-1.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-1Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-2.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-2Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-3.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-3Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-4.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-4Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-5.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-5Wide.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-6.png
+share/apps/dvdauthorwizard/Pictures/Shadow6-6Wide.png
+share/apps/dvdauthorwizard/Pictures/banner1.png
+share/apps/dvdauthorwizard/Pictures/dia.png
+share/apps/dvdauthorwizard/Pictures/diabig.png
+share/apps/dvdauthorwizard/Pictures/dvdlogo2.png
+share/apps/dvdauthorwizard/Pictures/lightbluecheckerboard.png
+share/apps/dvdauthorwizard/Pictures/lightbluecheckerboard_backup.png
+share/apps/dvdauthorwizard/Pictures/lightbluecheckerboardwide.png
+share/apps/dvdauthorwizard/Pictures/mask.png
+share/apps/dvdauthorwizard/Pictures/maskbig.png
+share/apps/dvdauthorwizard/Pictures/maskbigwide.png
+share/apps/dvdauthorwizard/Pictures/maskwide.png
+share/apps/dvdauthorwizard/Pictures/roll.png
+share/apps/dvdauthorwizard/Pictures/rollbig.png
+share/apps/dvdauthorwizard/Pictures/rollbigmask.png
+share/apps/dvdauthorwizard/Pictures/rollbigwide.png
+share/apps/dvdauthorwizard/Pictures/rollbigwidemask.png
+share/apps/dvdauthorwizard/Pictures/rollmask.png
+share/apps/dvdauthorwizard/Pictures/rollwide.png
+share/apps/dvdauthorwizard/Pictures/rollwidemask.png
+@dirrm share/apps/dvdauthorwizard/Pictures
+@dirrm share/apps/dvdauthorwizard