aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorCarlo Strub <cs@FreeBSD.org>2012-10-07 09:16:41 +0000
committerCarlo Strub <cs@FreeBSD.org>2012-10-07 09:16:41 +0000
commit4b7586933f6ad63ebf03ddfb990de8f76ea7ba29 (patch)
tree0e14946e49bff7dae6ebee5f1e6c169acd8e3e75 /multimedia
parent902cc7fc4f1307f4d36cc4119b3cbe8f86fd17ac (diff)
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ffmpegthumbnailer/Makefile33
-rw-r--r--multimedia/ffmpegthumbnailer/distinfo4
-rw-r--r--multimedia/ffmpegthumbnailer/files/bind-nautilus.sh16
-rw-r--r--multimedia/ffmpegthumbnailer/files/pkg-message.in2
-rw-r--r--multimedia/ffmpegthumbnailer/pkg-descr11
-rw-r--r--multimedia/ffmpegthumbnailer/pkg-plist2
6 files changed, 28 insertions, 40 deletions
diff --git a/multimedia/ffmpegthumbnailer/Makefile b/multimedia/ffmpegthumbnailer/Makefile
index 73ed7273e313..91d94422d1a0 100644
--- a/multimedia/ffmpegthumbnailer/Makefile
+++ b/multimedia/ffmpegthumbnailer/Makefile
@@ -5,12 +5,11 @@
# $FreeBSD$
PORTNAME= ffmpegthumbnailer
-PORTVERSION= 2.0.7
-PORTREVISION= 2
+PORTVERSION= 2.0.8
CATEGORIES= multimedia graphics
MASTER_SITES= GOOGLE_CODE
-MAINTAINER= dierk@blaxxtarz.de
+MAINTAINER= mbsd@isgroup.com.ua
COMMENT= Lightweight video thumbnailer that can be used by file managers
LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
@@ -19,22 +18,32 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png \
CPPFLAGS+= ${PTHREAD_CFLAGS} -I${LOCALBASE}/include
LDFLAGS+= ${PTHREAD_LIBS} -L${LOCALBASE}/lib
-CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig \
- --enable-gio
+CONFIGURE_ARGS= --with-pkgconfigdir=${PREFIX}/libdata/pkgconfig --enable-gio
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_GNOME= gnomehack pkgconfig _glib20
USE_LDCONFIG= yes
-MAN1= ffmpegthumbnailer.1
+WANT_GNOME= yes
+
+OPTIONS_DEFINE= GNOME
+
+.include <bsd.port.pre.mk>
-SUB_FILES= pkg-message
+.if ${PORT_OPTIONS:MGNOME}
+PKGNAMESUFFIX+= -gnome
+GCONF_SCHEMAS= ffmpegthumbnailer.schemas
+.endif
+
+MAN1= ffmpegthumbnailer.1
post-install:
cd ${WRKSRC}/ && ${SETENV} ${MAKE_ENV} ${MAKE} install-pkgconfigDATA
- ${MKDIR} ${DATADIR}
- ${INSTALL_SCRIPT} ${FILESDIR}/bind-nautilus.sh ${DATADIR}
- @${CAT} ${PKGMESSAGE}
-
-.include <bsd.port.mk>
+.if ${PORT_OPTIONS:MGNOME}
+ ${INSTALL_DATA} ${FILESDIR}/${GCONF_SCHEMAS} ${LOCALBASE}/etc/gconf/schemas
+ @${SETENV} GCONF_CONFIG_SOURCE=`gconftool-2 --get-default-source` \
+ gconftool-2 --makefile-install-rule ${LOCALBASE}/etc/gconf/schemas/${GCONF_SCHEMAS} \
+ > /dev/null
+.endif
+.include <bsd.port.post.mk>
diff --git a/multimedia/ffmpegthumbnailer/distinfo b/multimedia/ffmpegthumbnailer/distinfo
index 778322d165ed..9deff7f766d6 100644
--- a/multimedia/ffmpegthumbnailer/distinfo
+++ b/multimedia/ffmpegthumbnailer/distinfo
@@ -1,2 +1,2 @@
-SHA256 (ffmpegthumbnailer-2.0.7.tar.gz) = a71155339d17201a13fc3ebb649b0d00c7ab2d5a8880da071c8157a69c6f612b
-SIZE (ffmpegthumbnailer-2.0.7.tar.gz) = 359864
+SHA256 (ffmpegthumbnailer-2.0.8.tar.gz) = 2c8bbefa838d38ea42fc8ac78258cda36865d974c991624b14cffdb92a3bc68b
+SIZE (ffmpegthumbnailer-2.0.8.tar.gz) = 367186
diff --git a/multimedia/ffmpegthumbnailer/files/bind-nautilus.sh b/multimedia/ffmpegthumbnailer/files/bind-nautilus.sh
deleted file mode 100644
index 327f5db5bb83..000000000000
--- a/multimedia/ffmpegthumbnailer/files/bind-nautilus.sh
+++ /dev/null
@@ -1,16 +0,0 @@
-#!/bin/sh
-
-# Use this script to bind ffmpegthumbnailer to nautilus.
-
-type="application@x-extension-webm video/3gpp video/3gpp2 video@avi \
-video@flv video@mkv video@mp4 video@mpeg video@ogg video@quicktime video@webm \
-video@x-avi video@x-flv video@x-m4v video@x-matroska video@x-mkv video@x-mp4 \
-video@x-mpeg video@x-ms-asf video@x-ms-wmv video@x-ms-wvx video@x-msvideo \
-video@x-msvideo@avi video@x-theora@ogg video@x-theora@ogv video@x-webm"
-
-cmd="/usr/bin/ffmpegthumbnailer -s %s -i %i -o %o -f"
-
-for i in $type; do
-gconftool-2 -s "/desktop/gnome/thumbnailers/$i/command" -t string "$cmd"
-gconftool-2 -s "/desktop/gnome/thumbnailers/$i/enable" -t boolean "true"
-done
diff --git a/multimedia/ffmpegthumbnailer/files/pkg-message.in b/multimedia/ffmpegthumbnailer/files/pkg-message.in
deleted file mode 100644
index bcf6cc1c9434..000000000000
--- a/multimedia/ffmpegthumbnailer/files/pkg-message.in
+++ /dev/null
@@ -1,2 +0,0 @@
-Gnome users may bind ffmpegthumbnailer to nautilus using:
-%%DATADIR%%/bind-nautilus.sh.
diff --git a/multimedia/ffmpegthumbnailer/pkg-descr b/multimedia/ffmpegthumbnailer/pkg-descr
index 83ac996d1faa..de423197a7c6 100644
--- a/multimedia/ffmpegthumbnailer/pkg-descr
+++ b/multimedia/ffmpegthumbnailer/pkg-descr
@@ -1,9 +1,8 @@
-This video thumbnailer can be used by file managers to create thumbnails
-for your video files. The thumbnailer uses ffmpeg to decode frames from
-the video files, so supported videoformats depend on the configuration
-flags of ffmpeg.
+This video thumbnailer can be used by file managers to create thumbnails for
+your video files. The thumbnailer uses ffmpeg to decode frames from the video
+files, so supported videoformats depend on the configuration flags of ffmpeg.
-This thumbnailer was designed to be as fast and lightweight as possible.
-The only dependencies are ffmpeg, libjpeg and libpng.
+This thumbnailer was designed to be as fast and lightweight as possible. The
+only dependencies are ffmpeg, libjpeg and libpng.
WWW: http://code.google.com/p/ffmpegthumbnailer/
diff --git a/multimedia/ffmpegthumbnailer/pkg-plist b/multimedia/ffmpegthumbnailer/pkg-plist
index a4f514597ec6..7f8e8fb27c5b 100644
--- a/multimedia/ffmpegthumbnailer/pkg-plist
+++ b/multimedia/ffmpegthumbnailer/pkg-plist
@@ -10,6 +10,4 @@ lib/libffmpegthumbnailer.la
lib/libffmpegthumbnailer.so
lib/libffmpegthumbnailer.so.4
libdata/pkgconfig/libffmpegthumbnailer.pc
-%%DATADIR%%/bind-nautilus.sh
@dirrm include/libffmpegthumbnailer
-@dirrm %%DATADIR%%