aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorThomas Zander <riggs@FreeBSD.org>2014-06-07 13:24:16 +0000
committerThomas Zander <riggs@FreeBSD.org>2014-06-07 13:24:16 +0000
commit5f06c72a18eea77579dbf562fa295a3cefdec29f (patch)
treec23184ecac62e290f31d7090c6eeb184ab2df89e /multimedia
parent0cede931fdf1d2b1be8e7e0f8fdf9a3ea632e8a1 (diff)
downloadports-5f06c72a18eea77579dbf562fa295a3cefdec29f.tar.gz
ports-5f06c72a18eea77579dbf562fa295a3cefdec29f.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mencoder/Makefile6
-rw-r--r--multimedia/mplayer/Makefile12
-rw-r--r--multimedia/mplayer/files/patch-mplayer.c12
3 files changed, 22 insertions, 8 deletions
diff --git a/multimedia/mencoder/Makefile b/multimedia/mencoder/Makefile
index aac61522be05..c3ddec07b827 100644
--- a/multimedia/mencoder/Makefile
+++ b/multimedia/mencoder/Makefile
@@ -77,9 +77,9 @@ pre-everything::
@${ECHO_MSG} "N - O - T - E"
@${ECHO_MSG} ""
@${ECHO_MSG} "There are some knobs which *can* *not* be selected via the"
- @${ECHO_MSG} "OPTIONS framework. At the moment, their defaults are:"
- @${ECHO_MSG} "DEFAULT_DVD_DEVICE=/dev/cd0"
- @${ECHO_MSG} "DEFAULT_CDROM_DEVICE=/dev/cd0"
+ @${ECHO_MSG} "OPTIONS framework. At the moment, these settings are:"
+ @${ECHO_MSG} "DEFAULT_DVD_DEVICE=${DEFAULT_DVD_DEVICE}"
+ @${ECHO_MSG} "DEFAULT_CDROM_DEVICE=${DEFAULT_CDROM_DEVICE}"
post-patch:
.if ${OSVERSION} >= 900010
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 236cfd6dfa89..f799e030931c 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= mplayer
PORTVERSION= ${MPLAYER_PORT_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
COMMENT= High performance media player supporting many formats
@@ -39,6 +39,8 @@ X11VM_DESC?= X11 VidMode support
SUB_FILES= pkg-message
+CONFLICTS= mplayer2-2.*
+
CONFFILES= example.conf input.conf menu.conf dvb-menu.conf
USES+= pkgconfig
@@ -116,10 +118,10 @@ pre-everything::
@${ECHO_MSG} "N - O - T - E"
@${ECHO_MSG} ""
@${ECHO_MSG} "There are some knobs which *can* *not* be selected via the"
- @${ECHO_MSG} "OPTIONS framework. At the moment, their defaults are:"
- @${ECHO_MSG} "WITH_KERN_HZ=1024"
- @${ECHO_MSG} "DEFAULT_DVD_DEVICE=/dev/cd0"
- @${ECHO_MSG} "DEFAULT_CDROM_DEVICE=/dev/cd0"
+ @${ECHO_MSG} "OPTIONS framework. At the moment, these settings are:"
+ @${ECHO_MSG} "WITH_KERN_HZ=${DEFAULT_KERN_HZ}"
+ @${ECHO_MSG} "DEFAULT_DVD_DEVICE=${DEFAULT_DVD_DEVICE}"
+ @${ECHO_MSG} "DEFAULT_CDROM_DEVICE=${DEFAULT_CDROM_DEVICE}"
.if ${PORT_OPTIONS:MGUI} && ${PORT_OPTIONS:MX11}
@${ECHO_MSG} "If you want to use the GUI, you can use the skins from"
diff --git a/multimedia/mplayer/files/patch-mplayer.c b/multimedia/mplayer/files/patch-mplayer.c
new file mode 100644
index 000000000000..8fa3358f3950
--- /dev/null
+++ b/multimedia/mplayer/files/patch-mplayer.c
@@ -0,0 +1,12 @@
+--- mplayer.c.orig 2014-04-06 20:46:45.000000000 +0200
++++ mplayer.c 2014-06-07 14:40:43.756655422 +0200
+@@ -3707,7 +3707,8 @@
+ if (use_gui) {
+ if (!gui(GUI_SET_VIDEO, mpctx->sh_video))
+ goto goto_next_file;
+- gui(GUI_SET_AUDIO, mpctx->sh_audio);
++ if (mpctx->sh_audio)
++ gui(GUI_SET_AUDIO, mpctx->sh_audio);
+ }
+ #endif
+