aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-11-11 11:45:11 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-11-11 11:45:11 +0000
commit9adb469c8371aa40d88e402ff716d1035ed308b6 (patch)
tree65f297201bd402d11a7ddbc6c087acf7582863c0 /multimedia
parent1b1cf50789517ad79596df2361eca320e10863c1 (diff)
downloadports-9adb469c8371aa40d88e402ff716d1035ed308b6.tar.gz
ports-9adb469c8371aa40d88e402ff716d1035ed308b6.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mswebrtc/files/patch-CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/multimedia/mswebrtc/files/patch-CMakeLists.txt b/multimedia/mswebrtc/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..0ec1a163a101
--- /dev/null
+++ b/multimedia/mswebrtc/files/patch-CMakeLists.txt
@@ -0,0 +1,16 @@
+i386 target on BSDs doesn't include SSE2 by default
+
+--- CMakeLists.txt.orig 2017-07-20 13:56:58 UTC
++++ CMakeLists.txt
+@@ -204,6 +204,11 @@ if(ENABLE_AEC)
+ ${AEC_SRC_DIR}/aec_core_sse2.c
+ ${AEC_SRC_DIR}/aec_rdft_sse2.c
+ )
++ set_source_files_properties(
++ ${AEC_SRC_DIR}/aec_core_sse2.c
++ ${AEC_SRC_DIR}/aec_rdft_sse2.c
++ PROPERTIES COMPILE_FLAGS "-msse2"
++ )
+ endif()
+ include_directories(
+ ${AEC_SRC_DIR}/include