aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-02-22 14:07:39 +0000
committerMANTANI Nobutaka <nobutaka@FreeBSD.org>2004-02-22 14:07:39 +0000
commitb8b71f57a75371670bd3d6b8acbfc968690c9cfc (patch)
treef4d5812bc3401765957d11b66037e356fbb30ffb /multimedia
parent92000630adc8f60a21dcd720b593881f91b53244 (diff)
downloadports-b8b71f57a75371670bd3d6b8acbfc968690c9cfc.tar.gz
ports-b8b71f57a75371670bd3d6b8acbfc968690c9cfc.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/libxine/Makefile2
-rw-r--r--multimedia/libxine/distinfo1
-rw-r--r--multimedia/libxine/files/patch-src:audio_out:audio_arts_out.c22
-rw-r--r--multimedia/libxine/files/patch-src:video_out:video_out_xv.c13
4 files changed, 34 insertions, 4 deletions
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index ee62ad9f309e..62464fc17d5c 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xine
PORTVERSION= 1.0.r3
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/multimedia/libxine/distinfo b/multimedia/libxine/distinfo
index 4981916f2d7d..bed3419d0ca6 100644
--- a/multimedia/libxine/distinfo
+++ b/multimedia/libxine/distinfo
@@ -1 +1,2 @@
MD5 (xine-lib-1-rc3a.tar.gz) = 6dfd0c67b5b694adb283c0f6d8d3ab03
+SIZE (xine-lib-1-rc3a.tar.gz) = 6121483
diff --git a/multimedia/libxine/files/patch-src:audio_out:audio_arts_out.c b/multimedia/libxine/files/patch-src:audio_out:audio_arts_out.c
new file mode 100644
index 000000000000..2ee59d270443
--- /dev/null
+++ b/multimedia/libxine/files/patch-src:audio_out:audio_arts_out.c
@@ -0,0 +1,22 @@
+--- src/audio_out/audio_arts_out.c 2003/12/20 19:51:48 1.24
++++ src/audio_out/audio_arts_out.c 2004/02/15 19:29:47 1.25
+@@ -17,7 +17,7 @@
+ * along with this program; if not, write to the Free Software
+ * Foundation, Inc., 59 Temple Place - Suite 330, Boston, MA 02111-1307, USA
+ *
+- * $Id: audio_arts_out.c,v 1.24 2003/12/20 19:51:48 manfredtremmel Exp $
++ * $Id: audio_arts_out.c,v 1.25 2004/02/15 19:29:47 mroi Exp $
+ */
+
+ #ifndef __sun /* _XOPEN_SOURCE causes build prob's on sunos */
+@@ -227,7 +227,10 @@
+ arts_driver_t *this = (arts_driver_t *) this_gen;
+
+ ao_arts_close(this_gen);
++ /* FIXME: arts_free() freezes on BSD, so don't use it there */
++#if !defined(__OpenBSD__) && !defined (__FreeBSD__) && !defined(__NetBSD__)
+ arts_free();
++#endif
+
+ free (this);
+ }
diff --git a/multimedia/libxine/files/patch-src:video_out:video_out_xv.c b/multimedia/libxine/files/patch-src:video_out:video_out_xv.c
index 1ce2edca9cad..b1ed19060a64 100644
--- a/multimedia/libxine/files/patch-src:video_out:video_out_xv.c
+++ b/multimedia/libxine/files/patch-src:video_out:video_out_xv.c
@@ -1,6 +1,6 @@
---- src/video_out/video_out_xv.c.orig Sun Aug 10 00:46:38 2003
-+++ src/video_out/video_out_xv.c Sun Aug 10 01:19:42 2003
-@@ -45,7 +45,11 @@
+--- src/video_out/video_out_xv.c.orig Sun Dec 14 23:13:26 2003
++++ src/video_out/video_out_xv.c Thu Feb 5 14:27:10 2004
+@@ -47,13 +47,17 @@
#if defined (__SVR4) && defined (__sun)
# include <sys/int_types.h>
#else
@@ -12,4 +12,11 @@
+# endif
#endif
++#include <sys/types.h>
#if defined(__FreeBSD__)
+ #include <machine/param.h>
+ #endif
+-#include <sys/types.h>
+ #include <sys/ipc.h>
+ #include <sys/shm.h>
+ #include <sys/time.h>