aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-05-28 16:23:47 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-05-28 16:23:47 +0000
commitd097db9617b952d350880a9e887b8bc96d941a00 (patch)
treefcf5efc8547f31b7f351f8d1289d340b3dc44466 /multimedia
parent858b6c8e39ddf9cd94061a64f5b93e8842a759b1 (diff)
downloadports-d097db9617b952d350880a9e887b8bc96d941a00.tar.gz
ports-d097db9617b952d350880a9e887b8bc96d941a00.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/mplayer/files/patch-libao2-ao_oss.c15
2 files changed, 16 insertions, 1 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 013a9a5b34a0..58158c16095d 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -206,7 +206,7 @@
PORTNAME= mplayer
PORTVERSION= 0.92.1
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio ipv6
MASTER_SITES= http://www1.mplayerhq.hu/MPlayer/releases/ \
http://www2.mplayerhq.hu/MPlayer/releases/ \
diff --git a/multimedia/mplayer/files/patch-libao2-ao_oss.c b/multimedia/mplayer/files/patch-libao2-ao_oss.c
new file mode 100644
index 000000000000..c384d1da90a4
--- /dev/null
+++ b/multimedia/mplayer/files/patch-libao2-ao_oss.c
@@ -0,0 +1,15 @@
+--- libao2/ao_oss.c.orig Sun Jul 27 13:41:36 2003
++++ libao2/ao_oss.c Sun Jul 27 13:49:37 2003
+@@ -247,7 +247,11 @@
+ mp_msg(MSGT_AO,MSGL_ERR,"\nFatal error: *** CANNOT RE-OPEN / RESET AUDIO DEVICE *** %s\n", strerror(errno));
+ return;
+ }
+-
++
++#if defined(FD_CLOEXEC) && defined(F_SETFD)
++ fcntl(audio_fd, F_SETFD, FD_CLOEXEC);
++#endif
++
+ ioctl (audio_fd, SNDCTL_DSP_SETFMT, &ao_data.format);
+ if(ao_data.format != AFMT_AC3) {
+ if (ao_data.channels > 2)