aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-26 08:44:52 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2013-07-26 08:44:52 +0000
commitcaca977c2d48c7b3a0ee71147fab28e880ad34cf (patch)
treef68a8c7b83f9fcbb5a4d3539994bac84b691e004 /multimedia
parente4380cfce1663b6365c19ae0d19fe4c13db5647f (diff)
downloadports-caca977c2d48c7b3a0ee71147fab28e880ad34cf.tar.gz
ports-caca977c2d48c7b3a0ee71147fab28e880ad34cf.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/umplayer/Makefile36
1 files changed, 17 insertions, 19 deletions
diff --git a/multimedia/umplayer/Makefile b/multimedia/umplayer/Makefile
index 262fc33a3195..d532a69fed2d 100644
--- a/multimedia/umplayer/Makefile
+++ b/multimedia/umplayer/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: umplayer
-# Date created: 2 May, 2011
-# Whom: Zhihao Yuan <lichray@gmail.com>
-#
+# Created by: Zhihao Yuan <lichray@gmail.com>
# $FreeBSD$
-#
PORTNAME= umplayer
DISTVERSION= 0.97
@@ -12,33 +8,35 @@ CATEGORIES= multimedia audio kde
MASTER_SITES= LOCAL/wen
MAINTAINER= lichray@gmail.com
-COMMENT= A modern front-end for mplayer (forked from smplayer)
+COMMENT= Modern front-end for MPlayer (fork of SMPlayer)
RUN_DEPENDS= mplayer:${PORTSDIR}/multimedia/mplayer
+USES= gmake
+USE_XZ= yes
USE_QT4= gui network xml qmake_build moc_build rcc_build uic_build \
linguist_build
-
-ALL_TARGET= src/umplayer
-
-USE_XZ= yes
-USE_GMAKE= yes
INSTALLS_ICONS= yes
-MAKE_ARGS+= QMAKE_OPTS="DEFINES+=NO_DEBUG_ON_CONSOLE"
+MAKE_ARGS= QMAKE_OPTS="DEFINES+=NO_DEBUG_ON_CONSOLE" PREFIX="${PREFIX}"
+ALL_TARGET= src/umplayer
MAN1= umplayer.1
MANCOMPRESSED= yes
+OPTIONS_DEFINE= DOCS
+
+.include <bsd.port.options.mk>
+
post-patch:
- @${REINPLACE_CMD} -e 's|qmake|${QMAKE}|g' \
- -e 's|lrelease|${QT_PREFIX}/bin/lrelease-qt4|g' \
- -e 's|PREFIX=/usr/local|PREFIX=${PREFIX}|g' \
- -e 's,/share/man,/man,g' \
+ @${REINPLACE_CMD} -e 's| make| $$(MAKE)|' \
+ -e 's|cd src|(&| ; /cd src/s|$$|)|' \
+ -e 's|qmake|${QMAKE}|' \
+ -e 's|lrelease|${QT_PREFIX}/bin/lrelease-qt4|' \
+ -e 's|/share/man|/man|' \
-e 's|/doc/packages|/doc|' \
-e 's|^.*/get_svn_revision.sh$$||' \
- ${WRKSRC}/Makefile
-
-.if defined(NOPORTDOCS)
+ ${WRKSRC}/Makefile
+.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -E -e '/(install|tar).*DOC_PATH/d' \
${WRKSRC}/Makefile
.endif