aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorChristian Weisgerber <naddy@FreeBSD.org>2003-12-20 16:37:57 +0000
committerChristian Weisgerber <naddy@FreeBSD.org>2003-12-20 16:37:57 +0000
commit63d96de22f82f902e63a87ea5145bb12c985aad6 (patch)
treeb547f3a265861dfb243e0d8ad3978b9bf05b317f /multimedia
parent89c5de703163bc92603bc4ad3ec74b9e1f73f231 (diff)
downloadports-63d96de22f82f902e63a87ea5145bb12c985aad6.tar.gz
ports-63d96de22f82f902e63a87ea5145bb12c985aad6.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/avifile/Makefile3
-rw-r--r--multimedia/beep-media-player/Makefile4
-rw-r--r--multimedia/gstreamer-plugins/Makefile2
-rw-r--r--multimedia/gstreamer-plugins80/Makefile2
-rw-r--r--multimedia/kdemultimedia3/Makefile5
-rw-r--r--multimedia/kdemultimedia4/Makefile5
-rw-r--r--multimedia/libquicktime/Makefile3
-rw-r--r--multimedia/libxine/Makefile5
-rw-r--r--multimedia/mplayer/Makefile2
-rw-r--r--multimedia/ogmtools/Makefile5
-rw-r--r--multimedia/transcode/Makefile2
-rw-r--r--multimedia/vlc-devel/Makefile5
-rw-r--r--multimedia/vlc/Makefile5
-rw-r--r--multimedia/xmms/Makefile4
14 files changed, 24 insertions, 28 deletions
diff --git a/multimedia/avifile/Makefile b/multimedia/avifile/Makefile
index 700f74260efc..8a6d91c4717b 100644
--- a/multimedia/avifile/Makefile
+++ b/multimedia/avifile/Makefile
@@ -7,6 +7,7 @@
PORTNAME= avifile
PORTVERSION= 0.7.38
+PORTREVISION= 1
PORTEPOCH= 2
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
@@ -139,7 +140,7 @@ PLIST_SUB+= VIDIX="@comment "
# libvorbis; thus, libogg
.if !defined(WITHOUT_VORBIS)
-LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --with-vorbis-prefix=${LOCALBASE} \
--with-ogg-prefix=${LOCALBASE}
diff --git a/multimedia/beep-media-player/Makefile b/multimedia/beep-media-player/Makefile
index f58ad3c761e9..b6f3e92b2097 100644
--- a/multimedia/beep-media-player/Makefile
+++ b/multimedia/beep-media-player/Makefile
@@ -7,7 +7,7 @@
PORTNAME= beep-media-player
PORTVERSION= 1.0.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia audio
MASTER_SITES= http://linux-media.net/beep/downloads/
DISTNAME= ${PORTNAME}-${PORTVERSION}-pre5
@@ -52,7 +52,7 @@ PLIST_SUB+= MIKMODPLUGIN:="@comment "
#.endif
.if !defined(WITHOUT_VORBIS)
-LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
INPUT_PLUGINS+= vorbis
PLIST_SUB+= VORBISPLUGIN:=""
.else
diff --git a/multimedia/gstreamer-plugins/Makefile b/multimedia/gstreamer-plugins/Makefile
index 23e277b44eab..ec0c648d5586 100644
--- a/multimedia/gstreamer-plugins/Makefile
+++ b/multimedia/gstreamer-plugins/Makefile
@@ -606,7 +606,7 @@ CONFIGURE_ARGS+= --disable-vorbis \
--disable-vorbistest
PLIST_SUB+= VORBIS="@comment "
.else
-LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --with-vorbis=${LOCALBASE} \
--with-vorbis-libraries=${LOCALBASE}/lib \
diff --git a/multimedia/gstreamer-plugins80/Makefile b/multimedia/gstreamer-plugins80/Makefile
index 23e277b44eab..ec0c648d5586 100644
--- a/multimedia/gstreamer-plugins80/Makefile
+++ b/multimedia/gstreamer-plugins80/Makefile
@@ -606,7 +606,7 @@ CONFIGURE_ARGS+= --disable-vorbis \
--disable-vorbistest
PLIST_SUB+= VORBIS="@comment "
.else
-LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
CONFIGURE_ARGS+= --with-vorbis=${LOCALBASE} \
--with-vorbis-libraries=${LOCALBASE}/lib \
diff --git a/multimedia/kdemultimedia3/Makefile b/multimedia/kdemultimedia3/Makefile
index 97817ec3a5c3..2459cc727a50 100644
--- a/multimedia/kdemultimedia3/Makefile
+++ b/multimedia/kdemultimedia3/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdemultimedia
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -21,8 +21,7 @@ RUN_DEPENDS+= xanim:${PORTSDIR}/multimedia/xanim
LIB_DEPENDS+= audiofile:${PORTSDIR}/audio/libaudiofile \
cdda_paranoia:${PORTSDIR}/audio/cdparanoia \
mp3lame:${PORTSDIR}/audio/lame \
- ogg.4:${PORTSDIR}/audio/libogg \
- vorbis.2:${PORTSDIR}/audio/libvorbis
+ vorbis.3:${PORTSDIR}/audio/libvorbis
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
diff --git a/multimedia/kdemultimedia4/Makefile b/multimedia/kdemultimedia4/Makefile
index 97817ec3a5c3..2459cc727a50 100644
--- a/multimedia/kdemultimedia4/Makefile
+++ b/multimedia/kdemultimedia4/Makefile
@@ -8,7 +8,7 @@
PORTNAME= kdemultimedia
PORTVERSION= ${KDE_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia kde
MASTER_SITES= ${MASTER_SITE_KDE}
MASTER_SITE_SUBDIR= stable/${PORTVERSION}/src
@@ -21,8 +21,7 @@ RUN_DEPENDS+= xanim:${PORTSDIR}/multimedia/xanim
LIB_DEPENDS+= audiofile:${PORTSDIR}/audio/libaudiofile \
cdda_paranoia:${PORTSDIR}/audio/cdparanoia \
mp3lame:${PORTSDIR}/audio/lame \
- ogg.4:${PORTSDIR}/audio/libogg \
- vorbis.2:${PORTSDIR}/audio/libvorbis
+ vorbis.3:${PORTSDIR}/audio/libvorbis
USE_KDELIBS_VER=3
PREFIX= ${KDE_PREFIX}
diff --git a/multimedia/libquicktime/Makefile b/multimedia/libquicktime/Makefile
index 36776349852d..c5573e906fbc 100644
--- a/multimedia/libquicktime/Makefile
+++ b/multimedia/libquicktime/Makefile
@@ -8,6 +8,7 @@
PORTNAME= libquicktime
PORTVERSION= 0.9.2
+PORTREVISION= 1
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -15,7 +16,7 @@ MASTER_SITE_SUBDIR= ${PORTNAME}
MAINTAINER= ports@FreeBSD.org
COMMENT= A library for reading and writing quicktime files
-LIB_DEPENDS= vorbis.2:${PORTSDIR}/audio/libvorbis \
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis \
jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png \
dv.3:${PORTSDIR}/multimedia/libdv
diff --git a/multimedia/libxine/Makefile b/multimedia/libxine/Makefile
index 04845b5fdca1..ac826b8a285b 100644
--- a/multimedia/libxine/Makefile
+++ b/multimedia/libxine/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xine
PORTVERSION= 1.0.r2
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= multimedia
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -20,8 +20,7 @@ COMMENT= Libraries for xine multimedia player
BUILD_DEPENDS= ${LOCALBASE}/lib/libdjbfft.a:${PORTSDIR}/math/djbfft
LIB_DEPENDS= FLAC.5:${PORTSDIR}/audio/flac \
a52.0:${PORTSDIR}/audio/liba52 \
- ogg.4:${PORTSDIR}/audio/libogg \
- vorbis.2:${PORTSDIR}/audio/libvorbis \
+ vorbis.3:${PORTSDIR}/audio/libvorbis \
mad.2:${PORTSDIR}/audio/mad \
speex.2:${PORTSDIR}/audio/speex \
iconv.3:${PORTSDIR}/converters/libiconv \
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index b8ebafd29802..197ebb38c981 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -429,7 +429,7 @@ PKGNAMESUFFIX= -esound
.endif
.if defined(WITH_VORBIS)
-LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
.endif
.if defined(WITH_REALPLAYER)
diff --git a/multimedia/ogmtools/Makefile b/multimedia/ogmtools/Makefile
index e0944c90d7b1..d0213b3ef66f 100644
--- a/multimedia/ogmtools/Makefile
+++ b/multimedia/ogmtools/Makefile
@@ -7,15 +7,14 @@
PORTNAME= ogmtools
PORTVERSION= 1.1
+PORTREVISION= 1
CATEGORIES= multimedia audio
MASTER_SITES= http://www.bunkus.org/videotools/ogmtools/
MAINTAINER= lioux@FreeBSD.org
COMMENT= Tools to extract from/get info about/create OGG media streams
-LIB_DEPENDS= ogg.4:${PORTSDIR}/audio/libogg \
- vorbis.2:${PORTSDIR}/audio/libvorbis \
- vorbisenc.2:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS= vorbis.3:${PORTSDIR}/audio/libvorbis
USE_BZIP2= yes
USE_REINPLACE= yes
diff --git a/multimedia/transcode/Makefile b/multimedia/transcode/Makefile
index af9756ac692d..fb0686354ce6 100644
--- a/multimedia/transcode/Makefile
+++ b/multimedia/transcode/Makefile
@@ -203,7 +203,7 @@ PLIST_SUB+= WITH_LAME="@comment "
.endif
.if defined(WITH_OGG)
-LIB_DEPENDS+= ogg.4:${PORTSDIR}/audio/libogg
+LIB_DEPENDS+= ogg.5:${PORTSDIR}/audio/libogg
CONFIGURE_ARGS+= --with-ogg=yes
PLIST_SUB+= WITH_OGG=""
.else
diff --git a/multimedia/vlc-devel/Makefile b/multimedia/vlc-devel/Makefile
index 83f417727631..29bd5ef0f988 100644
--- a/multimedia/vlc-devel/Makefile
+++ b/multimedia/vlc-devel/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vlc
PORTVERSION= 0.6.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/${PORTVERSION}/
@@ -21,8 +21,7 @@ LIB_DEPENDS= dvdcss.2:${PORTSDIR}/multimedia/libdvdcss \
a52.0:${PORTSDIR}/audio/liba52 \
intl.5:${PORTSDIR}/devel/gettext \
iconv.3:${PORTSDIR}/converters/libiconv \
- vorbis.2:${PORTSDIR}/audio/libvorbis \
- ogg.4:${PORTSDIR}/audio/libogg \
+ vorbis.3:${PORTSDIR}/audio/libvorbis \
FLAC.5:${PORTSDIR}/audio/flac \
faad.0:${PORTSDIR}/audio/faad \
wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2 \
diff --git a/multimedia/vlc/Makefile b/multimedia/vlc/Makefile
index 83f417727631..29bd5ef0f988 100644
--- a/multimedia/vlc/Makefile
+++ b/multimedia/vlc/Makefile
@@ -7,7 +7,7 @@
PORTNAME= vlc
PORTVERSION= 0.6.2
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= multimedia
MASTER_SITES= http://www.videolan.org/pub/videolan/vlc/${PORTVERSION}/
@@ -21,8 +21,7 @@ LIB_DEPENDS= dvdcss.2:${PORTSDIR}/multimedia/libdvdcss \
a52.0:${PORTSDIR}/audio/liba52 \
intl.5:${PORTSDIR}/devel/gettext \
iconv.3:${PORTSDIR}/converters/libiconv \
- vorbis.2:${PORTSDIR}/audio/libvorbis \
- ogg.4:${PORTSDIR}/audio/libogg \
+ vorbis.3:${PORTSDIR}/audio/libvorbis \
FLAC.5:${PORTSDIR}/audio/flac \
faad.0:${PORTSDIR}/audio/faad \
wx_gtk2-2.4.0:${PORTSDIR}/x11-toolkits/wxgtk2 \
diff --git a/multimedia/xmms/Makefile b/multimedia/xmms/Makefile
index 740725c9675a..f206bf313b4e 100644
--- a/multimedia/xmms/Makefile
+++ b/multimedia/xmms/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xmms
PORTVERSION= 1.2.8
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES+= multimedia audio ipv6
MASTER_SITES= ftp://ftp.xmms.org/pub/xmms/1.2.x/ \
http://www.xmms.org/files/1.2.x/ \
@@ -64,7 +64,7 @@ PLIST_SUB+= MIKMODPLUGIN:="@comment "
.endif
.if !defined(WITHOUT_VORBIS)
-LIB_DEPENDS+= vorbis.2:${PORTSDIR}/audio/libvorbis
+LIB_DEPENDS+= vorbis.3:${PORTSDIR}/audio/libvorbis
INPUT_PLUGINS+= vorbis
PLIST_SUB+= VORBISPLUGIN:=""
.else