aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2004-08-15 14:49:36 +0000
committerPav Lucistnik <pav@FreeBSD.org>2004-08-15 14:49:36 +0000
commit3ea9ba4ea90eab62bab0b65ff86dde545f0d4f57 (patch)
treeefeb090cacc750b3e062023ed51f3da452c1a33b /multimedia
parent37f8349dd4cd306514041ab0cb5e5aad823ca2cc (diff)
- Fix build with gcc-3.4 by increasing optimization level to -O2
This is a workaround for what looks like preprocessor bug in gcc Clue provided by: bland
Notes
Notes: svn path=/head/; revision=116262
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/ogle/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/multimedia/ogle/Makefile b/multimedia/ogle/Makefile
index 7e6363f3cfff..5eee53996c76 100644
--- a/multimedia/ogle/Makefile
+++ b/multimedia/ogle/Makefile
@@ -54,6 +54,12 @@ pre-configure:
.include <bsd.port.pre.mk>
+# XXX due to gcc-3.4 (20040706) bug in preprocessing of inline functions,
+# this needs at least -O2 to compile. Fails with -O
+.if ${OSVERSION} >= 502126
+CFLAGS+= -O2
+.endif
+
# hack to make ogle work with liba52 + djbfft
.if exists(${LOCALBASE}/lib/liba52.la)
LIBA52_DEP_LIBS!= ${GREP} dependency_libs ${LOCALBASE}/lib/liba52.la | ${CUT} -d \' -f 2