aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorMarcus Alves Grando <mnag@FreeBSD.org>2005-09-24 20:43:22 +0000
committerMarcus Alves Grando <mnag@FreeBSD.org>2005-09-24 20:43:22 +0000
commitfa400f9ea9e31e52d062b206a00f37b0c2bf03f0 (patch)
tree1b08dde8c7d3c64bdaf55ced7a31b8912d9a702d /multimedia
parentd28cc167e42a1d68bd09708dbf5eb4e211a0b4c6 (diff)
Add support to DTS decoding
PR: ports/86473 Submitted by: bh@izb.knu.ac.kr Approved by: pav (mentor), riggs@rrr.de (maintainer)
Notes
Notes: svn path=/head/; revision=143497
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/mplayer/Makefile12
1 files changed, 12 insertions, 0 deletions
diff --git a/multimedia/mplayer/Makefile b/multimedia/mplayer/Makefile
index 2ef299a5e6ab..1e3e509034c0 100644
--- a/multimedia/mplayer/Makefile
+++ b/multimedia/mplayer/Makefile
@@ -241,6 +241,9 @@
# WITH_XMMS
# default: autodetect
#
+# WITH_DTS
+# default: autodetect
+#
# WITH_LANG
# default: en
# Enables language support bg, cz, de, dk, en, es, fr, gr, hu, it, ko, nl, no, pl, pt_BR, ro, ru, sk, tr, uk, zh
@@ -442,6 +445,10 @@ WITH_XVID= yes
WITH_XMMS= yes
.endif
+.if exists(${LOCALBASE}/lib/libdts.a)
+WITH_DTS= yes
+.endif
+
.if exists(${LOCALBASE}/lib/liblzo.so)
WITH_LZO= yes
.endif
@@ -737,6 +744,11 @@ CONFIGURE_ARGS+= --enable-xmms
LIB_DEPENDS+= xmms.4:${PORTSDIR}/multimedia/xmms
.endif
+.if defined(WITH_DTS)
+CONFIGURE_ARGS+= --enable-libdts
+BUILD_DEPENDS+= ${LOCALBASE}/lib/libdts.a:${PORTSDIR}/multimedia/libdts
+.endif
+
.if defined(WITH_FREETYPE)
CONFIGURE_ARGS+= --with-extraincdir=${LOCALBASE}/include/freetype2 \
--enable-freetype