aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 04:17:08 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2004-04-05 04:17:08 +0000
commit9693507d262bfd212bbfa743e769c733c261510c (patch)
tree4d6fab9796bb155475708b93673832686af4e3b5 /multimedia
parentd5fe9fe540b5cc0c901e659f86c00880d6986350 (diff)
downloadports-9693507d262bfd212bbfa743e769c733c261510c.tar.gz
ports-9693507d262bfd212bbfa743e769c733c261510c.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/gstreamer-player/Makefile46
-rw-r--r--multimedia/gstreamer-player/distinfo4
-rw-r--r--multimedia/gstreamer-player/files/patch-configure27
-rw-r--r--multimedia/gstreamer-player/files/patch-mozilla::Makefile.in18
-rw-r--r--multimedia/gstreamer-player/files/patch-mozilla::plugin.c35
-rw-r--r--multimedia/gstreamer-player/pkg-descr2
-rw-r--r--multimedia/gstreamer-player/pkg-plist2
7 files changed, 13 insertions, 121 deletions
diff --git a/multimedia/gstreamer-player/Makefile b/multimedia/gstreamer-player/Makefile
index c4489081888a..0c56d386d077 100644
--- a/multimedia/gstreamer-player/Makefile
+++ b/multimedia/gstreamer-player/Makefile
@@ -6,28 +6,25 @@
#
PORTNAME= gstreamer
-PORTVERSION= 0.6.0
-PORTREVISION= 4
+PORTVERSION= 0.8.0
CATEGORIES= multimedia audio gnome
-MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
-MASTER_SITE_SUBDIR= ${PORTNAME}
+MASTER_SITES= http://gstreamer.freedesktop.org/src/gst-player/
PKGNAMESUFFIX= -player
DISTNAME= gst-player-${PORTVERSION}
MAINTAINER= lioux@FreeBSD.org
COMMENT= Simple yet functional mediaplayer written with GStreamer
-LIB_DEPENDS= gstreamer-0.6.1:${PORTSDIR}/multimedia/gstreamer \
- gstplay-0.6.1:${PORTSDIR}/multimedia/gstreamer-plugins \
- popt.0:${PORTSDIR}/devel/popt
+LIB_DEPENDS= popt.0:${PORTSDIR}/devel/popt
+USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_GNOME= gnomehack \
gnomeprefix \
- gnomedesktop
+ gnomedesktop \
+ gstreamerplugins
USE_LIBTOOL_VER=13
-USE_SIZE= yes
GNOME_DESKTOP_VERSION=2
WANT_GNOME= yes
PLIST_SUB= \
@@ -42,33 +39,10 @@ MAN1= gst-player.1
# library minor number
SHLIB_VERSION= 0
-pre-install:
+pre-su-install:
# required for PREFIX safeness, the dir might not exist under PREFIX
@${MKDIR} ${PREFIX}/etc/gconf/
-.if defined(WITH_MOZILLA_PLUGIN)
-BUILD_DEPENDS+= ${X11BASE}/lib/${MOZILLA}/mozilla-config:${PORTSDIR}/www/${MOZILLA}
-
-.if !defined(WITH_MOZILLA)
-MOZILLA= mozilla
-HEADERS_SUFX=
-.else
-.if ${WITH_MOZILLA}=="mozilla-devel" || ${WITH_MOZILLA}=="mozilla-devel-gtk2"
-MOZILLA= ${WITH_MOZILLA}
-HEADERS_SUFX= -devel
-.else
-MOZILLA= mozilla
-HEADERS_SUFX=
-.endif
-.endif
-
-CONFIGURE_ENV+= MOZILLA_CONFIG="${X11BASE}/lib/${MOZILLA}/mozilla-config"
-PLIST_SUB+= MOZILLA_PLUGIN=""
-.else
-CONFIGURE_ENV+= MOZILLA_CONFIG="no"
-PLIST_SUB+= MOZILLA_PLUGIN="@comment "
-.endif
-
.include <bsd.port.pre.mk>
.if ${HAVE_GNOME:Mnautilus2}!=""
@@ -78,10 +52,4 @@ PLIST_SUB+= GST_PLAYER_VIEW=""
PLIST_SUB+= GST_PLAYER_VIEW="@comment "
.endif
-pre-everything::
-.ifndef (WITH_MOZILLA_PLUGIN)
- @${ECHO_MSG} "===>"
- @${ECHO_MSG} "===> Define WITH_MOZILLA_PLUGIN to compile the Mozilla plugin."
-.endif
-
.include <bsd.port.post.mk>
diff --git a/multimedia/gstreamer-player/distinfo b/multimedia/gstreamer-player/distinfo
index 450830ed1ed6..cc29acc6c36e 100644
--- a/multimedia/gstreamer-player/distinfo
+++ b/multimedia/gstreamer-player/distinfo
@@ -1,2 +1,2 @@
-MD5 (gst-player-0.6.0.tar.gz) = 8a7bc3f23b444f8ac91cc89e18ec201b
-SIZE (gst-player-0.6.0.tar.gz) = 537195
+MD5 (gst-player-0.8.0.tar.bz2) = 4b67afde07fdcf2bde0e3d9b6699465c
+SIZE (gst-player-0.8.0.tar.bz2) = 413172
diff --git a/multimedia/gstreamer-player/files/patch-configure b/multimedia/gstreamer-player/files/patch-configure
index b4052b2665d9..366f014f29ae 100644
--- a/multimedia/gstreamer-player/files/patch-configure
+++ b/multimedia/gstreamer-player/files/patch-configure
@@ -1,6 +1,6 @@
---- configure.orig Tue Oct 7 15:28:39 2003
-+++ configure Tue Oct 7 15:30:47 2003
-@@ -18452,7 +18452,8 @@
+--- configure.orig Sun Mar 21 15:03:49 2004
++++ configure Sun Mar 21 15:03:49 2004
+@@ -18471,7 +18471,8 @@
# This can be used to rebuild libtool when needed
@@ -10,24 +10,3 @@
# Always use our own libtool.
LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-@@ -20126,7 +20127,11 @@
- fi
- exec_prefix_save=$exec_prefix
- if test "x$exec_prefix" = "xNONE"; then
-+ if test "x$prefix" = "xNONE"; then
- exec_prefix=/usr/local
-+ else
-+ exec_prefix=${prefix}
-+ fi
- fi
-
- full_var="$FROM_VAR"
-@@ -21793,7 +21798,7 @@
- else
- HAVE_MOZILLA="yes"
- fi
--_mozilla_include_dir=`mozilla-config --cflags|sed 's/-I\(.*\) .*/\1/'`
-+_mozilla_include_dir=`$MOZILLA_CONFIG --cflags|sed 's/-I\(.*\) .*/\1/'`
- MOZILLA_CFLAGS="-I$_mozilla_include_dir/plugin -I$_mozilla_include_dir/java -I$_mozilla_include_dir/nspr"
-
-
diff --git a/multimedia/gstreamer-player/files/patch-mozilla::Makefile.in b/multimedia/gstreamer-player/files/patch-mozilla::Makefile.in
deleted file mode 100644
index bbdf61f6e328..000000000000
--- a/multimedia/gstreamer-player/files/patch-mozilla::Makefile.in
+++ /dev/null
@@ -1,18 +0,0 @@
---- mozilla/Makefile.in.orig Thu Nov 6 16:55:28 2003
-+++ mozilla/Makefile.in Thu Nov 6 16:56:31 2003
-@@ -215,13 +215,13 @@
- sysconfdir = @sysconfdir@
- target_alias = @target_alias@
-
--plugindir = $(libdir)/mozilla/plugins/
-+plugindir = $(libdir)/browser_plugins/
-
- plugin_LTLIBRARIES = libmozstreamer.la
-
- libmozstreamer_la_SOURCES = plugin.c
- libmozstreamer_la_CFLAGS = $(MOZILLA_CFLAGS) $(X_CFLAGS) -DBINDIR=\"$(bindir)\"
--libmozstreamer_la_LDFLAGS = $(X_LIBS)
-+libmozstreamer_la_LDFLAGS = -module -avoid-version $(X_LIBS)
- libmozstreamer_la_LIBADD = -lXt
- subdir = mozilla
- ACLOCAL_M4 = $(top_srcdir)/aclocal.m4
diff --git a/multimedia/gstreamer-player/files/patch-mozilla::plugin.c b/multimedia/gstreamer-player/files/patch-mozilla::plugin.c
deleted file mode 100644
index 7e73fa8a4152..000000000000
--- a/multimedia/gstreamer-player/files/patch-mozilla::plugin.c
+++ /dev/null
@@ -1,35 +0,0 @@
---- mozilla/plugin.c.orig Sat Jul 12 05:27:40 2003
-+++ mozilla/plugin.c Sat Nov 8 14:10:11 2003
-@@ -18,7 +18,12 @@
- */
-
- #include <stdio.h>
-+#ifdef HAVE_STDINT_H
- #include <stdint.h>
-+#else
-+#include <inttypes.h>
-+#endif
-+#include <signal.h>
- #include <unistd.h>
- #include <fcntl.h>
- #include <sys/wait.h>
-@@ -76,7 +81,7 @@
- dup2(fds[2],0);
- //dup2(fds[1],1);
-
-- argv[argc++] = "gst-player";
-+ argv[argc++] = "gst-player-gtk";
- argv[argc++] = "--xid";
- argv[argc++] = xid_str;
- if(plugin->width){
-@@ -92,8 +97,8 @@
- argv[argc++] = "fd://0";
- argv[argc] = NULL;
-
-- execvp("gst-player",argv);
-- execv(BINDIR "gst-player",argv);
-+ execvp("gst-player-gtk",argv);
-+ execv(BINDIR "gst-player-gtk",argv);
- _exit(255);
- }
-
diff --git a/multimedia/gstreamer-player/pkg-descr b/multimedia/gstreamer-player/pkg-descr
index bc9dd314888a..9b132c975b59 100644
--- a/multimedia/gstreamer-player/pkg-descr
+++ b/multimedia/gstreamer-player/pkg-descr
@@ -1,3 +1,3 @@
-Simple yet functional mediaplayer written with GStreamer
+Simple yet functional media player driven by GStreamer.
WWW: http://gstreamer.sourceforge.net/
diff --git a/multimedia/gstreamer-player/pkg-plist b/multimedia/gstreamer-player/pkg-plist
index 34cac6adbd5c..0ee551a460a0 100644
--- a/multimedia/gstreamer-player/pkg-plist
+++ b/multimedia/gstreamer-player/pkg-plist
@@ -1,11 +1,9 @@
bin/gst-player
-bin/gst-player-gtk
etc/gconf/gconf.xml.defaults/apps/gst-player/%gconf.xml
etc/gconf/gconf.xml.defaults/schemas/apps/gst-player/%gconf.xml
etc/gconf/schemas/gst-player.schemas
include/gst-player-%%VERSION%%/gst/gstvideowidget.h
include/gst-player-%%VERSION%%/gst/gtk-playlist.h
-%%MOZILLA_PLUGIN%%lib/browser_plugins/libmozstreamer.so
lib/libgstplayer.a
lib/libgstplayer.so
lib/libgstplayer.so.%%SHLIB_VERSION%%