aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-10-28 08:08:25 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2020-10-28 08:08:25 +0000
commitd7b9c29126078e75525afc51a1394cad7518b3e5 (patch)
treec23f75e568efab886c6a73bec332edb7746b61b4 /multimedia
parent9ab8559e3cd81afe3e1f6562297e42a21e939c03 (diff)
downloadports-d7b9c29126078e75525afc51a1394cad7518b3e5.tar.gz
ports-d7b9c29126078e75525afc51a1394cad7518b3e5.zip
Notes
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/motion/Makefile39
-rw-r--r--multimedia/motion/distinfo6
2 files changed, 27 insertions, 18 deletions
diff --git a/multimedia/motion/Makefile b/multimedia/motion/Makefile
index 7ecca60cd32b..2ee53cf16694 100644
--- a/multimedia/motion/Makefile
+++ b/multimedia/motion/Makefile
@@ -1,22 +1,31 @@
# Created by: Angel Carpintero <ack@telefonica.net>
# $FreeBSD$
+# PORTNAME block
PORTNAME= motion
-PORTVERSION= 4.3.1
+PORTVERSION= 4.3.2
DISTVERSIONPREFIX= release-
CATEGORIES= multimedia
+# Maintainer block
MAINTAINER= ports@blievers.net
COMMENT= Motion detection application
+# License block
LICENSE= GPLv2+
LICENSE_FILE= ${WRKSRC}/doc/COPYING
+# Dependencies
LIB_DEPENDS= libwebp.so:graphics/webp \
libmicrohttpd.so:www/libmicrohttpd
+# USES block
USES= autoreconf gmake jpeg localbase pkgconfig gettext
+KMODDIR?= /boot/modules
+.if ${KMODDIR} == /boot/kernel
+KMODDIR= /boot/modules
+.endif
USE_GITHUB= yes
GH_ACCOUNT= Motion-Project
USE_RC_SUBR= ${PORTNAME}
@@ -25,13 +34,10 @@ GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-linuxthreads \
--without-jpeg-mmx
-KMODDIR?= /boot/modules
-.if ${KMODDIR} == /boot/kernel
-KMODDIR= /boot/modules
-.endif
-
+# Standard bsd.port.mk variables
SUB_FILES= pkg-message
+# Packaging list block
PLIST_FILES= bin/motion \
man/man1/motion.1.gz \
"@sample ${ETCDIR}/motion.conf.sample" \
@@ -41,25 +47,20 @@ PORTDOCS= *
PORTEXAMPLES= camera1-dist.conf camera2-dist.conf \
camera3-dist.conf camera4-dist.conf
+# Options definitions
OPTIONS_DEFINE= DOCS EXAMPLES FFMPEG MYSQL PGSQL SQLITE3
+OPTIONS_DEFAULT= WEBCAMD FFMPEG
OPTIONS_RADIO= VIDEO
OPTIONS_RADIO_VIDEO= BKTR PWCBSD WEBCAMD
-OPTIONS_DEFAULT= WEBCAMD FFMPEG
-VIDEO_DESC= Video capture driver (Netcam support only if none selected)
BKTR_DESC= BKTR based TV capture cards
-BKTR_CONFIGURE_WITH= bktr
PWCBSD_DESC= PWCBSD based Webcams
-PWCBSD_BUILD_DEPENDS= v4l_compat>=1.0.20060801:multimedia/v4l_compat
-PWCBSD_RUN_DEPENDS= ${KMODDIR}/pwc.ko:multimedia/pwcbsd
-PWCBSD_CONFIGURE_WITH= pwcbsd
+VIDEO_DESC= Video capture driver (Netcam support only if none selected)
WEBCAMD_DESC= Webcams using webcamd
-WEBCAMD_BUILD_DEPENDS= v4l_compat>=1.0.20060801:multimedia/v4l_compat
-# note: all configure --with-pwcbsd does is not shut off v4l support
-WEBCAMD_CONFIGURE_WITH= pwcbsd
+BKTR_CONFIGURE_WITH= bktr
FFMPEG_LIB_DEPENDS= libavformat.so:multimedia/ffmpeg
FFMPEG_CONFIGURE_ON= --with-ffmpeg=${LOCALBASE}
FFMPEG_CONFIGURE_OFF= --without-ffmpeg
@@ -74,9 +75,17 @@ PGSQL_CONFIGURE_ON= --with-pgsql-lib=${LOCALBASE}/lib \
--with-pgsql-include=${LOCALBASE}/include
PGSQL_CONFIGURE_OFF= --without-pgsql
+PWCBSD_BUILD_DEPENDS= v4l_compat>=1.0.20060801:multimedia/v4l_compat
+PWCBSD_RUN_DEPENDS= ${KMODDIR}/pwc.ko:multimedia/pwcbsd
+PWCBSD_CONFIGURE_WITH= pwcbsd
+
SQLITE3_USES= sqlite:3
SQLITE3_CONFIGURE_WITH= sqlite3
+WEBCAMD_BUILD_DEPENDS= v4l_compat>=1.0.20060801:multimedia/v4l_compat
+# note: all configure --with-pwcbsd does is not shut off v4l support
+WEBCAMD_CONFIGURE_WITH= pwcbsd
+
.include <bsd.port.pre.mk>
.if ${JPEG_PORT} == "graphics/jpeg-turbo"
diff --git a/multimedia/motion/distinfo b/multimedia/motion/distinfo
index 815a398e87ef..33c442065554 100644
--- a/multimedia/motion/distinfo
+++ b/multimedia/motion/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1587178233
-SHA256 (Motion-Project-motion-release-4.3.1_GH0.tar.gz) = 545712b10fc4a0134e994b7d8a3773c1c22f0bf4bd7afea7d7ffff357aca9ea5
-SIZE (Motion-Project-motion-release-4.3.1_GH0.tar.gz) = 849633
+TIMESTAMP = 1603754625
+SHA256 (Motion-Project-motion-release-4.3.2_GH0.tar.gz) = dafa4264b2d8e4778f8be5871f09b6c0ec710d5a836182c583469c18db944d70
+SIZE (Motion-Project-motion-release-4.3.2_GH0.tar.gz) = 849378