aboutsummaryrefslogtreecommitdiff
path: root/multimedia
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-25 18:32:27 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2021-02-25 18:32:27 +0000
commit2c78b9754cd0638c4ba990970302077829c534b1 (patch)
tree5959688e073a6f80d1b08637f320c32e2551efad /multimedia
parentacefe46b40b398d8c35da5187f799fd739e1e27f (diff)
downloadports-2c78b9754cd0638c4ba990970302077829c534b1.tar.gz
ports-2c78b9754cd0638c4ba990970302077829c534b1.zip
MFH: r560298 r560302 r561371 r562151 r562559 r563142 r563143 r563149 r565356 r565465 r566011 r566182
finance/quickfix: fix build on non-x86 Code uses x86 assembly, but makes it possible to use Boost atomic. multimedia/zoneminder: enable on powerpc64 net/mpich: fix build on powerpc64 Neither __BYTE_ORDER nor __BIG_ENDIAN are defined: In file included from src/mpi/datatype/typerep/dataloop/looputil.c:10: ./src/mpi/datatype/typerep/dataloop/looputil.h:57:2: error: This code assumes that __BYTE_ORDER and __BIG_ENDIAN are defined #error This code assumes that __BYTE_ORDER and __BIG_ENDIAN are defined editors/libreoffice: fix build on powerpc64 elfv2 This set of patches is applied only on powerpc* architectures. Submitted by: afsilva Approved by: tier 2 blanket security/openconnect-gui: fix checksum emulators/riscv-isa-sim: enable on powerpc64 sysutils/linuxfdisk: enable on powerpc64 graphics/openfx-arena: enable on powerpc64 multimedia/arcan: enable LUAJIT on powerpc64 It builds fine with luajit-openresty. games/libretro-desmume2015: fix build on non-x86 / ARM JIT is only for x86 and ARM. astro/opencpn: fix build on powerpc64* Use GCC unconditionally on powerpc64*: In file included from /usr/lib/clang/11.0.1/include/xmmintrin.h:13: /usr/lib/clang/11.0.1/include/mmintrin.h:33:5: error: use of undeclared identifier '__builtin_ia32_emms'; did you mean '__builtin_isless'? __builtin_ia32_emms(); editors/libreoffice6: backport powerpc* patches to libreoffice6 Approved by: tier 2 blanket
Notes
Notes: svn path=/branches/2021Q1/; revision=566549
Diffstat (limited to 'multimedia')
-rw-r--r--multimedia/arcan/Makefile2
-rw-r--r--multimedia/zoneminder/Makefile2
2 files changed, 2 insertions, 2 deletions
diff --git a/multimedia/arcan/Makefile b/multimedia/arcan/Makefile
index 8df58c83140a..8ab39a41627e 100644
--- a/multimedia/arcan/Makefile
+++ b/multimedia/arcan/Makefile
@@ -2,6 +2,7 @@
PORTNAME= arcan
DISTVERSION= 0.6.0.1
+PORTREVISION= 1
CATEGORIES= multimedia
MAINTAINER= jbeich@FreeBSD.org
@@ -32,7 +33,6 @@ LDFLAGS_i386= -Wl,-z,notext
OPTIONS_DEFINE= ESPEAK FFMPEG LUAJIT SDL SUID TESSERACT UVC VLC VNC WAYLAND
OPTIONS_DEFAULT=ESPEAK FFMPEG LUAJIT SDL SUID TESSERACT UVC VLC VNC WAYLAND
OPTIONS_EXCLUDE_aarch64= LUAJIT # bug 225342
-OPTIONS_EXCLUDE_powerpc64= LUAJIT
OPTIONS_SUB= yes
ESPEAK_DESC= Text to speech via eSpeak
diff --git a/multimedia/zoneminder/Makefile b/multimedia/zoneminder/Makefile
index 12f0605c4fae..a08710342c79 100644
--- a/multimedia/zoneminder/Makefile
+++ b/multimedia/zoneminder/Makefile
@@ -10,7 +10,7 @@ COMMENT= Complete security camera solution, fully web based with image analysis
LICENSE= GPLv2
-ONLY_FOR_ARCHS= aarch64 amd64 i386
+ONLY_FOR_ARCHS= aarch64 amd64 i386 powerpc64
ZM_DEPENDS= p5-DBI>=0:databases/p5-DBI \
p5-DBD-mysql>=0:databases/p5-DBD-mysql \