aboutsummaryrefslogtreecommitdiff
path: root/net-im/ayttm/Makefile
diff options
context:
space:
mode:
authorPav Lucistnik <pav@FreeBSD.org>2009-06-30 14:56:40 +0000
committerPav Lucistnik <pav@FreeBSD.org>2009-06-30 14:56:40 +0000
commit567065c0e9083dba8f43501a2912318c8bcba25d (patch)
tree215820b150dc6202eccd77639d06aa904ce14f2e /net-im/ayttm/Makefile
parent9a1d9dbc5259072b087adfdeb244294672ea6be5 (diff)
- Update to 0.5.082
PR: ports/136174 Submitted by: Carlos A. M. dos Santos <unixmania@gmail.com>
Notes
Notes: svn path=/head/; revision=236819
Diffstat (limited to 'net-im/ayttm/Makefile')
-rw-r--r--net-im/ayttm/Makefile26
1 files changed, 22 insertions, 4 deletions
diff --git a/net-im/ayttm/Makefile b/net-im/ayttm/Makefile
index 88ba714c2478..a7e98fb5d283 100644
--- a/net-im/ayttm/Makefile
+++ b/net-im/ayttm/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ayttm
-PORTVERSION= 0.5.0.45
-PORTREVISION= 1
+PORTVERSION= 0.5.0.82
CATEGORIES= net-im
MASTER_SITES= SF
DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
@@ -20,8 +19,10 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
gpgme.17:${PORTSDIR}/security/gpgme \
pspell.16:${PORTSDIR}/textproc/aspell
-OPTIONS= ARTS "Enable aRts support" off \
- ESOUND "Enable EsounD support" off
+OPTIONS= ARTS "Enable aRts support" off \
+ ESOUND "Enable EsounD support" off \
+ AIM_TOC "Include aim-toc service" off \
+ ICQ_TOC "Include icq-toc service" off
USE_BZIP2= yes
USE_XORG= xpm xscrnsaver
@@ -51,6 +52,20 @@ USE_GNOME+= esound
CONFIGURE_ARGS+= --disable-esd
.endif
+.if defined(WITH_AIM_TOC)
+CONFIGURE_ARGS+= --enable-aim-toc
+PLIST_SUB+= AIM_TOC=""
+.else
+PLIST_SUB+= AIM_TOC="@comment "
+.endif
+
+.if defined(WITH_ICQ_TOC)
+CONFIGURE_ARGS+= --enable-icq-toc
+PLIST_SUB+= ICQ_TOC=""
+.else
+PLIST_SUB+= ICQ_TOC="@comment "
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-L/usr/local/lib||g ; \
s|-lpthread|${PTHREAD_LIBS}|g ; \
@@ -63,4 +78,7 @@ post-patch:
's|-L/usr/local/lib/pth/||g ; \
s|-lproxy|../libproxy/libproxy.a|g' ${WRKSRC}/src/Makefile.in
+post-build:
+ @${ECHO} 'Categories=Application;Network;' >> ${WRKSRC}/ayttm.desktop
+
.include <bsd.port.post.mk>