aboutsummaryrefslogtreecommitdiff
path: root/net-im/ayttm/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2004-08-02 20:21:30 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2004-08-02 20:21:30 +0000
commitbdd50664c36c8a3750fec985413a91502c34f879 (patch)
treeb54bbcc02422d83850f074240f038c29e11cddff /net-im/ayttm/Makefile
parente588f907e634e393a68fdd740891bac8e86bb7b5 (diff)
Update to version 0.4.6-17
PR: ports/69922 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=115303
Diffstat (limited to 'net-im/ayttm/Makefile')
-rw-r--r--net-im/ayttm/Makefile15
1 files changed, 10 insertions, 5 deletions
diff --git a/net-im/ayttm/Makefile b/net-im/ayttm/Makefile
index 2fd843e52684..7d432964876b 100644
--- a/net-im/ayttm/Makefile
+++ b/net-im/ayttm/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= ayttm
-PORTVERSION= 0.4.6
-PORTREVISION= 1
+PORTVERSION= 0.4.6.17
CATEGORIES= net
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= ${PORTNAME}-${PORTVERSION:R}-${PORTVERSION:E}
MAINTAINER= ports@FreeBSD.org
COMMENT= A "chat" program that combines AIM, ICQ, and Yahoo! Chat into one
@@ -20,17 +20,19 @@ LIB_DEPENDS= audiofile.0:${PORTSDIR}/audio/libaudiofile \
gpgme.9:${PORTSDIR}/security/gpgme \
pspell.15:${PORTSDIR}/textproc/aspell
-USE_LIBLTDL= yes
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION:R}
+
USE_BZIP2= yes
-USE_GCC= 3.2
+USE_GCC= 3.3
USE_X_PREFIX= yes
WANT_GNOME= yes
USE_GNOME= gdkpixbuf gnometarget lthack
USE_OPENSSL= yes
USE_GETOPT_LONG= yes
+USE_LIBLTDL= yes
USE_REINPLACE= yes
USE_GMAKE= yes
-USE_LIBTOOL_VER=13
+USE_LIBTOOL_VER= 13
LIBTOOLFLAGS= # none
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
CONFIGURE_ARGS= --enable-smtp --enable-jasper-filter
@@ -77,5 +79,8 @@ pre-everything::
post-patch:
@${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS:S/"//g}|g; \
s|-pthread|${PTHREAD_CFLAGS:S/"//g}|g' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e 's|= pixmaps|=|g ; \
+ s|^Utilities|#Utilities|g ; \
+ s|^gnome|#gnome|g' ${WRKSRC}/Makefile.in
.include <bsd.port.post.mk>