aboutsummaryrefslogtreecommitdiff
path: root/net-im/decibel
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2008-02-10 16:49:16 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2008-02-10 16:49:16 +0000
commit8fcf752444a95cf653c5fd3cc2db79d5d7ee7000 (patch)
treecbba25ae520a598ea38d830c0ec4ab50aa6a1eac /net-im/decibel
parentc868453a7709a1ff780cf7d7fe5bbef9367d0b9d (diff)
downloadports-8fcf752444a95cf653c5fd3cc2db79d5d7ee7000.tar.gz
ports-8fcf752444a95cf653c5fd3cc2db79d5d7ee7000.zip
Notes
Diffstat (limited to 'net-im/decibel')
-rw-r--r--net-im/decibel/Makefile42
-rw-r--r--net-im/decibel/distinfo3
-rw-r--r--net-im/decibel/pkg-descr13
-rw-r--r--net-im/decibel/pkg-plist41
4 files changed, 99 insertions, 0 deletions
diff --git a/net-im/decibel/Makefile b/net-im/decibel/Makefile
new file mode 100644
index 000000000000..9da5ac8c12dd
--- /dev/null
+++ b/net-im/decibel/Makefile
@@ -0,0 +1,42 @@
+# New ports collection Makefile for: decibel
+# Date created: 2008-02-10
+# Whom: arved
+#
+# $FreeBSD$
+
+PORTNAME= decibel
+PORTVERSION= 0.5.0
+CATEGORIES= net-im
+MASTER_SITES= http://decibel.kde.org/fileadmin/downloads/decibel/releases/
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Realtime communications framework
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+LIB_DEPENDS= QtTapioca.0:${PORTSDIR}/net-im/tapioca-qt
+
+USE_QT_VER= 4
+QT_COMPONENTS= corelib xml dbus moc uic rcc
+USE_LDCONFIG= yes
+
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/build
+CMAKE?= ${LOCALBASE}/bin/cmake
+CMAKE_ARGS= -DCMAKE_BUILD_TYPE=DEBUG \
+ -DCMAKE_INSTALL_PREFIX=${PREFIX} \
+ -DCMAKE_C_COMPILER:STRING='${CC}' \
+ -DCMAKE_C_FLAGS:STRING="${CFLAGS}" \
+ -DCMAKE_CXX_COMPILER:STRING=${CXX} \
+ -DCMAKE_CXX_FLAGS:STRING="${CXXFLAGS}"
+
+post-extract:
+ ${MKDIR} ${WRKSRC}
+
+post-patch:
+ ${REINPLACE_CMD} -e \
+ "s,$${LIB_INSTALL_DIR}/pkgconfig,data/pkgconfig,g"\
+ ${WRKSRC}/../src/client/Decibel/CMakeLists.txt
+
+do-configure:
+ cd ${WRKSRC}; ${SETENV} ${CONFIGURE_ENV} ${CMAKE} ${CMAKE_ARGS} ..
+
+.include <bsd.port.mk>
diff --git a/net-im/decibel/distinfo b/net-im/decibel/distinfo
new file mode 100644
index 000000000000..609b0bfc876a
--- /dev/null
+++ b/net-im/decibel/distinfo
@@ -0,0 +1,3 @@
+MD5 (decibel-0.5.0.tar.gz) = 7de299ace568c87a746388ad765228e5
+SHA256 (decibel-0.5.0.tar.gz) = e463e79e92dbfd1d987d22af4d432166f54e81c74916b540fdb79216b5d2711f
+SIZE (decibel-0.5.0.tar.gz) = 135664
diff --git a/net-im/decibel/pkg-descr b/net-im/decibel/pkg-descr
new file mode 100644
index 000000000000..8dc7e45fa4c2
--- /dev/null
+++ b/net-im/decibel/pkg-descr
@@ -0,0 +1,13 @@
+Decibel is a realtime communications framework, integrating services
+like CTI (Computer Telephone Integration), VoIP (Voice over IP), text
+based chat and instant messaging.
+Desktop users find in Decibel one central place to manage all their
+realtime communication settings and can easily configure and change responses
+to communication requests.
+By providing a simple, DBus-based API to the services like communication
+accountmanagement, connection to contacts, etc. Decibel reduces the
+complexity and effort of accessing realtime communication technologies in
+applications. This allows for integration of realtime communication
+technologies into applications that are not focused on communication.
+
+WWW: http://decibel.kde.org
diff --git a/net-im/decibel/pkg-plist b/net-im/decibel/pkg-plist
new file mode 100644
index 000000000000..396e09f43c58
--- /dev/null
+++ b/net-im/decibel/pkg-plist
@@ -0,0 +1,41 @@
+bin/decibel
+bin/decibel_logger
+include/Decibel/AccountData
+include/Decibel/AccountManager
+include/Decibel/ChannelHandler
+include/Decibel/ComponentManager
+include/Decibel/ContactManager
+include/Decibel/DBusNames
+include/Decibel/Errors
+include/Decibel/ProtocolManager
+include/Decibel/Types
+include/Decibel/accountdata.h
+include/Decibel/accountmanager.h
+include/Decibel/channelhandler.h
+include/Decibel/componentmanager.h
+include/Decibel/contactmanager.h
+include/Decibel/dbusnames.h
+include/Decibel/decibel_export.h
+include/Decibel/errors.h
+include/Decibel/protocolmanager.h
+include/Decibel/types.h
+lib/Decibel/decibel_chatstarter_demo
+lib/Decibel/decibel_defaultcmfor_demo
+lib/Decibel/decibel_deleteaccount_demo
+lib/Decibel/decibel_listaccounts_demo
+lib/Decibel/decibel_listcms_demo
+lib/Decibel/decibel_listcmsfor_demo
+lib/Decibel/decibel_phonestarter_demo
+lib/Decibel/decibel_registeraccount_demo
+lib/Decibel/decibel_setdefaultcmfor_demo
+lib/Decibel/decibel_setpresence_demo
+lib/Decibel/decibel_simpleclient_demo
+lib/Decibel/decibel_supportedprotocols_demo
+lib/libdecibel.so.0.5.0
+lib/libdecibel.so
+libdata/pkgconfig/Decibel.pc
+share/Decibel/components/de.basyskom.decibellogger.component
+share/Decibel/components/de.basyskom.simpleclient.textchannel.component
+share/dbus-1/services/de.basyskom.decibel.log.service
+share/dbus-1/services/de.basyskom.simpleclient.service
+share/doc/Decibel/demos.html