aboutsummaryrefslogtreecommitdiff
path: root/net-im/ejabberd/Makefile
diff options
context:
space:
mode:
authorShaun Amott <shaun@FreeBSD.org>2006-10-05 19:11:40 +0000
committerShaun Amott <shaun@FreeBSD.org>2006-10-05 19:11:40 +0000
commitf2f0e0ebba28bad1c8292749eb716bc0121702b7 (patch)
tree1c062a03312c8afd1841c505381a2f2dc45a5d2a /net-im/ejabberd/Makefile
parentde6a9109677552a4deaf9d2533da4c1d94d62a3c (diff)
Notes
Diffstat (limited to 'net-im/ejabberd/Makefile')
-rw-r--r--net-im/ejabberd/Makefile19
1 files changed, 15 insertions, 4 deletions
diff --git a/net-im/ejabberd/Makefile b/net-im/ejabberd/Makefile
index 837bb9ff0e77..6567b6ea6165 100644
--- a/net-im/ejabberd/Makefile
+++ b/net-im/ejabberd/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= ejabberd
-PORTVERSION= 1.1.1
-PORTREVISION= 2
+PORTVERSION= 1.1.2
CATEGORIES= net-im
MASTER_SITES= http://www.process-one.net/en/projects/ejabberd/download/${PORTVERSION}/ \
http://mirror.inerd.com/FreeBSD/distfiles/${PORTNAME}/
@@ -15,6 +14,8 @@ MASTER_SITES= http://www.process-one.net/en/projects/ejabberd/download/${PORTVER
MAINTAINER= shaun@FreeBSD.org
COMMENT= Free and Open Source distributed fault-tolerant Jabber server
+OPTIONS= ODBC "Enable ODBC support" off
+
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
RUN_DEPENDS= erl:${PORTSDIR}/lang/erlang
LIB_DEPENDS= expat.6:${PORTSDIR}/textproc/expat2
@@ -33,8 +34,18 @@ SUB_FILES= ${PORTNAME} pkg-message
SUB_LIST= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+.include <bsd.port.pre.mk>
+
+.if defined(WITH_ODBC)
+CONFIGURE_ARGS+=--enable-odbc
+PLIST_SUB+= ODBC=""
+.else
+PLIST_SUB+= ODBC="@comment "
+.endif
+
pre-install:
- ${FIND} ${WRKSRC} '(' -name \*.orig -or -name \*.bak ')' -delete
+ @${FIND} ${WRKSRC} '(' -name \*.orig -or -name \*.bak ')' -delete
+ @${RM} -f ${WRKSRC}/../doc/release_note_1.1.2.txt
post-install:
${INSTALL_SCRIPT} ${WRKDIR}/${PORTNAME} ${WRKSRC}/../tools/${PORTNAME}ctl ${PREFIX}/bin
@@ -56,4 +67,4 @@ post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
@${CAT} ${PKGMESSAGE}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>