aboutsummaryrefslogtreecommitdiff
path: root/net-im/ejabberd/Makefile
diff options
context:
space:
mode:
authorAshish SHUKLA <ashish@FreeBSD.org>2010-07-13 23:35:07 +0000
committerAshish SHUKLA <ashish@FreeBSD.org>2010-07-13 23:35:07 +0000
commit2bc822d8e8b19083fd7a9feac80eb48e88cbd7ed (patch)
tree98079bcc21e21df035d95e531320aabf835bd53e /net-im/ejabberd/Makefile
parente43e99ec48bd82b17afd5ec93a36f8fe549a44d9 (diff)
downloadports-2bc822d8e8b19083fd7a9feac80eb48e88cbd7ed.tar.gz
ports-2bc822d8e8b19083fd7a9feac80eb48e88cbd7ed.zip
Notes
Diffstat (limited to 'net-im/ejabberd/Makefile')
-rw-r--r--net-im/ejabberd/Makefile13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-im/ejabberd/Makefile b/net-im/ejabberd/Makefile
index 58136f025549..b54629b7ba1c 100644
--- a/net-im/ejabberd/Makefile
+++ b/net-im/ejabberd/Makefile
@@ -6,11 +6,11 @@
#
PORTNAME= ejabberd
-PORTVERSION= 2.1.3
+PORTVERSION= 2.1.4
CATEGORIES= net-im
MASTER_SITES= http://www.process-one.net/downloads/ejabberd/${PORTVERSION}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ashish@FreeBSD.org
COMMENT= Free and Open Source distributed fault-tolerant Jabber server
BUILD_DEPENDS= erlc:${PORTSDIR}/lang/erlang
@@ -35,6 +35,9 @@ SUB_FILES= pkg-message pkg-install
SUB_LIST= PORTNAME=${PORTNAME} PORTVERSION=${PORTVERSION}
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/src
+LICENSE= GPLv2
+LICENSE_FILE= ${WRKDIR}/${PORTNAME}-${PORTVERSION}/COPYING
+
.include <bsd.port.pre.mk>
.if defined(WITH_ODBC)
@@ -44,6 +47,12 @@ PLIST_SUB+= ODBC=""
PLIST_SUB+= ODBC="@comment "
.endif
+post-patch:
+.ifdef NOPORTDOCS
+ @${REINPLACE_CMD} -e '/DOCDIR)$$/s/^/#/g' ${WRKSRC}/Makefile.in
+.endif
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' ${WRKSRC}/configure
+
post-install:
@PKG_PREFIX=${PREFIX} ${SH} ${PKGINSTALL} ${PKGNAME} POST-INSTALL
${FIND} ${PREFIX}/lib/erlang/lib/${DISTNAME} -type f -print0 | ${XARGS} -0 ${CHMOD} ${SHAREMODE}