aboutsummaryrefslogtreecommitdiff
path: root/net-im/empathy
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/empathy
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'net-im/empathy')
-rw-r--r--net-im/empathy/Makefile71
-rw-r--r--net-im/empathy/distinfo4
-rw-r--r--net-im/empathy/files/patch-configure75
-rw-r--r--net-im/empathy/files/patch-libempathy_empathy-auth-factory.c10
-rw-r--r--net-im/empathy/files/patch-src_empathy-chat-window.c11
-rw-r--r--net-im/empathy/files/patch-src_empathy-status-icon.c13
-rw-r--r--net-im/empathy/pkg-plist4
7 files changed, 53 insertions, 135 deletions
diff --git a/net-im/empathy/Makefile b/net-im/empathy/Makefile
index ddf9c981d350..f8c3d7dca79a 100644
--- a/net-im/empathy/Makefile
+++ b/net-im/empathy/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: empathy
-# Date created: 2007-10-29
-# Whom: Michael Johnson <ahze@FreeBSD.org>
-#
+# Created by: Michael Johnson <ahze@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net-im/empathy/Makefile,v 1.76 2010/11/18 18:04:55 kwm Exp $
+# $MCom: ports/net-im/empathy/Makefile,v 1.90 2012/08/17 19:06:45 kwm Exp $
PORTNAME= empathy
-PORTVERSION= 2.32.2
+PORTVERSION= 2.34.0
PORTREVISION= 3
CATEGORIES= net-im gnome
MASTER_SITES= GNOME
@@ -17,20 +14,22 @@ COMMENT= GNOME IM client based around telepathy
BUILD_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss \
${LOCALBASE}/libexec/mission-control-5:${PORTSDIR}/net-im/telepathy-mission-control
-LIB_DEPENDS= enchant.1:${PORTSDIR}/textproc/enchant \
- telepathy.2:${PORTSDIR}/net-im/libtelepathy \
- telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib \
- telepathy-farsight.0:${PORTSDIR}/net-im/telepathy-farsight \
- telepathy-logger.1:${PORTSDIR}/net-im/telepathy-logger \
- folks-telepathy.16:${PORTSDIR}/net-im/folks \
- gcr.0:${PORTSDIR}/security/gnome-keyring \
- notify.4:${PORTSDIR}/devel/libnotify \
- unique-1.0.2:${PORTSDIR}/x11-toolkits/unique \
- canberra-gtk.0:${PORTSDIR}/audio/libcanberra
+LIB_DEPENDS= enchant:${PORTSDIR}/textproc/enchant \
+ telepathy:${PORTSDIR}/net-im/libtelepathy \
+ telepathy-glib:${PORTSDIR}/net-im/telepathy-glib \
+ telepathy-farsight:${PORTSDIR}/net-im/telepathy-farsight \
+ telepathy-logger:${PORTSDIR}/net-im/telepathy-logger \
+ folks-telepathy:${PORTSDIR}/net-im/folks04 \
+ unique-1.0:${PORTSDIR}/x11-toolkits/unique \
+ notify:${PORTSDIR}/devel/libnotify \
+ gcr:${PORTSDIR}/security/gnome-keyring \
+ canberra-gtk:${PORTSDIR}/audio/libcanberra
RUN_DEPENDS= ${LOCALBASE}/libdata/pkgconfig/iso-codes.pc:${PORTSDIR}/misc/iso-codes \
${LOCALBASE}/share/certs/ca-root-nss.crt:${PORTSDIR}/security/ca_root_nss \
${LOCALBASE}/libexec/mission-control-5:${PORTSDIR}/net-im/telepathy-mission-control
+CONFLICTS= empathy-3.[0-9]*
+
USE_GMAKE= yes
USE_BZIP2= yes
USE_GETTEXT= yes
@@ -51,39 +50,39 @@ GLIB_SCHEMAS= org.gnome.Empathy.gschema.xml
MAN1= empathy.1 empathy-accounts.1
-OPTIONS= JABBER "Enable jabber (XMPP) client support" on \
- MSN "Enable MSN client support" on \
- IRC "Enable IRC client support" on \
- SALUT "Enable link-local (serverless) XMPP support" off \
- HAZE "Enable libpurple protocol integration" off \
- WEBKIT "Enable Adium Message Style themes" on \
- NST "Enable Nautilus SendTo plugin" on \
- MAP "Enable graphical map support" on
+OPTIONS_DEFINE= JABBER MSN IRC SALUT HAZE WEBKIT NST MAP
+OPTIONS_DEFAULT=JABBER MSN IRC WEBKIT NST MAP
+MSN_DESC= MSN client support
+IRC_DESC= IRC client support
+SALUT_DESC= Link-local (serverless) XMPP support
+HAZE_DESC= Libpurple protocol integration
+NST_DESC= Nautilus SendTo plugin
+MAP_DESC= Graphical map support
-.include <bsd.port.pre.mk>
+.include <bsd.port.options.mk>
-.if defined(WITH_JABBER)
+.if ${PORT_OPTIONS:MJABBER}
RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-gabble:${PORTSDIR}/net-im/telepathy-gabble
.endif
-.if defined(WITH_MSN)
+.if ${PORT_OPTIONS:MMSN}
RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-butterfly:${PORTSDIR}/net-im/telepathy-butterfly
.endif
-.if defined(WITH_IRC)
+.if ${PORT_OPTIONS:MIRC}
RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-idle:${PORTSDIR}/net-im/telepathy-idle
.endif
-.if !defined(WITHOUT_SALUT)
+.if ${PORT_OPTIONS:MSALUT}
RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-salut:${PORTSDIR}/net-im/telepathy-salut
.endif
-.if !defined(WITHOUT_HAZE)
+.if ${PORT_OPTIONS:MHAZE}
RUN_DEPENDS+= ${LOCALBASE}/libexec/telepathy-haze:${PORTSDIR}/net-im/telepathy-haze
.endif
-.if defined(WITH_WEBKIT)
-LIB_DEPENDS+= webkitgtk-1.0.0:${PORTSDIR}/www/webkit-gtk2
+.if ${PORT_OPTIONS:MWEBKIT}
+LIB_DEPENDS+= webkitgtk-1.0:${PORTSDIR}/www/webkit-gtk2
CONFIGURE_ARGS+=--enable-webkit
PLIST_SUB+= ADIUM=""
.else
@@ -91,7 +90,7 @@ CONFIGURE_ARGS+=--disable-webkit
PLIST_SUB+= ADIUM="@comment "
.endif
-.if defined(WITH_NST)
+.if ${PORT_OPTIONS:MNST}
BUILD_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/nautilus-sendto.pc:${PORTSDIR}/deskutils/nautilus-sendto
RUN_DEPENDS+= ${LOCALBASE}/libdata/pkgconfig/nautilus-sendto.pc:${PORTSDIR}/deskutils/nautilus-sendto
CONFIGURE_ARGS+=--enable-nautilus-sendto=yes
@@ -101,8 +100,8 @@ CONFIGURE_ARGS+=--enable-nautilus-sendto=no
PLIST_SUB+= NST="@comment "
.endif
-.if !defined(WITHOUT_MAP)
-LIB_DEPENDS+= champlain-0.8.1:${PORTSDIR}/graphics/libchamplain
+.if ${PORT_OPTIONS:MMAP}
+LIB_DEPENDS+= champlain-0.8:${PORTSDIR}/graphics/libchamplain
CONFIGURE_ARGS+=--enable-map
PLIST_SUB+= MAP=""
.else
@@ -110,4 +109,4 @@ CONFIGURE_ARGS+=--disable-map
PLIST_SUB+= MAP="@comment "
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/empathy/distinfo b/net-im/empathy/distinfo
index aef3ef0e3e1f..1cfcc35b5f86 100644
--- a/net-im/empathy/distinfo
+++ b/net-im/empathy/distinfo
@@ -1,2 +1,2 @@
-SHA256 (empathy-2.32.2.tar.bz2) = f90a45955205fd8bd783a55acae4603197caab4f16a880106f8639cbbbe5e861
-SIZE (empathy-2.32.2.tar.bz2) = 2936340
+SHA256 (empathy-2.34.0.tar.bz2) = 6efa0ae3ac3580ac9600f889c92497f36983e22da79d547a65030a14691369d1
+SIZE (empathy-2.34.0.tar.bz2) = 3361496
diff --git a/net-im/empathy/files/patch-configure b/net-im/empathy/files/patch-configure
index 9bf98699b386..300f783e450a 100644
--- a/net-im/empathy/files/patch-configure
+++ b/net-im/empathy/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2011-08-16 16:19:02.000000000 +0200
-+++ configure 2011-08-16 16:19:59.000000000 +0200
+--- configure.orig 2010-11-18 17:41:43.000000000 +0100
++++ configure 2010-11-18 17:41:43.000000000 +0100
@@ -13390,8 +13390,8 @@
.SECONDARY: $(gsettings_SCHEMAS)
@@ -11,74 +11,3 @@
install-gsettings-schemas: $(gsettings_SCHEMAS:.xml=.valid)
@$(NORMAL_INSTALL)
-@@ -14771,14 +14771,14 @@
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnotify >= \$LIBNOTIFY_REQUIRED
-- libnotify < 0.7\""; } >&5
-+ libnotify < 0.9\""; } >&5
- ($PKG_CONFIG --exists --print-errors "libnotify >= $LIBNOTIFY_REQUIRED
-- libnotify < 0.7") 2>&5
-+ libnotify < 0.9") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_LIBNOTIFY_CFLAGS=`$PKG_CONFIG --cflags "libnotify >= $LIBNOTIFY_REQUIRED
-- libnotify < 0.7" 2>/dev/null`
-+ libnotify < 0.9" 2>/dev/null`
- else
- pkg_failed=yes
- fi
-@@ -14790,14 +14790,14 @@
- elif test -n "$PKG_CONFIG"; then
- if test -n "$PKG_CONFIG" && \
- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"libnotify >= \$LIBNOTIFY_REQUIRED
-- libnotify < 0.7\""; } >&5
-+ libnotify < 0.9\""; } >&5
- ($PKG_CONFIG --exists --print-errors "libnotify >= $LIBNOTIFY_REQUIRED
-- libnotify < 0.7") 2>&5
-+ libnotify < 0.9") 2>&5
- ac_status=$?
- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
- test $ac_status = 0; }; then
- pkg_cv_LIBNOTIFY_LIBS=`$PKG_CONFIG --libs "libnotify >= $LIBNOTIFY_REQUIRED
-- libnotify < 0.7" 2>/dev/null`
-+ libnotify < 0.9" 2>/dev/null`
- else
- pkg_failed=yes
- fi
-@@ -14818,16 +14818,16 @@
- fi
- if test $_pkg_short_errors_supported = yes; then
- LIBNOTIFY_PKG_ERRORS=`$PKG_CONFIG --short-errors --print-errors "libnotify >= $LIBNOTIFY_REQUIRED
-- libnotify < 0.7" 2>&1`
-+ libnotify < 0.9" 2>&1`
- else
- LIBNOTIFY_PKG_ERRORS=`$PKG_CONFIG --print-errors "libnotify >= $LIBNOTIFY_REQUIRED
-- libnotify < 0.7" 2>&1`
-+ libnotify < 0.9" 2>&1`
- fi
- # Put the nasty error message in config.log where it belongs
- echo "$LIBNOTIFY_PKG_ERRORS" >&5
-
- as_fn_error $? "Package requirements (libnotify >= $LIBNOTIFY_REQUIRED
-- libnotify < 0.7) were not met:
-+ libnotify < 0.9) were not met:
-
- $LIBNOTIFY_PKG_ERRORS
-
-@@ -15049,11 +15049,11 @@
- fi
-
- # Enable GSEAL checks if needed
--if test $USE_MAINTAINER_MODE = yes; then
-+#if test $USE_MAINTAINER_MODE = yes; then
-
--$as_echo "#define GSEAL_ENABLE /**/" >>confdefs.h
-+#$as_echo "#define GSEAL_ENABLE /**/" >>confdefs.h
-
--fi
-+#fi
-
- # -----------------------------------------------------------
- # Enable debug
diff --git a/net-im/empathy/files/patch-libempathy_empathy-auth-factory.c b/net-im/empathy/files/patch-libempathy_empathy-auth-factory.c
new file mode 100644
index 000000000000..879313c5b7c1
--- /dev/null
+++ b/net-im/empathy/files/patch-libempathy_empathy-auth-factory.c
@@ -0,0 +1,10 @@
+--- libempathy/empathy-auth-factory.c.orig 2011-12-07 17:19:17.000000000 +0000
++++ libempathy/empathy-auth-factory.c 2011-12-07 17:19:45.000000000 +0000
+@@ -23,6 +23,7 @@
+ #include <telepathy-glib/interfaces.h>
+ #include <telepathy-glib/simple-handler.h>
+ #include <telepathy-glib/util.h>
++#include <telepathy-glib/channel-dispatch-operation.h>
+
+ #define DEBUG_FLAG EMPATHY_DEBUG_TLS
+ #include "empathy-debug.h"
diff --git a/net-im/empathy/files/patch-src_empathy-chat-window.c b/net-im/empathy/files/patch-src_empathy-chat-window.c
deleted file mode 100644
index a01730405e99..000000000000
--- a/net-im/empathy/files/patch-src_empathy-chat-window.c
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/empathy-chat-window.c.orig 2011-08-16 16:23:38.000000000 +0200
-+++ src/empathy-chat-window.c 2011-08-16 16:24:00.000000000 +0200
-@@ -1300,7 +1300,7 @@ chat_window_show_or_update_notification
- to an existing notification with the same title.
- In this way the previous message will not be lost: the new
- message will appear below it, in the same notification */
-- notification = notify_notification_new (header, escaped, NULL, NULL);
-+ notification = notify_notification_new (header, escaped, NULL);
-
- if (priv->notification == NULL) {
- priv->notification = notification;
diff --git a/net-im/empathy/files/patch-src_empathy-status-icon.c b/net-im/empathy/files/patch-src_empathy-status-icon.c
deleted file mode 100644
index 354fa5a4e037..000000000000
--- a/net-im/empathy/files/patch-src_empathy-status-icon.c
+++ /dev/null
@@ -1,13 +0,0 @@
---- src/empathy-status-icon.c.orig 2011-08-16 16:25:07.000000000 +0200
-+++ src/empathy-status-icon.c 2011-08-16 16:25:32.000000000 +0200
-@@ -206,8 +206,8 @@ status_icon_update_notification (Empathy
- to an existing notification with the same title.
- In this way the previous message will not be lost: the new
- message will appear below it, in the same notification */
-- notification = notify_notification_new_with_status_icon
-- (priv->event->header, message_esc, NULL, priv->icon);
-+ notification = notify_notification_new
-+ (priv->event->header, message_esc, NULL);
-
- if (priv->notification == NULL) {
- priv->notification = notification;
diff --git a/net-im/empathy/pkg-plist b/net-im/empathy/pkg-plist
index daa8228d30de..77cbcd0e4bca 100644
--- a/net-im/empathy/pkg-plist
+++ b/net-im/empathy/pkg-plist
@@ -11,6 +11,7 @@ share/applications/empathy-accounts.desktop
share/applications/empathy.desktop
share/dbus-1/services/org.freedesktop.Telepathy.Client.Empathy.AudioVideo.service
share/dbus-1/services/org.freedesktop.Telepathy.Client.Empathy.Auth.service
+share/dbus-1/services/org.freedesktop.Telepathy.Client.Empathy.Call.service
share/dbus-1/services/org.freedesktop.Telepathy.Client.Empathy.service
%%DATADIR%%/Template.html
%%DATADIR%%/codec-preferences
@@ -32,6 +33,7 @@ share/dbus-1/services/org.freedesktop.Telepathy.Client.Empathy.service
%%DATADIR%%/empathy-chat.ui
%%DATADIR%%/empathy-chatroom-manager.dtd
%%DATADIR%%/empathy-chatrooms-window.ui
+%%DATADIR%%/empathy-contact-blocking-dialog.ui
%%DATADIR%%/empathy-contact-dialogs.ui
%%DATADIR%%/empathy-contact-groups.dtd
%%DATADIR%%/empathy-contact-selector-dialog.ui
@@ -1059,6 +1061,7 @@ share/gnome/help/empathy/zh_CN/video-call.page
share/icons/hicolor/16x16/apps/empathy.png
share/icons/hicolor/22x22/apps/empathy.png
share/icons/hicolor/24x24/apps/empathy.png
+share/icons/hicolor/256x256/apps/empathy.png
share/icons/hicolor/32x32/apps/empathy.png
share/icons/hicolor/48x48/apps/empathy.png
share/icons/hicolor/scalable/apps/empathy.svg
@@ -1142,6 +1145,7 @@ share/locale/zh_HK/LC_MESSAGES/empathy.mo
share/locale/zh_TW/LC_MESSAGES/empathy.mo
share/telepathy/clients/Empathy.AudioVideo.client
share/telepathy/clients/Empathy.Auth.client
+share/telepathy/clients/Empathy.Call.client
share/telepathy/clients/Empathy.client
@dirrmtry share/telepathy/clients
@dirrmtry share/telepathy