aboutsummaryrefslogtreecommitdiff
path: root/net-im/eva/Makefile
diff options
context:
space:
mode:
authorTilman Keskinoz <arved@FreeBSD.org>2005-06-10 21:19:57 +0000
committerTilman Keskinoz <arved@FreeBSD.org>2005-06-10 21:19:57 +0000
commit5c621630250f7e9f9152e53d095908dd2eacec51 (patch)
tree6a4f50b09b4957010930d2f628e39638615371ba /net-im/eva/Makefile
parent7f0b2c9f4d3c3d7ab940054f3138cb34c52623ef (diff)
Notes
Diffstat (limited to 'net-im/eva/Makefile')
-rw-r--r--net-im/eva/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-im/eva/Makefile b/net-im/eva/Makefile
new file mode 100644
index 000000000000..eca91d4d315d
--- /dev/null
+++ b/net-im/eva/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: eva
+# Date created: 16 April 2005
+# Whom: hamigua <hamigua@cuc.cn>
+#
+# $FreeBSD$
+#
+
+PORTNAME= evaq
+PORTVERSION= 0.2.1
+CATEGORIES= net kde
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+DISTNAME= eva-${PORTVERSION}-20050406
+
+MAINTAINER= hamigua@cuc.cn
+COMMENT= QQ IM Client for KDE3
+
+WRKSRC= ${WRKDIR}/eva-${PORTVERSION}
+USE_KDELIBS_VER=3
+GNU_CONFIGURE= yes
+USE_REINPLACE= yes
+USE_GMAKE= yes
+USE_BZIP2= yes
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= "does not compile"
+.endif
+
+pre-patch:
+ ${REINPLACE_CMD} -e 's/-pedantic //g; s/-O2//g; \
+ s/-lpthread/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
+
+.include <bsd.port.post.mk>