aboutsummaryrefslogtreecommitdiff
path: root/net-im/farsight2/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/farsight2/Makefile
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'net-im/farsight2/Makefile')
-rw-r--r--net-im/farsight2/Makefile27
1 files changed, 10 insertions, 17 deletions
diff --git a/net-im/farsight2/Makefile b/net-im/farsight2/Makefile
index 135a1ede1794..1f5ee13c4744 100644
--- a/net-im/farsight2/Makefile
+++ b/net-im/farsight2/Makefile
@@ -1,36 +1,29 @@
-# New ports collection makefile for: farsight2
-# Date created: 27 February 2009
-# Whom: Joe Marcus Clarke <marcus@FreeBSD.org>
-#
+# Created by: Joe Marcus Clarke <marcus@FreeBSD.org>
# $FreeBSD$
-#
+# $MCom: ports/net-im/farsight2/Makefile,v 1.10 2012/06/13 09:31:14 kwm Exp $
PORTNAME= farsight2
-PORTVERSION= 0.0.22
-PORTREVISION= 1
+PORTVERSION= 0.0.31
CATEGORIES= net-im devel
MASTER_SITES= http://farsight.freedesktop.org/releases/farsight2/
MAINTAINER= gnome@FreeBSD.org
COMMENT= Collection of GStreamer modules and libraries for videoconferencing
-LIB_DEPENDS= nice.0:${PORTSDIR}/net-im/libnice
+LIB_DEPENDS= nice:${PORTSDIR}/net-im/libnice
+CONFLICTS= farstream-[0-9]*
+
+FETCH_ARGS= -Fpr
USE_GMAKE= yes
USE_GETTEXT= yes
USE_LDCONFIG= yes
USE_PYTHON= yes
-USE_GNOME= gnomehack pkgconfig glib20 ltverhack \
- pygtk2
+USE_GNOME= gnomehack glib20 ltverhack
+USE_PKGCONFIG= build
USE_GSTREAMER= core good bad python
USE_AUTOTOOLS= libtool
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} < 702000
-BROKEN= does not build on FreeBSD 7.X prior 7.2
-.endif
-
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>