aboutsummaryrefslogtreecommitdiff
path: root/net-im/folks/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /net-im/folks/Makefile
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
Notes
Diffstat (limited to 'net-im/folks/Makefile')
-rw-r--r--net-im/folks/Makefile40
1 files changed, 27 insertions, 13 deletions
diff --git a/net-im/folks/Makefile b/net-im/folks/Makefile
index fec8de126d2c..96abe0a587d6 100644
--- a/net-im/folks/Makefile
+++ b/net-im/folks/Makefile
@@ -1,14 +1,9 @@
-# New ports collection makefile for: folks
-# Date created: 23 July 2010
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/net-im/folks/Makefile,v 1.8 2010/10/26 08:47:55 kwm Exp $
-#
+# $MCom: ports/net-im/folks/Makefile,v 1.29 2012/08/17 19:06:45 kwm Exp $
PORTNAME= folks
-PORTVERSION= 0.2.1
-PORTREVISION= 1
+PORTVERSION= 0.7.0
CATEGORIES= net-im
MASTER_SITES= GNOME
@@ -17,17 +12,36 @@ COMMENT= library to aggregates people from multiple sources
BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen \
g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
-LIB_DEPENDS= gee.2:${PORTSDIR}/devel/libgee \
+LIB_DEPENDS= gee:${PORTSDIR}/devel/libgee06 \
telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib
-USE_BZIP2= yes
+CONFLICTS= folks-0.4.[0-9]*
+
+USE_XZ= yes
+USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
USE_GMAKE= yes
-USE_GNOME= gnomehack
+USE_GNOME= gnomehier gnomehack intlhack ltverhack evolutiondataserver3
+USE_GETTEXT= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= -I${LOCALBASE}/include
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-PLIST_SUB= VERSION=16
+PLIST_SUB= LIBVER=25 VERSION=33
+
+#OPTIONS= SOCIALWEB "Enable social web backend" on
+
+#.include <bsd.port.options.mk>
+
+#.if defined(WITH_SOCIALWEB)
+#LIB_DEPENDS+= socialweb.0:${PORTSDIR}/www/libsocialweb
+#CONFIGURE_ARGS+=--enable-libsocialweb-backend=yes
+#.else
+CONFIGURE_ARGS+=--enable-libsocialweb-backend=no
+#.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|^build_old_libs=yes|build_old_libs=no|g' \
+ ${WRKDIR}/gnome-libtool
.include <bsd.port.mk>