aboutsummaryrefslogtreecommitdiff
path: root/net-im/folks
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
committerKoop Mast <kwm@FreeBSD.org>2010-11-20 15:37:08 +0000
commit3680f27ebff58ece429c4e032f9ad84fb1372114 (patch)
tree6c5ff4664c1a779ddad350ac887e5706dbfdd4eb /net-im/folks
parent02c6e6b485454dc3f5a27cbc887d9e4aaf376a36 (diff)
Presenting GNOME 2.32.1 for FreeBSD. The offical release notes for this
release can be found at http://library.gnome.org/misc/release-notes/2.32/ This will be the last release of the GNOME 2.x series, mainly a bugfix and bridge release to the first release of the GNOME 3.x series. This release features commits by avl, marcus, mezz and myself. The FreeBSD GNOME Team would like to thank the following contributors and testers for there help with this release: Zane C.B. <vvelox@vvelox.net> romain@ Olaf Seibert <O.Seibert@cs.ru.nl> DomiX Bapt <baptiste.daroussin@gmail.com> jsa@ miwi@ Sergio de Almeida Lenzi <lenzi.sergio@gmail.com> Maxim Samsonov <xors@mne.ru> Kris Moore And pav@ for 2 exp-runs PR: ports/152255 ports/143260 ports/141033 ports/149629 ports/150350 ports/151523 With hat: gnome@
Notes
Notes: svn path=/head/; revision=264837
Diffstat (limited to 'net-im/folks')
-rw-r--r--net-im/folks/Makefile32
-rw-r--r--net-im/folks/distinfo3
-rw-r--r--net-im/folks/pkg-descr7
-rw-r--r--net-im/folks/pkg-plist27
4 files changed, 69 insertions, 0 deletions
diff --git a/net-im/folks/Makefile b/net-im/folks/Makefile
new file mode 100644
index 000000000000..dc4484a65f19
--- /dev/null
+++ b/net-im/folks/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: folks
+# Date created: 23 July 2010
+# Whom: Koop Mast <kwm@FreeBSD.org>
+#
+# $FreeBSD$
+# $MCom: ports/net-im/folks/Makefile,v 1.8 2010/10/26 08:47:55 kwm Exp $
+#
+
+PORTNAME= folks
+PORTVERSION= 0.2.1
+CATEGORIES= net-im
+MASTER_SITES= GNOME
+
+MAINTAINER= gnome@FreeBSD.org
+COMMENT= library to aggregates people from multiple sources
+
+BUILD_DEPENDS= vapigen:${PORTSDIR}/lang/vala-vapigen \
+ g-ir-scanner:${PORTSDIR}/devel/gobject-introspection
+LIB_DEPENDS= gee.2:${PORTSDIR}/devel/libgee \
+ telepathy-glib.0:${PORTSDIR}/net-im/telepathy-glib
+
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+USE_GMAKE= yes
+USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include " \
+ LDFLAGS="-L${LOCALBASE}/lib"
+
+PLIST_SUB= VERSION=16
+
+.include <bsd.port.mk>
diff --git a/net-im/folks/distinfo b/net-im/folks/distinfo
new file mode 100644
index 000000000000..240bbf5187cb
--- /dev/null
+++ b/net-im/folks/distinfo
@@ -0,0 +1,3 @@
+MD5 (folks-0.2.1.tar.bz2) = afabe04bd84347e73e9c94eb1b8cf3c1
+SHA256 (folks-0.2.1.tar.bz2) = f8eeeb6a6974416d4db1ab6b18187173fb6ff4ec7830bece379dfba9b25f2a29
+SIZE (folks-0.2.1.tar.bz2) = 465522
diff --git a/net-im/folks/pkg-descr b/net-im/folks/pkg-descr
new file mode 100644
index 000000000000..21280dabf8d6
--- /dev/null
+++ b/net-im/folks/pkg-descr
@@ -0,0 +1,7 @@
+libfolks is a library that aggregates people from multiple sources
+(eg, Telepathy connection managers and eventually evolution data server,
+Facebook, etc.) to create metacontacts. It's written in Vala (in part to
+evaluate Vala). The initial goal is for GObject/C support, though the Vala
+bindings should basically automatic.
+
+WWW: http://telepathy.freedesktop.org/wiki/Folks
diff --git a/net-im/folks/pkg-plist b/net-im/folks/pkg-plist
new file mode 100644
index 000000000000..a9cd7dbadde4
--- /dev/null
+++ b/net-im/folks/pkg-plist
@@ -0,0 +1,27 @@
+bin/folks-import
+include/folks/folks-telepathy.h
+include/folks/folks.h
+lib/folks/%%VERSION%%/backends/key-file/libfolks-backend-key-file.la
+lib/folks/%%VERSION%%/backends/key-file/libfolks-backend-key-file.so
+lib/folks/%%VERSION%%/backends/telepathy/libfolks-backend-telepathy.la
+lib/folks/%%VERSION%%/backends/telepathy/libfolks-backend-telepathy.so
+lib/libfolks-telepathy.la
+lib/libfolks-telepathy.so
+lib/libfolks-telepathy.so.%%VERSION%%
+lib/libfolks.la
+lib/libfolks.so
+lib/libfolks.so.%%VERSION%%
+libdata/pkgconfig/folks-telepathy.pc
+libdata/pkgconfig/folks.pc
+share/vala/vapi/folks-telepathy.deps
+share/vala/vapi/folks-telepathy.vapi
+share/vala/vapi/folks.deps
+share/vala/vapi/folks.vapi
+@dirrmtry share/vala/vapi
+@dirrmtry share/vala
+@dirrm lib/folks/%%VERSION%%/backends/telepathy
+@dirrm lib/folks/%%VERSION%%/backends/key-file
+@dirrm lib/folks/%%VERSION%%/backends
+@dirrm lib/folks/%%VERSION%%
+@dirrm lib/folks
+@dirrm include/folks