aboutsummaryrefslogtreecommitdiff
path: root/net-im/gaim-ignorance/Makefile
diff options
context:
space:
mode:
authorJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-24 09:26:40 +0000
committerJean-Yves Lefort <jylefort@FreeBSD.org>2005-10-24 09:26:40 +0000
commit552c46f80551891260b93f355094652a4ac433b1 (patch)
treeaafb08813b09a1b298145613a83fcbf092515a85 /net-im/gaim-ignorance/Makefile
parentea9c48b7a59c0e09ed9df194c6e835e356e3e141 (diff)
downloadports-552c46f80551891260b93f355094652a4ac433b1.tar.gz
ports-552c46f80551891260b93f355094652a4ac433b1.zip
Notes
Diffstat (limited to 'net-im/gaim-ignorance/Makefile')
-rw-r--r--net-im/gaim-ignorance/Makefile28
1 files changed, 9 insertions, 19 deletions
diff --git a/net-im/gaim-ignorance/Makefile b/net-im/gaim-ignorance/Makefile
index 653321f97bff..bcc7f1b09bc1 100644
--- a/net-im/gaim-ignorance/Makefile
+++ b/net-im/gaim-ignorance/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= ignorance
-PORTVERSION= 2.1
+PORTVERSION= 2.2
CATEGORIES= misc
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -23,34 +23,24 @@ USE_BZIP2= yes
USE_LIBTOOL_VER=15
USE_REINPLACE= yes
-EXAMPLESDIR_REL=${EXAMPLESDIR:S,^${PREFIX}/,,}
-PLIST_SUB= EXAMPLESDIR_REL=${EXAMPLESDIR_REL}
-
SUB_FILES= pkg-message
-
-BROKEN= "does not compile"
-
-.if !defined(NOPORTDOCS)
PORTDOCS= README
-.endif
-
-post-extract:
- @${REINPLACE_CMD} -e "s/ignorance.conf/ignorance.conf.sample/g" ${WRKSRC}/Makefile.in
- @${MV} ${WRKSRC}/ignorance.conf ${WRKSRC}/ignorance.conf.sample
post-patch:
@${REINPLACE_CMD} -e 's|-g3||' ${WRKSRC}/configure
+ @${REINPLACE_CMD} -e "s/ignorance.conf/ignorance.conf.sample/g" ${WRKSRC}/Makefile.in
+ @${MV} ${WRKSRC}/ignorance.conf ${WRKSRC}/ignorance.conf.sample
post-install:
- @${MKDIR} ${EXAMPLESDIR}
- @${INSTALL_DATA} ${WRKSRC}/ignorance ${EXAMPLESDIR}
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/ignorance ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
- @${CAT} ${PKGMESSAGE}
- @if ${TEST} ! -f ${PREFIX}/etc/gaim/ignorance.conf; then \
+ if ${TEST} ! -f ${PREFIX}/etc/gaim/ignorance.conf; then \
${CP} ${PREFIX}/etc/gaim/ignorance.conf.sample ${PREFIX}/etc/gaim/ignorance.conf; \
fi
+ @${CAT} ${PKGMESSAGE}
.include <bsd.port.mk>