aboutsummaryrefslogtreecommitdiff
path: root/net-im/gaim-ignorance/Makefile
diff options
context:
space:
mode:
authorRoman Bogorodskiy <novel@FreeBSD.org>2005-08-07 18:40:50 +0000
committerRoman Bogorodskiy <novel@FreeBSD.org>2005-08-07 18:40:50 +0000
commit542db9acde039088e1aa97cced5eca54b226db8e (patch)
tree3e0449bcebb7e0259572480c38995924f24218af /net-im/gaim-ignorance/Makefile
parent30d9d0f73a03e58c473454f64008b8db41c8ec97 (diff)
downloadports-542db9acde039088e1aa97cced5eca54b226db8e.tar.gz
ports-542db9acde039088e1aa97cced5eca54b226db8e.zip
Notes
Diffstat (limited to 'net-im/gaim-ignorance/Makefile')
-rw-r--r--net-im/gaim-ignorance/Makefile19
1 files changed, 13 insertions, 6 deletions
diff --git a/net-im/gaim-ignorance/Makefile b/net-im/gaim-ignorance/Makefile
index 94d027822da4..6072b49f4be4 100644
--- a/net-im/gaim-ignorance/Makefile
+++ b/net-im/gaim-ignorance/Makefile
@@ -7,6 +7,7 @@
PORTNAME= ignorance
PORTVERSION= 1.3.1.2
+PORTREVISION= 1
CATEGORIES= misc
MASTER_SITES= http://bard.sytes.net/ignorance/
PKGNAMEPREFIX= gaim-
@@ -23,8 +24,7 @@ USE_LIBTOOL_VER=15
USE_REINPLACE= yes
EXAMPLESDIR_REL=${EXAMPLESDIR:S,^${PREFIX}/,,}
-PLIST_FILES= lib/gaim/ignorance.so ${EXAMPLESDIR_REL}/ignorance
-PLIST_DIRS= ${EXAMPLESDIR_REL}
+PLIST_SUB= EXAMPLESDIR_REL=${EXAMPLESDIR_REL}
SUB_FILES= pkg-message
@@ -32,16 +32,23 @@ SUB_FILES= pkg-message
PORTDOCS= README
.endif
+post-extract:
+ @${REINPLACE_CMD} -e "s/ignorance.conf/ignorance.conf.sample/g" ${WRKSRC}/Makefile.in
+ @${MV} ${WRKSRC}/ignorance.conf ${WRKSRC}/ignorance.conf.sample
+
post-patch:
@${REINPLACE_CMD} -e 's|-g3||' ${WRKSRC}/configure
post-install:
- ${MKDIR} ${EXAMPLESDIR}
- ${INSTALL_DATA} ${WRKSRC}/ignorance ${EXAMPLESDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ @${INSTALL_DATA} ${WRKSRC}/ignorance ${EXAMPLESDIR}
.if !defined(NOPORTDOCS)
- ${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ @${MKDIR} ${DOCSDIR}
+ @${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
.endif
@${CAT} ${PKGMESSAGE}
+ @if ${TEST} ! -f ${PREFIX}/etc/gaim/ignorance.conf; then \
+ ${CP} ${PREFIX}/etc/gaim/ignorance.conf.sample ${PREFIX}/etc/gaim/ignorance.conf; \
+ fi
.include <bsd.port.mk>