aboutsummaryrefslogtreecommitdiff
path: root/net-im/gajim/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2007-02-08 22:33:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2007-02-08 22:33:51 +0000
commit357ad9bd8c54d9bdd31cf0a5948d054898a59d48 (patch)
tree13932edf112a713934f1918a961e2f5c0c0fcff5 /net-im/gajim/Makefile
parentdab1a921f458fc3fcbfe2774d511459ae02f905b (diff)
downloadports-357ad9bd8c54d9bdd31cf0a5948d054898a59d48.tar.gz
ports-357ad9bd8c54d9bdd31cf0a5948d054898a59d48.zip
Notes
Diffstat (limited to 'net-im/gajim/Makefile')
-rw-r--r--net-im/gajim/Makefile58
1 files changed, 41 insertions, 17 deletions
diff --git a/net-im/gajim/Makefile b/net-im/gajim/Makefile
index a3186aa6bddb..5fb31cd208ed 100644
--- a/net-im/gajim/Makefile
+++ b/net-im/gajim/Makefile
@@ -6,37 +6,61 @@
#
PORTNAME= gajim
-PORTVERSION= 0.10.1
+PORTVERSION= 0.11
CATEGORIES= net-im
MASTER_SITES= http://www.gajim.org/downloads/
MAINTAINER= ports@FreeBSD.org
-COMMENT= Gajim is a Jabber client based on a plugin system
+COMMENT= A Jabber client based on a plugin system
-LIB_DEPENDS= gtkspell.0:${PORTSDIR}/textproc/gtkspell
-RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite21
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/pysqlite2/__init__.py:${PORTSDIR}/databases/py-pysqlite21 \
+ bash:${PORTSDIR}/shells/bash
-USE_X_PREFIX= yes
-USE_PYTHON= 2.3+
-USE_GMAKE= yes
USE_BZIP2= yes
-USE_GNOME= pygtk2
+USE_XLIB= yes
+USE_GNOME= gnometarget intlhack pygtk2
+USE_PYTHON= 2.4+
USE_GETTEXT= yes
-
-MAKE_ENV+= PY_CFLAGS=-I${PYTHON_INCLUDEDIR} \
- PY_PREFIX=${LOCALBASE} \
- CC=${CC} LDFLAGS=-L${LOCALBASE}/lib
+USE_GMAKE= yes
+USE_AUTOTOOLS= libtool:15
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man
MAN1= gajim.1 \
gajim-remote.1
+CPPFLAGS= -I${LOCALBASE}/include -I${X11BASE}/include
+LDFLAGS= -L${LOCALBASE}/lib -L${X11BASE}/lib
+
+.if defined(WITHOUT_DBUS)
+CONFIGURE_ARGS+= --disable-remote
+PLIST_SUB+= DBUS="@comment "
+.else
+LIB_DEPENDS+= dbus-1.3:${PORTSDIR}/devel/dbus
+RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/dbus/__init__.py:${PORTSDIR}/devel/py-dbus
+PLIST_SUB+= DBUS=""
+.endif
+
+.if defined(WITHOUT_GTKSPELL)
+CONFIGURE_ARGS+= --disable-gtkspell
+PLIST_SUB+= GTKSPELL="@comment "
+.else
+LIB_DEPENDS+= gtkspell.0:${PORTSDIR}/textproc/gtkspell
+PLIST_SUB+= GTKSPELL=""
+.endif
+
post-patch:
@${REINPLACE_CMD} -e \
- 's|^PREFIX.*=.*||; s|^DESTDIR.*=.*||; s|share/man|man|' \
- ${WRKSRC}/Makefile
+ 's|: install-docfilesDATA|:|g' ${WRKSRC}/Makefile.in
@${REINPLACE_CMD} -e \
- 's|CFLAGS =|CFLAGS +=|; s|LDFLAGS =|LDFLAGS +=|; \
- s|-I/usr/include/python\$$(PYTHONVER)|$$(PY_CFLAGS)|' \
- ${WRKSRC}/src/Makefile ${WRKSRC}/src/common/Makefile
+ 's|^#!.*|#!${LOCALBASE}/bin/bash|g' ${WRKSRC}/scripts/gajim.in
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for file in AUTHORS ChangeLog README README.html THANKS
+ ${INSTALL_DATA} ${WRKSRC}/${file} ${DOCSDIR}
+.endfor
+.endif
.include <bsd.port.mk>