aboutsummaryrefslogtreecommitdiff
path: root/net-im/gale/Makefile
diff options
context:
space:
mode:
authorWill Andrews <will@FreeBSD.org>2000-08-11 11:19:21 +0000
committerWill Andrews <will@FreeBSD.org>2000-08-11 11:19:21 +0000
commit5473c4da09c1c3856da18a7650c0e55192c6a19f (patch)
treea420ae3fafe3ddc50a4c28657d22403ae42e9ff6 /net-im/gale/Makefile
parent491b358b14380cee70ab3ad014cf627b82342c0b (diff)
downloadports-5473c4da09c1c3856da18a7650c0e55192c6a19f.tar.gz
ports-5473c4da09c1c3856da18a7650c0e55192c6a19f.zip
Notes
Diffstat (limited to 'net-im/gale/Makefile')
-rw-r--r--net-im/gale/Makefile32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-im/gale/Makefile b/net-im/gale/Makefile
new file mode 100644
index 000000000000..356209c67045
--- /dev/null
+++ b/net-im/gale/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: gale
+# Date created: 14 July 2000
+# Whom: Peter Haight <peterh@sapros.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gale
+PORTVERSION= 0.99a
+CATEGORIES= net
+MASTER_SITES= http://www.gale.org/dist/
+
+MAINTAINER= peterh@sapros.com
+
+BUILD_DEPENDS= ${LOCALBASE}/lib/libgc.a:${PORTSDIR}/devel/boehm-gc
+LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww
+.if defined(USA_RESIDENT) && ${USA_RESIDENT} == YES
+LIB_DEPENDS+= rsaref.2:${PORTSDIR}/security/rsaref
+.endif
+
+GNU_CONFIGURE= yes
+
+CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
+CPPFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
+ -I${LOCALBASE}/include/w3c-libwww
+LDFLAGS+= -L${LOCALBASE}/lib
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}" INSTALL=""
+
+post-install:
+ ${CAT} ${PKGDIR}/MESSAGE
+
+.include <bsd.port.mk>