aboutsummaryrefslogtreecommitdiff
path: root/net-im/gale
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2005-04-21 10:19:42 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2005-04-21 10:19:42 +0000
commit2a8b912745d89f3f3033ed50e0733a8472208255 (patch)
treec000bea9c0348d52f5549e9c5c5a04601e74ac32 /net-im/gale
parent6410f439793692028d3bcc15d3d7a90ec761ec11 (diff)
downloadports-2a8b912745d89f3f3033ed50e0733a8472208255.tar.gz
ports-2a8b912745d89f3f3033ed50e0733a8472208255.zip
Notes
Diffstat (limited to 'net-im/gale')
-rw-r--r--net-im/gale/Makefile25
-rw-r--r--net-im/gale/distinfo4
-rw-r--r--net-im/gale/files/patch-acinclude.m4114
-rw-r--r--net-im/gale/files/patch-wcwidth20
-rw-r--r--net-im/gale/pkg-descr4
-rw-r--r--net-im/gale/pkg-message2
-rw-r--r--net-im/gale/pkg-plist5
7 files changed, 21 insertions, 153 deletions
diff --git a/net-im/gale/Makefile b/net-im/gale/Makefile
index 3b67978c290d..2c6a787a158f 100644
--- a/net-im/gale/Makefile
+++ b/net-im/gale/Makefile
@@ -6,24 +6,24 @@
#
PORTNAME= gale
-PORTVERSION= 0.99e
+PORTVERSION= 0.99f
CATEGORIES= net
-MASTER_SITES= http://www.mit.edu/afs/sipb/project/gale/src/ \
- # http://download.ofb.net/gale/ - original mastersite
-DISTNAME= ${PORTNAME}-${PORTVERSION}gg
+MASTER_SITES= http://download.ofb.net/${PORTNAME}/
+DISTNAME= ${PORTNAME}-${PORTVERSION}ruit
-MAINTAINER= peterh@sapros.com
+MAINTAINER= jason-fbsd-ports-gale@shalott.net
COMMENT= A secure instant messaging system
BUILD_DEPENDS= ${LOCALBASE}/lib/libgc.a:${PORTSDIR}/devel/boehm-gc
LIB_DEPENDS= wwwcore.1:${PORTSDIR}/www/libwww \
adns.1:${PORTSDIR}/dns/adns
+USE_ICONV= yes
+USE_GNOME= glib12
+GNU_CONFIGURE= yes
USE_OPENSSL= yes
-USE_AUTOCONF_VER=213
-USE_AUTOMAKE_VER=14
-USE_INC_LIBTOOL_VER=13
INSTALLS_SHLIB= yes
+USE_REINPLACE= YES
CFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib
CPPFLAGS+= -I${LOCALBASE}/include -L${LOCALBASE}/lib \
@@ -33,12 +33,15 @@ CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 502126
-BROKEN= "Does not compile on FreeBSD >= 5.x"
+.if ${OSVERSION} < 500039
+IGNORE= requires wchar functions for compilation
.endif
+# cheesy hack - test-oop doesn't build, but we don't care.
pre-configure:
- cd ${WRKSRC} && ${ACLOCAL} -I ${LIBTOOL_SHAREDIR}/libltdl
+ ${REINPLACE_CMD} -e 's/\(^noinst_PROGRAMS =.*\)test-oop/\1/' \
+ ${WRKSRC}/liboop/Makefile.in
+ ${ECHO} -n > ${WRKSRC}/libgale/wcwidth.c
post-install:
@${CAT} ${PKGMESSAGE}
diff --git a/net-im/gale/distinfo b/net-im/gale/distinfo
index 38c72ae3d14f..f4578673cb03 100644
--- a/net-im/gale/distinfo
+++ b/net-im/gale/distinfo
@@ -1,2 +1,2 @@
-MD5 (gale-0.99egg.tar.gz) = 5240b10de2c7998887b3bc3dd7e8b30b
-SIZE (gale-0.99egg.tar.gz) = 370153
+MD5 (gale-0.99fruit.tar.gz) = b3bd4c412037d7e63fa9fde556045934
+SIZE (gale-0.99fruit.tar.gz) = 536852
diff --git a/net-im/gale/files/patch-acinclude.m4 b/net-im/gale/files/patch-acinclude.m4
deleted file mode 100644
index 3960395014b1..000000000000
--- a/net-im/gale/files/patch-acinclude.m4
+++ /dev/null
@@ -1,114 +0,0 @@
-diff -u -N /tmp/gale-0.99egg/acinclude.m4 ./acinclude.m4
---- /tmp/gale-0.99egg/acinclude.m4 Wed Dec 31 16:00:00 1969
-+++ ./acinclude.m4 Tue Nov 6 13:55:13 2001
-@@ -0,0 +1,110 @@
-+dnl This is a subroutine of AC_OUTPUT.
-+dnl It is called after running config.status.
-+dnl AC_OUTPUT_SUBDIRS(DIRECTORY...)
-+define([AC_OUTPUT_SUBDIRS],
-+[
-+ifdef([AC_PROVIDE_AC_PROG_INSTALL], [ac_given_INSTALL="$INSTALL"
-+])dnl
-+if test "$no_recursion" != yes; then
-+
-+ # Remove --cache-file and --srcdir arguments so they do not pile up.
-+ ac_sub_configure_args=
-+ ac_prev=
-+ for ac_arg in $ac_configure_args; do
-+ if test -n "$ac_prev"; then
-+ ac_prev=
-+ continue
-+ fi
-+ case "$ac_arg" in
-+ -cache-file | --cache-file | --cache-fil | --cache-fi \
-+ | --cache-f | --cache- | --cache | --cach | --cac | --ca | --c)
-+ ac_prev=cache_file ;;
-+ -cache-file=* | --cache-file=* | --cache-fil=* | --cache-fi=* \
-+ | --cache-f=* | --cache-=* | --cache=* | --cach=* | --cac=* | --ca=* | --c=*)
-+ ;;
-+ -srcdir | --srcdir | --srcdi | --srcd | --src | --sr)
-+ ac_prev=srcdir ;;
-+ -srcdir=* | --srcdir=* | --srcdi=* | --srcd=* | --src=* | --sr=*)
-+ ;;
-+ *) ac_sub_configure_args="$ac_sub_configure_args $ac_arg" ;;
-+ esac
-+ done
-+
-+ for ac_config_dir in $1; do
-+
-+ # Do not complain, so a configure script can configure whichever
-+ # parts of a large source tree are present.
-+ if test ! -d $srcdir/$ac_config_dir; then
-+ continue
-+ fi
-+
-+ echo configuring in $ac_config_dir
-+
-+ case "$srcdir" in
-+ .) ;;
-+ *)
-+ if test -d ./$ac_config_dir || mkdir ./$ac_config_dir; then :;
-+ else
-+ AC_MSG_ERROR(can not create `pwd`/$ac_config_dir)
-+ fi
-+ ;;
-+ esac
-+
-+ ac_popdir=`pwd`
-+ cd $ac_config_dir
-+
-+changequote(, )dnl
-+ # A "../" for each directory in /$ac_config_dir.
-+ ac_dots=`echo $ac_config_dir|sed -e 's%^\./%%' -e 's%[^/]$%&/%' -e 's%[^/]*/%../%g'`
-+changequote([, ])dnl
-+
-+ case "$srcdir" in
-+ .) # No --srcdir option. We are building in place.
-+ ac_sub_srcdir=$srcdir ;;
-+ /*) # Absolute path.
-+ ac_sub_srcdir=$srcdir/$ac_config_dir ;;
-+ *) # Relative path.
-+ ac_sub_srcdir=$ac_dots$srcdir/$ac_config_dir ;;
-+ esac
-+
-+ # Check for guested configure; otherwise get Cygnus style configure.
-+ if test -f $ac_sub_srcdir/configure; then
-+ ac_sub_configure=$ac_sub_srcdir/configure
-+ elif test -f $ac_sub_srcdir/configure.in; then
-+ ac_sub_configure=$ac_configure
-+ else
-+ AC_MSG_WARN(no configuration information is in $ac_config_dir)
-+ ac_sub_configure=
-+ fi
-+
-+ # The recursion is here.
-+ if test -n "$ac_sub_configure"; then
-+
-+ # Make the cache file name correct relative to the subdirectory.
-+ case "$cache_file" in
-+ /*) ac_sub_cache_file=$cache_file ;;
-+ *) # Relative path.
-+ ac_sub_cache_file="$ac_dots$cache_file" ;;
-+ esac
-+ifdef([AC_PROVIDE_AC_PROG_INSTALL],
-+ [ case "$ac_given_INSTALL" in
-+changequote(, )dnl
-+ [/$]*) INSTALL="$ac_given_INSTALL" ;;
-+changequote([, ])dnl
-+ *) INSTALL="$ac_dots$ac_given_INSTALL" ;;
-+ esac
-+])dnl
-+
-+ echo "[running ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file] --srcdir=$ac_sub_srcdir"
-+ # The eval makes quoting arguments work.
-+ if eval ${CONFIG_SHELL-/bin/sh} $ac_sub_configure $ac_sub_configure_args --cache-file=$ac_sub_cache_file --srcdir=$ac_sub_srcdir
-+ then :
-+ else
-+ AC_MSG_ERROR($ac_sub_configure failed for $ac_config_dir)
-+ fi
-+ fi
-+
-+ cd $ac_popdir
-+ done
-+fi
-+])
diff --git a/net-im/gale/files/patch-wcwidth b/net-im/gale/files/patch-wcwidth
deleted file mode 100644
index 11029afc3555..000000000000
--- a/net-im/gale/files/patch-wcwidth
+++ /dev/null
@@ -1,20 +0,0 @@
---- /tmp/wcwidth.c.orig Fri Oct 25 21:05:46 2002
-+++ libgale/wcwidth.c Fri Oct 25 21:05:51 2002
-@@ -6,10 +6,16 @@
- * Markus Kuhn -- 2000-02-08 -- public domain
- */
-
--#ifdef __FreeBSD__ /* peterh@sapros.com */
-+#ifdef __FreeBSD__
-+#include <osreldate.h>
-+#if __FreeBSD_version >= 500000
-+#include <wchar.h>
-+#else
- #include <rune.h>
- #endif
-+#else
- #include <wchar.h>
-+#endif
-
- /* These functions define the column width of an ISO 10646 character
- * as follows:
diff --git a/net-im/gale/pkg-descr b/net-im/gale/pkg-descr
index 38098b2f442f..58896b04e41c 100644
--- a/net-im/gale/pkg-descr
+++ b/net-im/gale/pkg-descr
@@ -1,8 +1,6 @@
Gale is an open-source messaging system. It provides private messaging and
public chat, uses strong end-to-end cryptography for security, and supports
a distributed server network with a range of clients (both console and GUI)
-available. Gale is currently in early alpha testing.
+available.
WWW: http://www.gale.org/
-
-peterh@sapros.com
diff --git a/net-im/gale/pkg-message b/net-im/gale/pkg-message
index 57b640e59809..cc7120c7715f 100644
--- a/net-im/gale/pkg-message
+++ b/net-im/gale/pkg-message
@@ -1,3 +1,3 @@
--------------------------------------------------------------------------------
-now run ${PREFIX}/bin/gale-install ... even for an upgrade
+now run gale-install ... even for an upgrade
--------------------------------------------------------------------------------
diff --git a/net-im/gale/pkg-plist b/net-im/gale/pkg-plist
index db341487c6f6..1745e92d9834 100644
--- a/net-im/gale/pkg-plist
+++ b/net-im/gale/pkg-plist
@@ -28,8 +28,9 @@ include/oop-tcl.h
include/oop-www.h
include/oop.h
lib/libgale.a
+lib/libgale.la
lib/libgale.so
-lib/libgale.so.12
+lib/libgale.so.14
lib/liboop-adns.a
lib/liboop-adns.la
lib/liboop-adns.so
@@ -53,7 +54,7 @@ lib/liboop-www.so.0
lib/liboop.a
lib/liboop.la
lib/liboop.so
-lib/liboop.so.3
+lib/liboop.so.4
sbin/gksign
@exec mkdir -m 1777 %D/etc/gale/auth/cache
@exec mkdir -m 1777 %D/etc/gale/auth/local