aboutsummaryrefslogtreecommitdiff
path: root/net-im/gloox/Makefile
diff options
context:
space:
mode:
authorYing-Chieh Liao <ijliao@FreeBSD.org>2006-04-28 08:12:11 +0000
committerYing-Chieh Liao <ijliao@FreeBSD.org>2006-04-28 08:12:11 +0000
commitab0b1f8d32a18ba0b819967ef3589695149edf58 (patch)
tree947e428d7a6ddb587ab0d61e3d9fb15fba73c5fd /net-im/gloox/Makefile
parentb62fac1e235aece8f40f52edb9caecf8cd94ec29 (diff)
downloadports-ab0b1f8d32a18ba0b819967ef3589695149edf58.tar.gz
ports-ab0b1f8d32a18ba0b819967ef3589695149edf58.zip
Notes
Diffstat (limited to 'net-im/gloox/Makefile')
-rw-r--r--net-im/gloox/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-im/gloox/Makefile b/net-im/gloox/Makefile
new file mode 100644
index 000000000000..ec4b53220cf8
--- /dev/null
+++ b/net-im/gloox/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: gloox
+# Date created: 24 April 2006
+# Whom: trasz
+#
+# $FreeBSD$
+#
+
+PORTNAME= gloox
+PORTVERSION= 0.8
+CATEGORIES= net-im
+MASTER_SITES= http://camaya.net/download/
+
+MAINTAINER= trasz@pin.if.uz.zgora.pl
+COMMENT= Jabber/XMPP client library
+
+LIB_DEPENDS= iksemel.3:${PORTSDIR}/textproc/iksemel \
+ idn.16:${PORTSDIR}/dns/libidn \
+ gnutls.15:${PORTSDIR}/security/gnutls
+
+USE_BZIP2= yes
+USE_GNOME= gnomehack
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS="${CXXFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${LOCALBASE}/lib"
+INSTALLS_SHLIB= yes
+
+post-install:
+ @${FIND} ${PREFIX}/include/gloox ! -type d | \
+ ${SED} "s,${PREFIX}/,," >> ${TMPPLIST}
+ @${FIND} ${PREFIX}/include/gloox -type d | ${SORT} -r | \
+ ${SED} "s,${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+
+.include <bsd.port.mk>