aboutsummaryrefslogtreecommitdiff
path: root/net-im/gloox/Makefile
diff options
context:
space:
mode:
authorDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-19 23:30:13 +0000
committerDanilo Egea Gondolfo <danilo@FreeBSD.org>2014-02-19 23:30:13 +0000
commit4238ea20797e32c7f796308bc40f41b22c42d48e (patch)
tree35fc8b2801cbd95c98d5f2b37ab5d5689396aa7b /net-im/gloox/Makefile
parente28ac7c0d74a0112bcce06b96f52351f2322d394 (diff)
downloadports-4238ea20797e32c7f796308bc40f41b22c42d48e.tar.gz
ports-4238ea20797e32c7f796308bc40f41b22c42d48e.zip
Notes
Diffstat (limited to 'net-im/gloox/Makefile')
-rw-r--r--net-im/gloox/Makefile31
1 files changed, 17 insertions, 14 deletions
diff --git a/net-im/gloox/Makefile b/net-im/gloox/Makefile
index f14a45201cf2..4e22cb2cbc18 100644
--- a/net-im/gloox/Makefile
+++ b/net-im/gloox/Makefile
@@ -2,32 +2,35 @@
# $FreeBSD$
PORTNAME= gloox
-PORTVERSION= 1.0
-PORTREVISION= 3
+PORTVERSION= 1.0.9
CATEGORIES= net-im
MASTER_SITES= http://camaya.net/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Jabber/XMPP client library
+LICENSE= GPLv3
+
LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
libgnutls.so:${PORTSDIR}/security/gnutls
-USE_AUTOTOOLS= libtool
USE_BZIP2= yes
-USES= pathfix pkgconfig
+USES= compiler:c++11-lang libtool pathfix pkgconfig
+USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
+
+CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
-USE_LDCONFIG= yes
-post-patch:
- @${REINPLACE_CMD} -e 's|libgnutls-config|pkg-config gnutls|' ${WRKSRC}/configure
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 900033
+USE_BINUTILS= yes
+LDFLAGS+= -B${LOCALBASE}/bin
+.endif
-post-install:
- ${FIND} ${STAGEDIR}${PREFIX}/include/gloox ! -type d | \
- ${SED} "s,${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
- ${FIND} ${STAGEDIR}${PREFIX}/include/gloox -type d | ${SORT} -r | \
- ${SED} "s,${STAGEDIR}${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+post-patch:
+ @${REINPLACE_CMD} -e \
+ 's|-lgcrypt||' ${WRKSRC}/configure
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>