aboutsummaryrefslogtreecommitdiff
path: root/net-im/gloox/Makefile
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2014-01-17 12:27:30 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2014-01-17 12:27:30 +0000
commita54b9bae02d89d6a0f5e5cd833e7b6afcb21f8b3 (patch)
tree27c2f49e0dffad203e065be5a0328ce4ee77c9e8 /net-im/gloox/Makefile
parent2a66bb8ec187ed8b1558d8af2fa4635f2c7370b4 (diff)
downloadports-a54b9bae02d89d6a0f5e5cd833e7b6afcb21f8b3.tar.gz
ports-a54b9bae02d89d6a0f5e5cd833e7b6afcb21f8b3.zip
Notes
Diffstat (limited to 'net-im/gloox/Makefile')
-rw-r--r--net-im/gloox/Makefile14
1 files changed, 7 insertions, 7 deletions
diff --git a/net-im/gloox/Makefile b/net-im/gloox/Makefile
index 35373705c346..f14a45201cf2 100644
--- a/net-im/gloox/Makefile
+++ b/net-im/gloox/Makefile
@@ -10,8 +10,8 @@ MASTER_SITES= http://camaya.net/download/
MAINTAINER= ports@FreeBSD.org
COMMENT= Jabber/XMPP client library
-LIB_DEPENDS= idn.17:${PORTSDIR}/dns/libidn \
- gnutls.26:${PORTSDIR}/security/gnutls
+LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
+ libgnutls.so:${PORTSDIR}/security/gnutls
USE_AUTOTOOLS= libtool
USE_BZIP2= yes
@@ -21,13 +21,13 @@ CPPFLAGS+= ${CXXFLAGS} -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_LDCONFIG= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e 's|libgnutls-config|pkg-config gnutls|' ${WRKSRC}/configure
+
post-install:
- @${FIND} ${PREFIX}/include/gloox ! -type d | \
- ${SED} "s,${PREFIX}/,," >> ${TMPPLIST}
- @${FIND} ${PREFIX}/include/gloox -type d | ${SORT} -r | \
- ${SED} "s,${PREFIX}/,@dirrm ," >> ${TMPPLIST}
+ ${FIND} ${STAGEDIR}${PREFIX}/include/gloox ! -type d | \
+ ${SED} "s,${STAGEDIR}${PREFIX}/,," >> ${TMPPLIST}
+ ${FIND} ${STAGEDIR}${PREFIX}/include/gloox -type d | ${SORT} -r | \
+ ${SED} "s,${STAGEDIR}${PREFIX}/,@dirrm ," >> ${TMPPLIST}
.include <bsd.port.mk>