aboutsummaryrefslogtreecommitdiff
path: root/net-im/gloox
diff options
context:
space:
mode:
authorGuido Falsi <madpilot@FreeBSD.org>2015-09-26 13:04:22 +0000
committerGuido Falsi <madpilot@FreeBSD.org>2015-09-26 13:04:22 +0000
commitbd5cee9c8495f402564e780d4b745e46a60ecf31 (patch)
treed5f3ee05c7d937691a022dbfbe0218eab2a3c60e /net-im/gloox
parent249b34beb289364effd8d7b92e2dddf6ff94102d (diff)
Notes
Diffstat (limited to 'net-im/gloox')
-rw-r--r--net-im/gloox/Makefile11
-rw-r--r--net-im/gloox/distinfo4
-rw-r--r--net-im/gloox/files/patch-src__examples__e2ee_client.cpp4
-rw-r--r--net-im/gloox/files/patch-src__examples__e2ee_server.cpp4
-rw-r--r--net-im/gloox/files/patch-src__examples__ft_recv.cpp4
-rw-r--r--net-im/gloox/files/patch-src__examples__linklocal_example.cpp21
-rw-r--r--net-im/gloox/files/patch-src__linklocalclient.cpp11
-rw-r--r--net-im/gloox/files/patch-src__linklocalmanager.cpp11
8 files changed, 60 insertions, 10 deletions
diff --git a/net-im/gloox/Makefile b/net-im/gloox/Makefile
index a9d558a99483..213d4d60669b 100644
--- a/net-im/gloox/Makefile
+++ b/net-im/gloox/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= gloox
-PORTVERSION= 1.0.13
+PORTVERSION= 1.0.14
CATEGORIES= net-im
MASTER_SITES= http://camaya.net/download/
@@ -10,6 +10,7 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= Jabber/XMPP client library
LICENSE= GPLv3
+#LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libidn.so:${PORTSDIR}/dns/libidn \
libgnutls.so:${PORTSDIR}/security/gnutls
@@ -24,9 +25,15 @@ LDFLAGS+= -L${LOCALBASE}/lib
PORTSCOUT= skipv:1.0.x
+OPTIONS_DEFINE= MDNSRESPONDER
+
+MDNSRESPONDER_LIB_DEPENDS= libdns_sd.so:${PORTSDIR}/net/mDNSResponder
+MDNSRESPONDER_CONFIGURE_ENABLE= mdns
+
post-patch:
@${REINPLACE_CMD} -e \
- 's| -ansi||' ${WRKSRC}/configure
+ 's| -ansi|| ; \
+ s|\(enable_mdns=\)yes|\1$$enableval|' ${WRKSRC}/configure
@${FIND} ${WRKSRC} -name "Makefile.in" | ${XARGS} ${REINPLACE_CMD} -e \
's| -pedantic|| ; \
s| -pipe||'
diff --git a/net-im/gloox/distinfo b/net-im/gloox/distinfo
index 6dab03cdf36b..bc061295e1df 100644
--- a/net-im/gloox/distinfo
+++ b/net-im/gloox/distinfo
@@ -1,2 +1,2 @@
-SHA256 (gloox-1.0.13.tar.bz2) = 4d9f1eeac97c6563dde11d4bdba346a025ef27908b088b47b5c8d3d03df6ea8a
-SIZE (gloox-1.0.13.tar.bz2) = 675842
+SHA256 (gloox-1.0.14.tar.bz2) = 520b72a66fa9fea917a0336872101539f0bea30d1f871e12c31b6c2cd0203941
+SIZE (gloox-1.0.14.tar.bz2) = 696719
diff --git a/net-im/gloox/files/patch-src__examples__e2ee_client.cpp b/net-im/gloox/files/patch-src__examples__e2ee_client.cpp
index d5782161f4d3..6631984cfdb1 100644
--- a/net-im/gloox/files/patch-src__examples__e2ee_client.cpp
+++ b/net-im/gloox/files/patch-src__examples__e2ee_client.cpp
@@ -1,6 +1,6 @@
---- src/examples/e2ee_client.cpp.orig
+--- src/examples/e2ee_client.cpp.orig 2015-08-11 14:37:51 UTC
+++ src/examples/e2ee_client.cpp
-@@ -12,8 +12,8 @@
+@@ -24,8 +24,8 @@
using namespace gloox;
#include <unistd.h>
diff --git a/net-im/gloox/files/patch-src__examples__e2ee_server.cpp b/net-im/gloox/files/patch-src__examples__e2ee_server.cpp
index ae339096bc7c..47c21aa73425 100644
--- a/net-im/gloox/files/patch-src__examples__e2ee_server.cpp
+++ b/net-im/gloox/files/patch-src__examples__e2ee_server.cpp
@@ -1,6 +1,6 @@
---- src/examples/e2ee_server.cpp.orig
+--- src/examples/e2ee_server.cpp.orig 2015-08-11 14:37:51 UTC
+++ src/examples/e2ee_server.cpp
-@@ -12,8 +12,8 @@
+@@ -24,8 +24,8 @@
using namespace gloox;
#include <unistd.h>
diff --git a/net-im/gloox/files/patch-src__examples__ft_recv.cpp b/net-im/gloox/files/patch-src__examples__ft_recv.cpp
index ad681938ac83..e2f5ea1e94e6 100644
--- a/net-im/gloox/files/patch-src__examples__ft_recv.cpp
+++ b/net-im/gloox/files/patch-src__examples__ft_recv.cpp
@@ -1,6 +1,6 @@
---- src/examples/ft_recv.cpp.orig
+--- src/examples/ft_recv.cpp.orig 2015-08-11 14:37:51 UTC
+++ src/examples/ft_recv.cpp
-@@ -11,7 +11,7 @@
+@@ -23,7 +23,7 @@
using namespace gloox;
#include <unistd.h>
diff --git a/net-im/gloox/files/patch-src__examples__linklocal_example.cpp b/net-im/gloox/files/patch-src__examples__linklocal_example.cpp
new file mode 100644
index 000000000000..3ae81ee8ea60
--- /dev/null
+++ b/net-im/gloox/files/patch-src__examples__linklocal_example.cpp
@@ -0,0 +1,21 @@
+--- src/examples/linklocal_example.cpp.orig 2015-08-11 14:37:51 UTC
++++ src/examples/linklocal_example.cpp
+@@ -111,15 +111,15 @@ class LinkLocalExample : public LinkLoca
+ for( ; it != services.end(); ++it )
+ {
+ printf( "%s:\t%s.%s%s on interface %d\n", (*it).flag == LinkLocal::AddService ? "Added" : "Removed", (*it).service.c_str(), (*it).regtype.c_str(),
+- (*it).domain.c_str(), (*it).interface );
++ (*it).domain.c_str(), (*it).iface );
+ if( !m_fClient /*&& (*it)->flag == LinkLocal::AddService && (*it)->service != "js@pitufo"*/ )
+ {
+ printf( "setting up new local client and connecting to %s.%s%s on interface %d\n",
+- (*it).service.c_str(), (*it).regtype.c_str(), (*it).domain.c_str(), (*it).interface );
++ (*it).service.c_str(), (*it).regtype.c_str(), (*it).domain.c_str(), (*it).iface );
+ m_fClient = new LinkLocal::Client( JID( "js@pitufo" ) );
+ m_fClient->logInstance().registerLogHandler( LogLevelDebug, LogAreaAll, this );
+ m_fClient->registerConnectionListener( this );
+- if( !m_fClient->connect( (*it).service, (*it).regtype, (*it).domain, (*it).interface ) )
++ if( !m_fClient->connect( (*it).service, (*it).regtype, (*it).domain, (*it).iface ) )
+ {
+ printf( "m_fClient->connect() failed\n" );
+ }
diff --git a/net-im/gloox/files/patch-src__linklocalclient.cpp b/net-im/gloox/files/patch-src__linklocalclient.cpp
new file mode 100644
index 000000000000..711b6b6cbf85
--- /dev/null
+++ b/net-im/gloox/files/patch-src__linklocalclient.cpp
@@ -0,0 +1,11 @@
+--- src/linklocalclient.cpp.orig 2015-08-11 14:37:51 UTC
++++ src/linklocalclient.cpp
+@@ -55,7 +55,7 @@ namespace gloox
+ bool Client::connect( const std::string& service, const std::string& type,
+ const std::string& domain, int iface )
+ {
+- m_interface = interface;
++ m_interface = iface;
+ return resolve( service, type, domain );
+ }
+
diff --git a/net-im/gloox/files/patch-src__linklocalmanager.cpp b/net-im/gloox/files/patch-src__linklocalmanager.cpp
new file mode 100644
index 000000000000..281462d32950
--- /dev/null
+++ b/net-im/gloox/files/patch-src__linklocalmanager.cpp
@@ -0,0 +1,11 @@
+--- src/linklocalmanager.cpp.orig 2015-08-11 14:37:51 UTC
++++ src/linklocalmanager.cpp
+@@ -197,7 +197,7 @@ namespace gloox
+
+ void Manager::handleBrowse( Flag flag, const std::string& service, const std::string& regtype, const std::string& domain, int iface, bool moreComing )
+ {
+- Service s( flag, service, regtype, domain, interface );
++ Service s( flag, service, regtype, domain, iface );
+ m_tmpServices.push_back( s );
+
+ // switch( flag )