aboutsummaryrefslogtreecommitdiff
path: root/net-im/gtkyahoo
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-11-13 01:19:23 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-11-13 01:19:23 +0000
commit268ea6f2948b61abb9b49ee6cfd8d0ed4a7202ac (patch)
tree0012e54178c6b08565c4e01b21ebca4a2b289af0 /net-im/gtkyahoo
parent8393f841e2ca6750b624e3e0ef62780c348241b4 (diff)
downloadports-268ea6f2948b61abb9b49ee6cfd8d0ed4a7202ac.tar.gz
ports-268ea6f2948b61abb9b49ee6cfd8d0ed4a7202ac.zip
Notes
Diffstat (limited to 'net-im/gtkyahoo')
-rw-r--r--net-im/gtkyahoo/Makefile11
-rw-r--r--net-im/gtkyahoo/files/patch-gtkyahoo.c10
-rw-r--r--net-im/gtkyahoo/files/patch-libyahoo_libyahoo.c30
3 files changed, 43 insertions, 8 deletions
diff --git a/net-im/gtkyahoo/Makefile b/net-im/gtkyahoo/Makefile
index b2b37233ded6..3fa84d3d5fab 100644
--- a/net-im/gtkyahoo/Makefile
+++ b/net-im/gtkyahoo/Makefile
@@ -22,14 +22,9 @@ GNU_CONFIGURE= yes
USE_LDCONFIG= yes
ONLY_FOR_ARCHS= i386
-.include <bsd.port.pre.mk>
-
-.if ${OSVERSION} >= 700042
-BROKEN= Does not compile with GCC 4.2
-.endif
-
post-patch:
- @${REINPLACE_CMD} -e '/@INSTALL@/s/$$INSTALL/${INSTALL}/' \
+ @${REINPLACE_CMD} -e '/@INSTALL@/s/$$INSTALL/${INSTALL}/; \
+ s/echo aout/echo elf/' \
${WRKSRC}/libyahoo/configure
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/net-im/gtkyahoo/files/patch-gtkyahoo.c b/net-im/gtkyahoo/files/patch-gtkyahoo.c
new file mode 100644
index 000000000000..35cd492a7939
--- /dev/null
+++ b/net-im/gtkyahoo/files/patch-gtkyahoo.c
@@ -0,0 +1,10 @@
+--- gtkyahoo.c.orig 2007-11-12 15:21:19.000000000 +0100
++++ gtkyahoo.c 2007-11-12 15:21:22.000000000 +0100
+@@ -1456,6 +1456,7 @@
+ int setgeom = 0;
+ int curarg = 1;
+ GtkAllocation initial_geometry;
++ initial_geometry.x = initial_geometry.y = initial_geometry.width = initial_geometry.height = 0;
+
+ DBG_Open(NULL);
+
diff --git a/net-im/gtkyahoo/files/patch-libyahoo_libyahoo.c b/net-im/gtkyahoo/files/patch-libyahoo_libyahoo.c
new file mode 100644
index 000000000000..44a1d5aba1ea
--- /dev/null
+++ b/net-im/gtkyahoo/files/patch-libyahoo_libyahoo.c
@@ -0,0 +1,30 @@
+--- libyahoo/libyahoo.c.orig 2007-11-12 15:12:19.000000000 +0100
++++ libyahoo/libyahoo.c 2007-11-12 15:13:33.000000000 +0100
+@@ -746,15 +746,15 @@
+ static char *yahoo_urlencode(const char *instr)
+ {
+ register int ipos, bpos; //input str pos., buffer pos.
+- static unsigned char *str = NULL;
++ static char *str = NULL;
+ int len = strlen(instr);
+ int tmp;
+
+ //attempt to reuse buffer
+ if (NULL == str)
+- str = (unsigned char *) malloc(3 * len + 1);
++ str = malloc(3 * len + 1);
+ else
+- str = (unsigned char *) realloc(str, 3 * len + 1);
++ str = realloc(str, 3 * len + 1);
+
+ //malloc, realloc failed ?
+ if (errno == ENOMEM)
+@@ -791,7 +791,7 @@
+
+ //free extra alloc'ed mem.
+ tmp = strlen(str);
+- str = (unsigned char *) realloc(str, tmp + 1);
++ str = realloc(str, tmp + 1);
+
+ return (str);
+ }