aboutsummaryrefslogtreecommitdiff
path: root/net-im/hotot
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2012-10-30 10:39:29 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2012-10-30 10:39:29 +0000
commitb7377280b1fee1aebc365cbe7470b7a0264124bd (patch)
tree51655895f32d4a185dd33bcd3bbfa827f534e74a /net-im/hotot
parent1f0745998bf7dafdaf62ed3baa6a17994e7e136d (diff)
downloadports-b7377280b1fee1aebc365cbe7470b7a0264124bd.tar.gz
ports-b7377280b1fee1aebc365cbe7470b7a0264124bd.zip
Notes
Diffstat (limited to 'net-im/hotot')
-rw-r--r--net-im/hotot/Makefile49
-rw-r--r--net-im/hotot/distinfo2
-rw-r--r--net-im/hotot/files/patch-hotot_hotot.py18
-rw-r--r--net-im/hotot/pkg-descr19
-rw-r--r--net-im/hotot/pkg-plist297
5 files changed, 385 insertions, 0 deletions
diff --git a/net-im/hotot/Makefile b/net-im/hotot/Makefile
new file mode 100644
index 000000000000..ef446b7e7335
--- /dev/null
+++ b/net-im/hotot/Makefile
@@ -0,0 +1,49 @@
+# Created by: Alexey Dokuchaev <danfe@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= hotot
+PORTVERSION= 0.9.8.8
+CATEGORIES= net-im www
+DISTNAME= ${GH_ACCOUNT}-${GH_PROJECT}-${GH_COMMIT}
+
+MAINTAINER= danfe@FreeBSD.org
+COMMENT= Lightweight, flexible microblogging client
+
+LICENSE= LGPL3
+
+RUN_DEPENDS= ${PYTHON_SITELIBDIR}/webkit/__init__.py:${PORTSDIR}/www/py-webkitgtk \
+ ${PYTHON_SITELIBDIR}/keybinder/__init__.py:${PORTSDIR}/x11/keybinder
+
+USE_GITHUB= yes
+GH_ACCOUNT= shellex
+GH_PROJECT= Hotot
+GH_TAGNAME= master
+GH_COMMIT= 9c8c8a2
+
+USE_CMAKE= yes
+USE_GETTEXT= yes
+USE_PYTHON= yes
+USE_QT4= moc_build qmake_build rcc_build uic_build \
+ corelib gui sql webkit
+USE_GNOME= intltool
+INSTALLS_ICONS= yes
+
+CFLAGS+= -I${LOCALBASE}/include # does not uphold CPPFLAGS
+
+post-patch:
+# Upstream should probably use platform.system() instead of hardcoding its
+# name in Python code (at least)
+ @${REINPLACE_CMD} -e 's,Linux,${OPSYS},' ${WRKSRC}/data/js/conf.js \
+ ${WRKSRC}/data/js/util.js ${WRKSRC}/hotot/view.py
+# Strip shlib versions from the library filenames
+ @${REINPLACE_CMD} -E 's,so\.[0-9]+,so,' ${WRKSRC}/hotot/utils.py
+# Remove `sourceid' parameter from the search string
+ @${REINPLACE_CMD} -e 's,sourceid=chrome&,,' \
+ ${WRKSRC}/data/js/ui.context_menu.js
+# Sanitize font selection list
+ @${REINPLACE_CMD} -e "/font_list/s/\[.*/['DejaVu Sans', 'Bitstream Vera Sans', 'Droid Sans', 'Verdana', 'Arial', 'Helvetica']/" \
+ ${WRKSRC}/data/js/conf.js
+# Remove stale backup files (or they would pollute pkg-plist)
+ @${FIND} ${WRKSRC} -type f -name *.bak -delete
+
+.include <bsd.port.mk>
diff --git a/net-im/hotot/distinfo b/net-im/hotot/distinfo
new file mode 100644
index 000000000000..80025a973cf1
--- /dev/null
+++ b/net-im/hotot/distinfo
@@ -0,0 +1,2 @@
+SHA256 (shellex-Hotot-9c8c8a2.tar.gz) = 6689abd05454513308093770f382efd6677c81f4d13070f2b8970e17efa8e28b
+SIZE (shellex-Hotot-9c8c8a2.tar.gz) = 1179741
diff --git a/net-im/hotot/files/patch-hotot_hotot.py b/net-im/hotot/files/patch-hotot_hotot.py
new file mode 100644
index 000000000000..25ef1980a92f
--- /dev/null
+++ b/net-im/hotot/files/patch-hotot_hotot.py
@@ -0,0 +1,18 @@
+--- hotot/hotot.py.orig
++++ hotot/hotot.py
+@@ -377,12 +377,10 @@
+ config.loads();
+ try:
+ import ctypes
+- libc = ctypes.CDLL('libc.so.6')
+- libc.prctl(15, 'hotot', 0, 0, 0)
++ libc = ctypes.CDLL(os.path.join('/usr/lib', 'libc.so'))
++ libc.setproctitle('hotot')
+ except:
+- import dl
+- libc = dl.open('/lib/libc.so.6')
+- libc.call('prctl', 15, 'hotot', 0, 0, 0)
++ pass
+
+ agent.init_notify()
+ app = Hotot()
diff --git a/net-im/hotot/pkg-descr b/net-im/hotot/pkg-descr
new file mode 100644
index 000000000000..c68853c522ea
--- /dev/null
+++ b/net-im/hotot/pkg-descr
@@ -0,0 +1,19 @@
+Hotot is a multi-column microblogging client written with HTML5 technologies
+through Webkit.
+
+It supports Twitter and Identi.ca services, as well as real-time update (via
+Twitter streaming API), profile editing, multi-lingual, thread conversations,
+three level in-app effects, trending topics detailed into city level, color
+labels (assign colors to people).
+
+For a geek, it has native notification system, HTTP/Socks proxy, vim-style
+keyboard shortcuts, and a powerful Kismet content filter system which could
+perform a few automated tasks, and speech input on Google Chrome.
+
+It supports Instapaper/ReadItLater, Google tweet translation, geographic
+information shown on Google Maps, plenty of image upload services including
+Twitter official one (and their previews), video preview like YouTube, URL
+shorten and unshorten (many beautiful prefixes), and user stats through the
+internal extensions.
+
+WWW: http://www.hotot.org/
diff --git a/net-im/hotot/pkg-plist b/net-im/hotot/pkg-plist
new file mode 100644
index 000000000000..1ec2e840176d
--- /dev/null
+++ b/net-im/hotot/pkg-plist
@@ -0,0 +1,297 @@
+bin/hotot
+bin/hotot-qt
+%%PYTHON_SITELIBDIR%%/hotot/__init__.py
+%%PYTHON_SITELIBDIR%%/hotot/__init__.pyc
+%%PYTHON_SITELIBDIR%%/hotot/agent.py
+%%PYTHON_SITELIBDIR%%/hotot/agent.pyc
+%%PYTHON_SITELIBDIR%%/hotot/config.py
+%%PYTHON_SITELIBDIR%%/hotot/config.pyc
+%%PYTHON_SITELIBDIR%%/hotot/gtknotification.py
+%%PYTHON_SITELIBDIR%%/hotot/gtknotification.pyc
+%%PYTHON_SITELIBDIR%%/hotot/hotot.py
+%%PYTHON_SITELIBDIR%%/hotot/hotot.pyc
+%%PYTHON_SITELIBDIR%%/hotot/i18n.py
+%%PYTHON_SITELIBDIR%%/hotot/i18n.pyc
+%%PYTHON_SITELIBDIR%%/hotot/utils.py
+%%PYTHON_SITELIBDIR%%/hotot/utils.pyc
+%%PYTHON_SITELIBDIR%%/hotot/view.py
+%%PYTHON_SITELIBDIR%%/hotot/view.pyc
+@dirrm %%PYTHON_SITELIBDIR%%/hotot
+share/applications/hotot.desktop
+share/applications/hotot-qt.desktop
+share/hotot/_locales/bg/messages.json
+share/hotot/_locales/bn/messages.json
+share/hotot/_locales/ca/messages.json
+share/hotot/_locales/de/messages.json
+share/hotot/_locales/el/messages.json
+share/hotot/_locales/en/messages.json
+share/hotot/_locales/es/messages.json
+share/hotot/_locales/fr/messages.json
+share/hotot/_locales/it/messages.json
+share/hotot/_locales/ja/messages.json
+share/hotot/_locales/lv/messages.json
+share/hotot/_locales/nl/messages.json
+share/hotot/_locales/pl_PL/messages.json
+share/hotot/_locales/pt_BR/messages.json
+share/hotot/_locales/ru/messages.json
+share/hotot/_locales/uk/messages.json
+share/hotot/_locales/zh_CAN/messages.json
+share/hotot/_locales/zh_CLS/messages.json
+share/hotot/_locales/zh_CN/messages.json
+share/hotot/_locales/zh_TW/messages.json
+share/hotot/css/hotot.widget.css
+share/hotot/css/mochi.css
+share/hotot/css/style.css
+share/hotot/ext/ext.js
+share/hotot/ext/org.hotot.appmask/entry.js
+share/hotot/ext/org.hotot.appmask/icon.png
+share/hotot/ext/org.hotot.cfw/entry.js
+share/hotot/ext/org.hotot.cfw/ic16_cfw.png
+share/hotot/ext/org.hotot.cfw/icon.png
+share/hotot/ext/org.hotot.gmap/entry.js
+share/hotot/ext/org.hotot.gmap/ic16_marker.png
+share/hotot/ext/org.hotot.gmap/icon.png
+share/hotot/ext/org.hotot.expandurls/entry.js
+share/hotot/ext/org.hotot.sample/entry.js
+share/hotot/ext/org.hotot.shorturl/entry.js
+share/hotot/ext/org.hotot.shorturl/icon.png
+share/hotot/ext/org.hotot.stat/16.png
+share/hotot/ext/org.hotot.stat/ani_loading_bar_gray.gif
+share/hotot/ext/org.hotot.stat/entry.js
+share/hotot/ext/org.hotot.stat/icon.png
+share/hotot/ext/org.hotot.stat/jquery.flot.min.js
+share/hotot/ext/org.hotot.stat/jquery.flot.pie.min.js
+share/hotot/ext/org.hotot.stat/summary.html
+share/hotot/ext/org.hotot.translate/entry.js
+share/hotot/ext/org.hotot.translate/ic16_translate.png
+share/hotot/ext/org.hotot.translate/icon.png
+share/hotot/icons/128x128/apps/hotot.ico
+share/hotot/icons/128x128/apps/hotot.png
+share/hotot/icons/22x22/apps/hotot.png
+share/hotot/icons/24x24/apps/hotot.png
+share/hotot/icons/32x32/apps/hotot.png
+share/hotot/icons/48x48/apps/hotot.png
+share/hotot/icons/64x64/apps/hotot.png
+share/hotot/image/ani_loading_bar.gif
+share/hotot/image/dark-bg.png
+share/hotot/image/deleted_mark.png
+share/hotot/image/emit.png
+share/hotot/image/expand.png
+share/hotot/image/fold.png
+share/hotot/image/go_bg.png
+share/hotot/image/hint_arrow_up.png
+share/hotot/image/ic128_hotot.png
+share/hotot/image/ic16_arrow_down_gray.png
+share/hotot/image/ic16_arrow_up_gray.png
+share/hotot/image/ic16_checked.png
+share/hotot/image/ic16_clear_text.png
+share/hotot/image/ic16_close.png
+share/hotot/image/ic16_delete.png
+share/hotot/image/ic16_dm.png
+share/hotot/image/ic16_edit.png
+share/hotot/image/ic16_gear.png
+share/hotot/image/ic16_hotot.png
+share/hotot/image/ic16_identica.png
+share/hotot/image/ic16_imageuploader.png
+share/hotot/image/ic16_link.png
+share/hotot/image/ic16_retweet_light.png
+share/hotot/image/ic16_save.png
+share/hotot/image/ic16_save_alt.png
+share/hotot/image/ic16_smile.png
+share/hotot/image/ic16_twitter.png
+share/hotot/image/ic24_hotot.png
+share/hotot/image/ic24_hotot_mono_dark.svg
+share/hotot/image/ic24_hotot_mono_light.png
+share/hotot/image/ic24_hotot_mono_light.svg
+share/hotot/image/ic24_hotot_mono_light_blink.svg
+share/hotot/image/ic24_identica.png
+share/hotot/image/ic24_twitter.png
+share/hotot/image/ic32_hotot_mono_light.png
+share/hotot/image/ic48_lock.png
+share/hotot/image/ic48_profile_image.png
+share/hotot/image/ic64_add.png
+share/hotot/image/ic64_hotot.png
+share/hotot/image/ic64_identica.png
+share/hotot/image/ic64_twitter.png
+share/hotot/image/ic_add.png
+share/hotot/image/ic_archive.png
+share/hotot/image/ic_archive_alt.png
+share/hotot/image/ic_compose.png
+share/hotot/image/ic_dm.png
+share/hotot/image/ic_fav.png
+share/hotot/image/ic_fav_alt.png
+share/hotot/image/ic_home.png
+share/hotot/image/ic_hotot.png
+share/hotot/image/ic_list.png
+share/hotot/image/ic_mention.png
+share/hotot/image/ic_people.png
+share/hotot/image/ic_retweet.png
+share/hotot/image/ic_search.png
+share/hotot/image/tweet_ctrl_icons.png
+share/hotot/image/welcome_bg.jpg
+share/hotot/image/mask.png
+share/hotot/image/tweet_fav_indicator.png
+share/hotot/index.html
+share/hotot/js/background.coffee
+share/hotot/js/background.js
+share/hotot/js/base64.js
+share/hotot/js/conf.js
+share/hotot/js/daemon.js
+share/hotot/js/db.js
+share/hotot/js/hotot.js
+share/hotot/js/hotkey.js
+share/hotot/js/i18n.js
+share/hotot/js/jquery.js
+share/hotot/js/jquery.layout.js
+share/hotot/js/jquery.transit.min.js
+share/hotot/js/kismet.js
+share/hotot/js/lib.network.js
+share/hotot/js/lib.oauth.js
+share/hotot/js/lib.twitter.js
+share/hotot/js/mochi.js
+share/hotot/js/notification.js
+share/hotot/js/readlater.coffee
+share/hotot/js/readlater.js
+share/hotot/js/sha1.js
+share/hotot/js/toast.js
+share/hotot/js/ui.about_dlg.js
+share/hotot/js/ui.add_to_list_dlg.js
+share/hotot/js/ui.action_menu.js
+share/hotot/js/ui.context_menu.js
+share/hotot/js/ui.dm_tabs.js
+share/hotot/js/ui.error_dlg.js
+share/hotot/js/ui.exts_dlg.js
+share/hotot/js/ui.finder.js
+share/hotot/js/ui.form_checker.js
+share/hotot/js/ui.header.js
+share/hotot/js/ui.home_tabs.js
+share/hotot/js/ui.imageuploader.js
+share/hotot/js/ui.kismet_dlg.js
+share/hotot/js/ui.list_attr_dlg.js
+share/hotot/js/ui.listview.js
+share/hotot/js/ui.main.js
+share/hotot/js/ui.mention_tabs.js
+share/hotot/js/ui.peopleview.js
+share/hotot/js/ui.pin_dlg.js
+share/hotot/js/ui.prefs_dlg.js
+share/hotot/js/ui.previewer.coffee
+share/hotot/js/ui.previewer.js
+share/hotot/js/ui.profile_dlg.js
+share/hotot/js/ui.retweetview.js
+share/hotot/js/ui.searchview.js
+share/hotot/js/ui.sidebar.js
+share/hotot/js/ui.slider.js
+share/hotot/js/ui.status_box.js
+share/hotot/js/ui.template.js
+share/hotot/js/ui.trending_topicsview.js
+share/hotot/js/ui.welcome.js
+share/hotot/js/widget.autocomplete.js
+share/hotot/js/widget.scrollbar.coffee
+share/hotot/js/util.js
+share/hotot/js/widget.bubble.js
+share/hotot/js/widget.button.js
+share/hotot/js/widget.dialog.js
+share/hotot/js/widget.listview.js
+share/hotot/js/widget.radio_group.js
+share/hotot/js/widget.scrollbar.js
+share/hotot/sound/notify.wav
+share/hotot/theme/Bare/info.json
+share/hotot/theme/Bare/preview.png
+share/hotot/theme/Bare/style.css
+share/hotot/theme/Classic/info.json
+share/hotot/theme/Classic/preview.png
+share/hotot/theme/Classic/style.css
+share/hotot/theme/Iron Heart/background-stripes.gif
+share/hotot/theme/Iron Heart/expand.png
+share/hotot/theme/Iron Heart/fold.png
+share/hotot/theme/Iron Heart/ic16_close.png
+share/hotot/theme/Iron Heart/ic16_gear.png
+share/hotot/theme/Iron Heart/info.json
+share/hotot/theme/Iron Heart/preview.png
+share/hotot/theme/Iron Heart/style.css
+share/hotot/theme/New Hope/info.json
+share/hotot/theme/New Hope/preview.png
+share/hotot/theme/New Hope/style.css
+share/hotot/background.html
+share/hotot/manifest.json
+share/icons/hicolor/scalable/status/hotot_qt-inactive.svg
+share/icons/hicolor/scalable/status/hotot_qt-active.svg
+share/icons/hicolor/22x22/apps/hotot.png
+share/icons/hicolor/24x24/apps/hotot.png
+share/icons/hicolor/32x32/apps/hotot.png
+share/icons/hicolor/48x48/apps/hotot.png
+share/icons/hicolor/64x64/apps/hotot.png
+share/icons/hicolor/128x128/apps/hotot.png
+share/locale/ca/LC_MESSAGES/hotot.mo
+share/locale/de_DE/LC_MESSAGES/hotot.mo
+share/locale/es_ES/LC_MESSAGES/hotot.mo
+share/locale/es_MX/LC_MESSAGES/hotot.mo
+share/locale/fr_FR/LC_MESSAGES/hotot.mo
+share/locale/gl/LC_MESSAGES/hotot.mo
+share/locale/it_IT/LC_MESSAGES/hotot.mo
+share/locale/ja/LC_MESSAGES/hotot.mo
+share/locale/pt_BR/LC_MESSAGES/hotot.mo
+share/locale/pt_PT/LC_MESSAGES/hotot.mo
+share/locale/tr_TR/LC_MESSAGES/hotot.mo
+share/locale/zh_CN/LC_MESSAGES/hotot.mo
+share/locale/zh_TW/LC_MESSAGES/hotot.mo
+@dirrmtry share/locale/tr_TR/LC_MESSAGES
+@dirrmtry share/locale/it_IT/LC_MESSAGES
+@dirrmtry share/locale/de_DE/LC_MESSAGES
+@dirrmtry share/locale/tr_TR
+@dirrmtry share/locale/it_IT
+@dirrmtry share/locale/de_DE
+@dirrm share/hotot/theme/New Hope
+@dirrm share/hotot/theme/Iron Heart
+@dirrm share/hotot/theme/Classic
+@dirrm share/hotot/theme/Bare
+@dirrm share/hotot/theme
+@dirrm share/hotot/sound
+@dirrm share/hotot/js
+@dirrm share/hotot/image
+@dirrm share/hotot/icons/64x64/apps
+@dirrm share/hotot/icons/64x64
+@dirrm share/hotot/icons/48x48/apps
+@dirrm share/hotot/icons/48x48
+@dirrm share/hotot/icons/32x32/apps
+@dirrm share/hotot/icons/32x32
+@dirrm share/hotot/icons/24x24/apps
+@dirrm share/hotot/icons/24x24
+@dirrm share/hotot/icons/22x22/apps
+@dirrm share/hotot/icons/22x22
+@dirrm share/hotot/icons/128x128/apps
+@dirrm share/hotot/icons/128x128
+@dirrm share/hotot/icons
+@dirrm share/hotot/ext/org.hotot.translate
+@dirrm share/hotot/ext/org.hotot.stat
+@dirrm share/hotot/ext/org.hotot.shorturl
+@dirrm share/hotot/ext/org.hotot.sample
+@dirrm share/hotot/ext/org.hotot.gmap
+@dirrm share/hotot/ext/org.hotot.expandurls
+@dirrm share/hotot/ext/org.hotot.cfw
+@dirrm share/hotot/ext/org.hotot.appmask
+@dirrm share/hotot/ext
+@dirrm share/hotot/css
+@dirrm share/hotot/_locales/zh_TW
+@dirrm share/hotot/_locales/zh_CN
+@dirrm share/hotot/_locales/zh_CLS
+@dirrm share/hotot/_locales/zh_CAN
+@dirrm share/hotot/_locales/uk
+@dirrm share/hotot/_locales/ru
+@dirrm share/hotot/_locales/pt_BR
+@dirrm share/hotot/_locales/pl_PL
+@dirrm share/hotot/_locales/nl
+@dirrm share/hotot/_locales/lv
+@dirrm share/hotot/_locales/ja
+@dirrm share/hotot/_locales/it
+@dirrm share/hotot/_locales/fr
+@dirrm share/hotot/_locales/es
+@dirrm share/hotot/_locales/en
+@dirrm share/hotot/_locales/el
+@dirrm share/hotot/_locales/de
+@dirrm share/hotot/_locales/ca
+@dirrm share/hotot/_locales/bn
+@dirrm share/hotot/_locales/bg
+@dirrm share/hotot/_locales
+@dirrm share/hotot
+@dirrmtry share/applications