aboutsummaryrefslogtreecommitdiff
path: root/net-im/icqnd/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2006-08-30 12:01:02 +0000
committerRenato Botelho <garga@FreeBSD.org>2006-08-30 12:01:02 +0000
commitf12cefe82abb13ed4e86aaf644b8e64871952d4c (patch)
treea9a4303c6f0b9d8dd5433daae15f2b901f705835 /net-im/icqnd/Makefile
parent14e22ed87eb7c18049369bb8d07d35b06498b803 (diff)
Notes
Diffstat (limited to 'net-im/icqnd/Makefile')
-rw-r--r--net-im/icqnd/Makefile35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-im/icqnd/Makefile b/net-im/icqnd/Makefile
new file mode 100644
index 000000000000..4073b5b5247f
--- /dev/null
+++ b/net-im/icqnd/Makefile
@@ -0,0 +1,35 @@
+# New ports collection makefile for: icqnd
+# Date Created: 29 Ago 2006
+# Whom: Rodrigo Graeff <delphus@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= icqnd
+PORTVERSION= 0.1.9.5
+CATEGORIES= net-im
+MASTER_SITES= SF
+
+MAINTAINER= delphus@gmail.com
+COMMENT= GTK based LICQ GUI program
+
+BUILD_DEPENDS= licq:${PORTSDIR}/net-im/licq
+RUN_DEPENDS= ${BUILD_DEPENDS}
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+GNU_CONFIGURE= yes
+USE_GNOME= gtk20 gnomehack
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.pre.mk>
+
+.if ${OSVERSION} < 500000
+BROKEN= Doesn't build on 4.x
+.endif
+
+post-install:
+ @${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.post.mk>