aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabber-pyicq
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2008-01-15 13:11:29 +0000
committerRenato Botelho <garga@FreeBSD.org>2008-01-15 13:11:29 +0000
commitdaa3fc0c2f1c29971035106825adb81718d4706e (patch)
treea96fb1a5f343282e640f13ab9ee691dddfecac61 /net-im/jabber-pyicq
parent76185e146b94fb19bd4a4a71171bd863ea88ab85 (diff)
downloadports-daa3fc0c2f1c29971035106825adb81718d4706e.tar.gz
ports-daa3fc0c2f1c29971035106825adb81718d4706e.zip
Notes
Diffstat (limited to 'net-im/jabber-pyicq')
-rw-r--r--net-im/jabber-pyicq/Makefile1
-rw-r--r--net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in1
-rw-r--r--net-im/jabber-pyicq/files/patch-src_legacy_icqt.py12
3 files changed, 13 insertions, 1 deletions
diff --git a/net-im/jabber-pyicq/Makefile b/net-im/jabber-pyicq/Makefile
index 3cf5838ee092..3e5b346186b3 100644
--- a/net-im/jabber-pyicq/Makefile
+++ b/net-im/jabber-pyicq/Makefile
@@ -6,6 +6,7 @@
PORTNAME= pyicq
PORTVERSION= 0.8a
+PORTREVISION= 1
CATEGORIES= net-im
MASTER_SITES= http://www.blathersource.org/download.php/pyicq-t/
PKGNAMEPREFIX= jabber-
diff --git a/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in b/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in
index d2da9865b6c6..d5f9e0eb96e4 100644
--- a/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in
+++ b/net-im/jabber-pyicq/files/jabber-pyicq-transport.sh.in
@@ -4,7 +4,6 @@
#
# PROVIDE: jabber_pyicq
# REQUIRE: DAEMON %%JABBER_REQUIRE%%
-# BEFORE: LOGIN
# KEYWORD: shutdown
#
# Define these jabber_pyicq_* variables in one of these files:
diff --git a/net-im/jabber-pyicq/files/patch-src_legacy_icqt.py b/net-im/jabber-pyicq/files/patch-src_legacy_icqt.py
new file mode 100644
index 000000000000..b16bf791a92d
--- /dev/null
+++ b/net-im/jabber-pyicq/files/patch-src_legacy_icqt.py
@@ -0,0 +1,12 @@
+--- src/legacy/icqt.py.orig 2008-01-09 04:58:42.000000000 +0100
++++ src/legacy/icqt.py 2008-01-13 08:06:51.411126927 +0100
+@@ -327,7 +327,8 @@
+ status = msg[0] + ": " + status
+
+ status = status.decode(charset, 'replace')
+- LogEvent(INFO, self.session.jabberID, "Away (%s, %s) message %s" % (charset, msg[0], status))
++ utfmsg = unicode(msg[0], errors='replace')
++ LogEvent(INFO, self.session.jabberID, "Away (%s, %s) message %s" % (charset, utfmsg[0], status))
+
+ if status == "Away" or status=="I am currently away from the computer." or status=="I am away from my computer right now.":
+ status = ""