aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabber-pymsn
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2007-01-15 12:03:28 +0000
committerRenato Botelho <garga@FreeBSD.org>2007-01-15 12:03:28 +0000
commitdd05b52dba9d80d49afb6f5b34039e124a119430 (patch)
tree2c59dd832d47a44f22b66c3ba58bf3ec3fd763f2 /net-im/jabber-pymsn
parenta6f3b1c3a3b08e13528c4357e3d078f787a93835 (diff)
downloadports-dd05b52dba9d80d49afb6f5b34039e124a119430.tar.gz
ports-dd05b52dba9d80d49afb6f5b34039e124a119430.zip
Notes
Diffstat (limited to 'net-im/jabber-pymsn')
-rw-r--r--net-im/jabber-pymsn/Makefile4
-rw-r--r--net-im/jabber-pymsn/distinfo6
-rw-r--r--net-im/jabber-pymsn/files/patch-src_main.py14
3 files changed, 19 insertions, 5 deletions
diff --git a/net-im/jabber-pymsn/Makefile b/net-im/jabber-pymsn/Makefile
index 8f5336d56510..85758f82a775 100644
--- a/net-im/jabber-pymsn/Makefile
+++ b/net-im/jabber-pymsn/Makefile
@@ -5,8 +5,7 @@
# $FreeBSD$
PORTNAME= pymsn
-DISTVERSION= 0.11.2-dev2
-PORTREVISION= 1
+DISTVERSION= 0.11.2
PORTEPOCH= 1
CATEGORIES= net-im
MASTER_SITES= http://delx.cjb.net/pymsnt/tarballs/ \
@@ -74,6 +73,7 @@ post-patch:
${WRKSRC}/src/main.py
@${REINPLACE_CMD} -i "" 's|#!.*$$|#!${LOCAL_PYTHON}|' \
${WRKSRC}/PyMSNt.py
+ @${RM} -f ${WRKSRC}/src/main.py.orig
do-install:
${MKDIR} ${INST_DIR}/src ${INST_DIR}/data
diff --git a/net-im/jabber-pymsn/distinfo b/net-im/jabber-pymsn/distinfo
index 6c3ca1a6ea4d..b0df8dc15c3b 100644
--- a/net-im/jabber-pymsn/distinfo
+++ b/net-im/jabber-pymsn/distinfo
@@ -1,3 +1,3 @@
-MD5 (jabber/pymsnt-0.11.2-dev2.tar.gz) = 92494ba56a9b2c553b44f14cbad20e1d
-SHA256 (jabber/pymsnt-0.11.2-dev2.tar.gz) = 6fd35ce292147aaeaf68e7d84ed0aefc092cf745b638fd463b07d53fdcb9a661
-SIZE (jabber/pymsnt-0.11.2-dev2.tar.gz) = 313504
+MD5 (jabber/pymsnt-0.11.2.tar.gz) = 855cb25e2254522ba98ba02d59fdd9b6
+SHA256 (jabber/pymsnt-0.11.2.tar.gz) = d0d7064f50133453d170008e075de2d3ec0138e593c5bc9ec4052cfb2fe28459
+SIZE (jabber/pymsnt-0.11.2.tar.gz) = 311947
diff --git a/net-im/jabber-pymsn/files/patch-src_main.py b/net-im/jabber-pymsn/files/patch-src_main.py
new file mode 100644
index 000000000000..ea09afa24bd3
--- /dev/null
+++ b/net-im/jabber-pymsn/files/patch-src_main.py
@@ -0,0 +1,14 @@
+--- src/main.py.orig Wed Oct 18 01:40:55 2006
++++ src/main.py Sun Jan 14 19:47:46 2007
+@@ -390,7 +390,10 @@
+ # Set SIGHUP to reload the config file & close & open debug file
+ signal.signal(signal.SIGHUP, SIGHUPstuff)
+ # Load some scripts for PID and daemonising
+- from twisted.scripts import twistd
++ try:
++ from twisted.scripts import _twistd_unix as twistd
++ except:
++ from twisted.scripts import twistd
+
+
+ def main():