aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabber.el/Makefile
diff options
context:
space:
mode:
authorAndrey Slusar <anray@FreeBSD.org>2006-05-26 20:08:06 +0000
committerAndrey Slusar <anray@FreeBSD.org>2006-05-26 20:08:06 +0000
commitabf9bc09d1ff49676af3fd3954b0c26608250f1c (patch)
tree6fe07b148bc49ca2bab25dea5512a5b8732a2984 /net-im/jabber.el/Makefile
parentf04cca356460a649e927a2f9b1184091312b22f6 (diff)
downloadports-abf9bc09d1ff49676af3fd3954b0c26608250f1c.tar.gz
ports-abf9bc09d1ff49676af3fd3954b0c26608250f1c.zip
Notes
Diffstat (limited to 'net-im/jabber.el/Makefile')
-rw-r--r--net-im/jabber.el/Makefile50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-im/jabber.el/Makefile b/net-im/jabber.el/Makefile
new file mode 100644
index 000000000000..947a65d21e38
--- /dev/null
+++ b/net-im/jabber.el/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: jabber.el
+# Date created: 26 May 2006
+# Whom: Max N. Boyarov <m.boyarov@bsd.by>
+#
+# $FreeBSD$
+
+PORTNAME= jabber.el
+PORTVERSION= 0.7
+CATEGORIES= net-im elisp
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= emacs-jabber
+DISTNAME= emacs-jabber-${PORTVERSION}
+
+MAINTAINER= m.boyarov@bsd.by
+COMMENT= A minimal jabber client for [X]Emacs
+
+NO_BUILD= yes
+
+INFO= jabber.el
+PORTDOCS+= AUTHORS NEWS README filetransfer.txt
+
+EMACS_LISPDIR= ${PREFIX}/share/emacs/site-lisp/${PORTNAME}
+XEMACS_LISPDIR= ${PREFIX}/lib/xemacs/site-lisp/${PORTNAME}
+
+## Generate info
+pre-install:
+ ${REINPLACE_CMD} -e 's/^@setfilename jabber.info/@setfilename jabber.el.info/' \
+ -e 's/\* jabber\.el: (jabber)\./* jabber.el: (jabber.el)./' \
+ ${WRKSRC}/jabber.texi
+ ( cd ${WRKSRC}; makeinfo --no-split jabber.texi; )
+
+do-install:
+ ${MKDIR} ${EMACS_LISPDIR}
+ ${MKDIR} ${XEMACS_LISPDIR}
+ cd ${WRKSRC}; \
+ for el in `ls -1 *.el`; do \
+ ${INSTALL_DATA} $$el ${EMACS_LISPDIR}/; \
+ ${LN} -sf ${EMACS_LISPDIR}/$$el ${XEMACS_LISPDIR}/; \
+ done;
+
+ ${INSTALL_DATA} ${WRKSRC}/${INFO}.info ${PREFIX}/${INFO_PATH}/
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+.for doc in ${PORTDOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${doc} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>