aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabber/Makefile
diff options
context:
space:
mode:
authorMartin Matuska <mm@FreeBSD.org>2007-07-18 06:09:10 +0000
committerMartin Matuska <mm@FreeBSD.org>2007-07-18 06:09:10 +0000
commit227bddd7a1d1f488314b2a054c4533b14aaec83f (patch)
treead5ef19e917e9f5100964d180e81b10d2aa14002 /net-im/jabber/Makefile
parent837915d5e3a96e8217efde292762ed81a82b9f67 (diff)
- update to 1.6.1
- additional patches - fix jabber.in, pkg-message.in Approved by: garga (mentor)
Notes
Notes: svn path=/head/; revision=195826
Diffstat (limited to 'net-im/jabber/Makefile')
-rw-r--r--net-im/jabber/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/net-im/jabber/Makefile b/net-im/jabber/Makefile
index 548a67997f4e..bbe7eb0331f0 100644
--- a/net-im/jabber/Makefile
+++ b/net-im/jabber/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= jabber
-PORTVERSION= 1.6.0
+PORTVERSION= 1.6.1
PORTEPOCH= 1
CATEGORIES= net-im ipv6
MASTER_SITES= http://download.jabberd.org/jabberd14/
@@ -19,14 +19,15 @@ COMMENT= XMPP/Jabber server daemon
LIB_DEPENDS= pth.20:${PORTSDIR}/devel/pth-hard \
popt.0:${PORTSDIR}/devel/popt \
idn.16:${PORTSDIR}/dns/libidn \
- expat.6:${PORTSDIR}/textproc/expat2
+ expat.6:${PORTSDIR}/textproc/expat2 \
+ tasn1.3:${PORTSDIR}/security/libtasn1 \
+ gnutls.13:${PORTSDIR}/security/gnutls
OPTIONS= IPV6 "Enable IPv6 support" off \
MYSQL "Build with MySQL support" off \
PGSQL "Build with PostgreSQL support" off
USE_RC_SUBR= jabber
-USE_OPENSSL= yes
USE_ICONV= yes
USE_GMAKE= yes
USE_GETTEXT= yes
@@ -48,8 +49,8 @@ JABBER_SPOOLDIR="/var/spool/jabberd"
JABBER_LOGDIR= "/var/log/jabberd"
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --localstatedir=/var --enable-ssl \
- --with-ssl-legacy=${OPENSSLBASE} --sysconfdir=${JABBER_ETCDIR} \
+CONFIGURE_ARGS= --mandir=${MANPREFIX}/man --localstatedir=/var \
+ --sysconfdir=${JABBER_ETCDIR} \
--includedir=${TARGETDIR}/include/jabber \
--libdir=${TARGETDIR}/lib/jabber