aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabber
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-29 16:13:16 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2017-11-29 16:13:16 +0000
commit5989eb5b6ebd643a666ef1016ce627ab5f0ebed7 (patch)
treec7d69e5306470fe04df2f970be5c9289cd7bab00 /net-im/jabber
parentf9f96a0ac5edd7f4ff70df97407286c9f90b4ed9 (diff)
downloadports-5989eb5b6ebd643a666ef1016ce627ab5f0ebed7.tar.gz
ports-5989eb5b6ebd643a666ef1016ce627ab5f0ebed7.zip
Notes
Diffstat (limited to 'net-im/jabber')
-rw-r--r--net-im/jabber/Makefile39
1 files changed, 17 insertions, 22 deletions
diff --git a/net-im/jabber/Makefile b/net-im/jabber/Makefile
index b635aa247168..0c4892b640aa 100644
--- a/net-im/jabber/Makefile
+++ b/net-im/jabber/Makefile
@@ -14,7 +14,8 @@ DIST_SUBDIR= jabber
MAINTAINER= ports@FreeBSD.org
COMMENT= XMPP/Jabber server daemon
-LICENSE= GPLv2
+LICENSE= GPLv2+
+LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libpopt.so:devel/popt \
libpth.so:devel/pth-hard \
@@ -22,23 +23,19 @@ LIB_DEPENDS= libpopt.so:devel/popt \
libgnutls.so:security/gnutls \
libexpat.so:textproc/expat2
-OPTIONS_DEFINE= IPV6 MYSQL PGSQL DOCS
-
+USES= gettext gmake iconv libtool localbase:ldflags pkgconfig
GNU_CONFIGURE= yes
-INSTALL_TARGET= install-strip
-USES= gettext gmake iconv libtool pkgconfig
USE_RC_SUBR= jabber
CONFIGURE_ARGS= --localstatedir=/var \
--sysconfdir=${JABBER_ETCDIR} \
--includedir=${PREFIX}/include/jabber \
--libdir=${PREFIX}/lib/jabber
+INSTALL_TARGET= install-strip
USE_LDCONFIG= ${PREFIX}/lib/jabber
MAKE_JOBS_UNSAFE= yes
-CPPFLAGS+= $$(pth-config --cflags) \
- -I${LOCALBASE}/include
-LDFLAGS+= $$(pth-config --ldflags) \
- -L${LOCALBASE}/lib
+CPPFLAGS+= $$(pth-config --cflags)
+LDFLAGS+= $$(pth-config --ldflags)
SUB_FILES= pkg-message
SUB_LIST= JABBER_USER=${JABBER_USER} \
@@ -63,21 +60,17 @@ JABBER_RUNDIR= /var/run/jabberd
JABBER_SPOOLDIR=/var/spool/jabberd
JABBER_LOGDIR= /var/log/jabberd
-.include <bsd.port.options.mk>
+OPTIONS_DEFINE= IPV6 MYSQL PGSQL DOCS
-.if ${PORT_OPTIONS:MMYSQL}
-USE_MYSQL= yes
-CONFIGURE_ARGS+= --with-mysql=${LOCALBASE}
-.endif
+MYSQL_USES= mysql
+MYSQL_CONFIGURE_ON= --with-mysql=${LOCALBASE}
-.if ${PORT_OPTIONS:MPGSQL}
-USES+= pgsql
-CONFIGURE_ARGS+= --with-postgresql=${LOCALBASE}
-.endif
+PGSQL_USES= pgsql
+PGSQL_CONFIGURE_ON= --with-postgresql=${LOCALBASE}
-.if ${PORT_OPTIONS:MIPV6}
-CONFIGURE_ARGS+= --enable-ipv6
-.endif
+IPV6_CONFIGURE_ON= --enable-ipv6
+
+.include <bsd.port.options.mk>
.if exists(${LOCALBASE}/include/pth/pthread.h)
IGNORE= pth with soft syscalls is installed, please reinstall pth from devel/pth-hard
@@ -110,10 +103,12 @@ post-install:
@${TOUCH} ${STAGEDIR}${PREFIX}/include/jabber/platform-settings
(cd ${WRKSRC} && ${INSTALL_DATA} jabber.xml.dist \
${STAGEDIR}${PREFIX}/etc/jabber.xml.sample)
+
+post-install-DOCS-on:
@${MKDIR} ${STAGEDIR}${DOCSDIR}
.for i in AUTHORS ChangeLog INSTALL NEWS README README.SQL README.config \
README.filespool README.karma README.protocols TODO UPGRADE mysql.sql
- (cd ${WRKSRC} && ${INSTALL_DATA} ${i} ${STAGEDIR}${DOCSDIR})
+ ${INSTALL_DATA} ${WRKSRC}/${i} ${STAGEDIR}${DOCSDIR}
.endfor
.include <bsd.port.mk>