aboutsummaryrefslogtreecommitdiff
path: root/net-im/jabberd
diff options
context:
space:
mode:
authorDmitry Sivachenko <demon@FreeBSD.org>2003-12-30 12:03:43 +0000
committerDmitry Sivachenko <demon@FreeBSD.org>2003-12-30 12:03:43 +0000
commit748533e26b9307a8d40a09a74cebe74157a2206d (patch)
tree32572251824dabe8fea3e76ec95b0f2b249bc634 /net-im/jabberd
parent58fb1d85c3d5848afdb8327634af18a86ed42a40 (diff)
downloadports-748533e26b9307a8d40a09a74cebe74157a2206d.tar.gz
ports-748533e26b9307a8d40a09a74cebe74157a2206d.zip
Notes
Diffstat (limited to 'net-im/jabberd')
-rw-r--r--net-im/jabberd/Makefile44
-rw-r--r--net-im/jabberd/files/patch-configure9
2 files changed, 32 insertions, 21 deletions
diff --git a/net-im/jabberd/Makefile b/net-im/jabberd/Makefile
index 739f06a1149a..654e27fd84ae 100644
--- a/net-im/jabberd/Makefile
+++ b/net-im/jabberd/Makefile
@@ -16,29 +16,49 @@ MAINTAINER= demon@FreeBSD.org
COMMENT= Online presence and instant messaging server
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-openssl=/usr \
- --with-libiconv-prefix=${LOCALBASE}
+CONFIGURE_ARGS= --with-libiconv-prefix=${LOCALBASE} \
+ --enable-storage='${STORAGE}' \
+ --enable-authreg='${AUTHREG}'
-.if defined(WITH_BDB)
-LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
-CONFIGURE_ARGS+=--with-berkeley-db=${LOCALBASE} \
- --enable-storage=db \
- --enable-authreg=db
-LDFLAGS+= -ldb41
-CFLAGS+= -I${LOCALBASE}/include/db41
+STORAGE+= fs
+AUTHREG+= anon pipe
+
+.if defined(WITH_PGSQL)
+LIB_DEPENDS+= pq.3:${PORTSDIR}/databases/postgresql-client
+CONFIGURE_ARGS+=--with-pgsql=${LOCALBASE}/include:${LOCALBASE}/lib
+STORAGE+= pgsql
+AUTHREG+= pgsql
.endif
.if defined(WITH_MYSQL)
USE_MYSQL= yes
-CONFIGURE_ARGS+=--with-mysql=${LOCALBASE} \
- --enable-storage=mysql \
- --enable-authreg=mysql
+CONFIGURE_ARGS+=--with-mysql=${LOCALBASE}/include/mysql:${LOCALBASE}/lib/mysql
+STORAGE+= mysql
+AUTHREG+= mysql
+.endif
+
+.if defined(WITH_BDB)
+LIB_DEPENDS+= db41.1:${PORTSDIR}/databases/db41
+CONFIGURE_ARGS+=--with-berkeley-db=${LOCALBASE}/include/db41:${LOCALBASE}/lib
+STORAGE+= db
+AUTHREG+= db
.endif
.if defined(WITH_LDAP)
USE_OPENLDAP= yes
+CONFIGURE_ARGS+=--with-ldap=${LOCALBASE}/include:${LOCALBASE}/lib
+AUTHREG+= ldap
.endif
MAN8= c2s.8 jabberd.8 resolver.8 router.8 s2s.8 sm.8
+pre-everything::
+ @${ECHO}
+ @${ECHO} "You can build jabberd with the following options:"
+ @${ECHO} "WITH_PGSQL use PostgreSQL for storage and authentication"
+ @${ECHO} "WITH_BDB use Berkeley DB for storage and authentication"
+ @${ECHO} "WITH_MYSQL use MySQL for storage and authentication"
+ @${ECHO} "WITH_LDAP use LDAP for authentication"
+ @${ECHO}
+
.include <bsd.port.mk>
diff --git a/net-im/jabberd/files/patch-configure b/net-im/jabberd/files/patch-configure
index 39311cb7a000..2ce43d89bc23 100644
--- a/net-im/jabberd/files/patch-configure
+++ b/net-im/jabberd/files/patch-configure
@@ -1,14 +1,5 @@
--- configure.orig Mon Dec 29 16:07:44 2003
+++ configure Mon Dec 29 16:07:56 2003
-@@ -23698,7 +23698,7 @@
- fi;
-
- if test "$places" = "search"; then
-- places="std /usr/local/include/db4:/usr/local/lib /usr/local
-+ places="std /usr/local/include/db41:/usr/local/lib /usr/local
- /usr/local/BerkeleyDB.4.1 /usr/include/db4:/usr/lib
- /sw/include/db4:/sw/lib"
- fi
@@ -23734,7 +23734,7 @@
;;
esac